locked
Drive Mapping and Folder Redirection: Inconsistent and delayed server communication RRS feed

  • Question

  • I am doing performance testing in preparation to deploy GPO's that will both map drives and handle folder redirection.  The drives are mapped based on security groups using user configuration preferences with Win 2008 R2.  The drive mappings utilize a DFS namespace and have 2 file servers to choose from.  Sites are set up with their respective subnets, and drives do pick the correct server depending on what site I am at.

    The environment consists of Windows 2003 R3, 2008 R2, XP SP3, 7 SP1
    The testing is taking place with a local (same site) file server, and test folders that are empty to test if folder redirection is working as expected.  Files are stored locally when offline by default.

    Expected result:  Mapped drives should be applied instantly and offline files stored locally or new files should be synchronized with server immediately
    Problem: XP works fine, mapped drives appear and are accessible virtually instantly and synchronization takes place immediately. Win 7 is showing mixes results.

    Procedure1:  recording wait time for mapped drives
    Log into Win 7 machine with user1 (different set of shared drives from user 2)
    As soon as desktop is displayed, start timer
    Access shared drive as soon as possible
    Record time when drives are accessible 

    Results for User1
    1- 0 (Shared drives were accessible virtually instantly)
    2- 1:40 (Shared drives became accessible after 1 min 40 secs. Time was measured in 5 second intervals)
    3- 0
    4- 1:45
    5- 0
    6- 1:45
    7- 0
    8- 1:45
    9- 0
    10- 0
    11- 0
    12- 1:45

    It looked like there was a pattern, but the alternating wait times seems to be random...slightly favouring no wait time

    Results for User2 on the same machine
    1- 0
    2- 0
    3- 1:45
    4- 0
    5- 0
    6- 0
    7- 1:45
    8- 0

    This time the results favour no wait time.

    Procedure 2: Synchronizing between different OS’s and machines User1

    - Log onto Virtual 7 machine
    - Create a folder on desktop and documents
    - Shutdown
    - Login to Virtual XP Machine
    - Confirm previously created folders appear on the new machine (record time)
    - Shutdown

    Results:
    Win 7 to server: 1:40
    Server to XP: virtually instant

    The same test above, but from Win XP to Win 7 shows the same times but in reverse.  As shown above, this test is sometimes completed with no wait time as well. 

    From this I discovered the folder redirection was not working as expected either until about 1 min 40ish seconds passed (sometimes).  It appears the file server is unreachable during this waiting period despite consistent network connectivity.  If I create the create a folder and shut down before the mapped drives work, the new folder will not sync with the server. After the mapped drives become accessible, new files instantaneously sync with the server in Win 7.  Unlike Windows 7, XP doesn't seem to have the same problem communicating with the server, and consistently provides 0 wait time.

    Any idea why I need to wait for the server to wake up only some of the time, and only for Win 7?  Perhaps it has something to do with having 2 file servers to choose from... but when the drives are eventually mapped, it consistently picks the correct server, so I'm baffled :(


    One click to automate them all!


    • Edited by Rawrasaurus Tuesday, July 19, 2011 7:07 PM Did additional testing which classified the question
    Tuesday, July 19, 2011 5:34 PM

All replies

  • Hi,

    If you use GPP to deploy the mapped drive, the policies will spent some time to be applied.

    I do not know how you open the mapped drive,  But I need to advise that the GPP can not be applied to Windows XP unless it had already installed CSE.

    For more information, please refer to the article below.

    http://technet.microsoft.com/en-us/library/cc731892(WS.10).aspx 

     


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread. ”
    Thursday, July 21, 2011 7:16 AM
  • Hi Juke,

    I understand that in scenarios where a server is busy, or the server being accessed is remote, it can take some time for the mapped drives to become available.  However, as you can see from the testing, majority of the time they are applied virtually instantly.

    By Virtually instantly, I mean that as soon as the desktop appears, I navigate to My Computer, scroll down, and double click on the mapped drive (which is applied through GPP), even if it says it is currently disconnected.  I continue to do this with intervals of 5 seconds until the drive is available.  When the drive becomes available, all other drives are also available, and the desktop synchronizes with the server automatically VIA folder redirection.  Essentially,  when I double click on the mapped drive and it has become available, it is at that point that I know the server is responding correctly.

    The problem is outlined in the tests shown above.  Sometimes, as you pointed out, it takes time for the mapped drives to become available.  Other times, but only for Win 7, I have to wait 1 minute 45 seconds (1:45).  I never have to wait for the drives to become available for Windows XP under the same test conditions (all same computer, same server, same site, 2 different user profiles).

    Note: CSE is installed, otherwise it wouldn't work at all for XP.  XP is not the issue here, it works great. Win 7 has the occasional wait times, not XP.

    Cheers,
    Brian 


    One click to automate them all!
    Thursday, July 21, 2011 12:14 PM
  • Hi,

    I think you have not fully understood what I meant. According to your description, I suspect that the network is not ready for accessing when you log on the computer. Please check the networking status when you need to spend time to wait.


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread. ”
    Friday, July 22, 2011 6:02 AM
  • Have you tried the following GPO?

    Computer Configuration>Administrative Templates>System>Logon>Always wait for the network at computer startup and logon

    The following blog on Windows 7/Vista and Offline Files on a DFS maybe of use.

    http://blogs.technet.com/b/netro/archive/2011/01/24/using-offline-files-on-dfs-shares-all-shares-are-going-offline.aspx

     

    Friday, July 22, 2011 6:28 AM
  • Hello Juke,

    When I was forced to wait, leading up to the 1 min 40-50 second mark I tested network connectivity and got the following results:
    - Good:Network activity is good, and I can access the internet
    - Good: I am able to ping both file servers which are synchronized through DFS
    - Good: I can navigate to mapped folders via file server name: \\Server1 or Server2\Files\GroupShares\Folder
    - Bad: Unable to access the folder path using the namespace: \\Domain\Namespace\Facility\Folder 
    Note: The domain name when mapping, and in this example does not include ".local" since it was giving me problems earlier when trying to get the drives to map to Win 7 using the GPO preferences (but with .local it worked on XP) 

    With this in mind, it is very likely that if I was not using a DFS namespace and mapping directly to the sever, this problem probably would not exist.  The real question is why XP does not have the problem when 7 should be able to work with DFS namespaces better than XP.

    After the usual wait time I can manually navigate to the share using the namespace

    Cheers,
    Brian

    Going to try CPFC's suggestion next 
    One click to automate them all!


    • Edited by Rawrasaurus Friday, July 22, 2011 1:19 PM Additional info
    Friday, July 22, 2011 1:03 PM
  • Hi CPFC,

    I tested out your suggestion, and got unusual, and unexpected results.  The GPO was originally designed for XP, and even in the Win 2008 documentation, it makes no mention of Win 7. This may explain so that may explain why the results are odd.  It also mentioned that it could take up to 2 restarts and logging for the GPO to apply.  This can be observed in the tests below:

    1: Regular login time, Desktop present, Mapped drives immediately present 
    2: Regular login time, Desktop present, Mapped drives immediately present  (2 times in a row is not uncommon for everything to work well.  From testing, I'd say roughly 70% of the time, Drives map immediately and Redirected files sync without a wait time)
    3: Long login time, Desktop files not present, warning saying drives cannot be mapped, BUT they have actually mapped when I go to click on them (At this point I assume the GPO has taken affect
    4: Same thing as run #3, but I try creating a folder. It takes unusually long to register the new folder.  I check the server and it has synchronized properly and appears with the other desktop files that should be on the client's desktop (but never appear even after waiting for 7 minutes)
    5-12: Same results as the third run, no desktop icons except the recycling bin

    At this point I deleted the GPO link
    13 and 14: same as run #3 
    15: GPO affects are gone, and things are normal again.  

    Strange results, but needless to say, it didn't work :(

    Cheers,
    Brian  


    One click to automate them all!
    • Edited by Rawrasaurus Friday, July 22, 2011 2:55 PM light editing
    Friday, July 22, 2011 2:47 PM
  • Hi,

    The following link may help.

    http://support.microsoft.com/kb/983620 

    Also, you may disable SMBv2 for a test.

    If the issue still persists, it is necessary to enable network monitor, and even enable the trace to perform analysis/troubleshooting. However, please understand that it could be time consuming to analyze these trace logs. Also, forum is not the best resource to troubleshoot this kind of issue. I’d like to recommend that you contact Microsoft Customer Support Service for assistance. The support professionals there can provide one-one instant support for you so that the issue can be resolved more efficiently.

    To obtain the phone numbers for specific technology request please take a look at the web site listed below:
    http://support.microsoft.com/default.aspx?scid=fh;EN-US;PHONENUMBERS


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread. ”
    Tuesday, July 26, 2011 9:54 AM