Internet Explorer GPO RRS feed

  • Question

  • We have an issue where our IE11 installations that are configured through Group Policy, can no longer play HTML5 videos from YouTube or similar sites as mentioned in the following blog:

    As described in the post, once custom security settings are applied to the Internet Zone, HTML5 video is disallowed. The following registry key can be changed to enable it HKCU\Software\Microsoft\Windows\CurrentVersion\Internet Settings\Zones\3 2701 by changing the value from 3 to 0. 

    The issue is that when it is setup to do so with group policy preferences, the setting does not change, even though it is the winning policy. If I manually change it, everything works until the next policy refresh interval. 

    Does anyone have any thoughts on this outside of reverting to the default security settings for that zone?

    Monday, May 16, 2016 3:55 PM

All replies

  • Hi unicron19,

    I want to confirm with you that what is “the next policy refresh”. It means that reboot or use the command “gpupdate /force”. Please try use the command “gpresult” to check all policy settings in effect for a specific user or computer. Please check the link below.

    Hope it will be helpful to you.

    Please mark the reply as an answer if you find it is helpful.

    If you have feedback for TechNet Support, contact

    Tuesday, May 17, 2016 12:10 PM
  • That is correct. Next reboot or using "gpupdate /force". I did use gpresult and as stated, the winning policy is the one that I created to change the key. Just to make sure the policy was indeed working, I also added a new "TEST" key.  I am getting that key with no problem. It is just changing the 2701 key being the issue.
    Tuesday, May 17, 2016 5:06 PM
  • Hi unicron19,

    Glad to hear that you have solved the problem and thank you for sharing it here. Please remember to mark the replies as answers if they help, it will be helpful to other community members who have same questions.

    Best regards

    Carl Fan

    Please mark the reply as an answer if you find it is helpful.

    If you have feedback for TechNet Support, contact

    Wednesday, May 18, 2016 7:15 AM
  • Perhaps my last reply was not quite clear. I am still having the issue. I was pointing out that I did do a "gpresult" and the winning policy is the one for the registry key. However, it really is not changing the key because our custom security settings in IE are changing it back. I cannot figure out a way around this other than using default security settings in the Internet Zone, which at this point, I have no idea what that could potentially break in our enterprise.
    Wednesday, May 18, 2016 2:50 PM
  • Did you manage to fix the issue? I am fighting the same problem at the moment.
    Tuesday, May 24, 2016 11:38 AM
  • Unfortunately, I have not. Not sure what to do at this point other than use default settings in that zone, but I have no idea what it will impact in our company. Very hesitant to do that.
    • Edited by PaulBach Tuesday, May 24, 2016 1:49 PM
    Tuesday, May 24, 2016 1:49 PM
  • I would suggest you not to do that. Last week it not went well when I did the same in our environment. Still looking to find a solution... I am wondering how to check what setting/GPO is winning
    Tuesday, May 24, 2016 2:11 PM
  • I did a gpresult /h ReportName.html. It will export the resulting set of policies to an html file which you can then open with a browser. It will tell you the winning policy. In my case, it was the registry policy that I created, but appears to not work.
    Tuesday, May 24, 2016 5:14 PM
  • I will try to create a new policy with higher inheritance, just only with this registry preference and see if it will be applied
    Wednesday, May 25, 2016 7:42 AM
  • hello

    i have exactly the same behavior than unicron descibes.

    there is something special with this value, the logs states the value is correctly written but when you check is not.

    i let you now if i find something


    Wednesday, May 25, 2016 9:37 AM
  • Ended up opening a ticket with Microsoft and have it fixed in my environment now. Instead of placing the registry key under HKCU\Software\Microsoft\Windows\CurrentVersion\Internet Settings\Zones\3, create the key under HKCU\Software\Policies\Microsoft\Windows\CurrentVersion\Internet Settings\Zones\3. Have had this in place for a couple of days now and works just fine.

    • Proposed as answer by Dude1963 Friday, May 4, 2018 9:45 AM
    Tuesday, June 7, 2016 3:37 PM
  • Hi PaulBach,

    Thank you for share your experience and solution here. It will be very beneficial for other community members who have similar questions.

    Best regards,

    Carl Fan

    Please mark the reply as an answer if you find it is helpful.

    If you have feedback for TechNet Support, contact

    Wednesday, June 8, 2016 7:26 AM
  • We applied solution from Dieter Boonens comment to blog and it worked.

    Solution is described in comment to blog and basicaly requires editing file %logonserver%\sysvol\%YourDomain%\Policies\{%Guid_of_your_InternetExplorerGPO%}\User\Preferences\InternetSettings\InternetSettings.xml.

    Wednesday, November 2, 2016 10:08 AM
  • Excellent - this did the trick for me. Added DWORD 2701 Value 0 

    After gpupdate /force YouTube videos worked like a charm.

    thanks a lot.

    Friday, May 4, 2018 9:47 AM