locked
*.exe files cannot be run from a shared folder RRS feed

  • Question

  • I have a Microsoft Virtual PC running Windows 7 32bit on a host running Windows 7 64bit. In the virtual PC, the C: drive from the host is shared as Z:. I can see the files on Z: from the VM, I can copy the files from Z: to the virtual PC, but I cannot run *.exe files directly from Z:. An error message appears reporting a network problem.

    The error code is 0x800704b3
    The network path was either typed incorrectly, does not exist, or the network provider is not currently available.

    Does anyone have an idea what could be wrong?

    Wednesday, July 27, 2011 2:01 PM

All replies

  • Hi,

     

    This is a security software issue, could you please diable all anti-virus,malware, anti-spyware applications on both the host and in the Virtual Machine and tell me if it solves the issue.

     

    _______________________________________________

    Regards, Taylor Gibb

     

    MCITP: Enterprise Admin

    MCITP: Server Admin

    MCITP: Enterprise Desktop Support Technician on Windows 7

    MCITP: Enterprise Desktop Administrator on Windows 7

    MCSA

    MCTS x 5

    MOM: Microsoft Office Master Specialist

    Microsoft Office Expert

    Microsoft Office Specialist

     

     

     

    Wednesday, July 27, 2011 3:31 PM
  • Hi,

    thanks for the tip, unfortunately this is not so easy, both host and virtual machines are in the company's network and the policy does not allow disabling the antivirus and other software of this kind.

    But in the meantime I have found a solution although I don't fully understand what happened:

    In the properties of the shared folder (Z:) it was designated as Disconnected Network Drive (and still it was possible to see and access the files in a file manager. But in a command prompt there was a problem. The cd command worked, but dir not).

    After changing the networking option to Local Only, Z: changed to Network Drive and the exe file could be started. Interestingly enough, after changing the networking option back to full connectivity, the Z: drive remained as Network Drive and everything worked.

    Even after shutting down and restarting the virtual machine, the Z: drive is now fully functional.

    Maybe I should add that the virtual machine is in a workgroup, not in the domain.

    Anyway, thanks again.

    Pavel

     

     

    • Proposed as answer by zhen tan Friday, July 29, 2011 2:15 AM
    Thursday, July 28, 2011 8:24 AM