locked
Incredibly slow package stream/load speed from Management Server to TS/RDS Client RRS feed

  • Question

  • Hi everyone, I have a peculiar situation that is baffling me and driving me insane and was hoping the good folks on these forums could help me :)

    My environment : 6 RDS Host Servers Windows 2008 R2(there are 6, but even if all but 1 are offline, the problem I will describe below still occurs) running App-V Client x64 for Remote Desktop Services.
    1 Windows 2008 R2 App-V Management Server (version 4.5) that is also running a local copy of SQL Server Express 2008 SP1.  All apps are stored locally on the App-V Management Server.
    All the servers are on a 1 GB LAN.

    Problem : Whenever performing a refresh/load the transfer speed from the Management Server to the RDSHS Client is incredibly slow.  Standard file transfers and access occur without any problems and at the expected speed.  But for App-V package transfer, we're talking like 0.1% network utilization.  Consequently even relatively small packages take forever to transfer and cache.  Since these are RDSHS clients, all apps will always be fully cached on the client server.  Aside from the slow transfer speed, everything works fine and the logs don't show any type of error.  Does anyone know how I can make it so the transfer from the Management Server to the Client will fully utilize the available bandwidth?


    Thanks.
                             
    Wednesday, March 10, 2010 7:33 PM

Answers

All replies

  • Hello,

    I would start looking at moving away from SQL Express.

    next step would be to look at a network capture to see whats going on between app-v mgt server and a client to determine if there is something that needs to be done on the network or on the servers.

    /Znack
    Wednesday, March 10, 2010 7:54 PM
  • I checked the network and everything is fine there.  I also went ahead and rebuilt the app-v management server using windows 2003 and installed full version of sql server studio 2005 on it.  Same result.  Incredibly slow snail-pace transfer of App-V only.  Regular file transfers occur just fine.

    Friday, March 12, 2010 12:31 AM
  • Hello,

    Look into the receiving client - as you have determined that network and servers are OK - perhaps the error is at the receiving end?

    /ZNack
    Friday, March 12, 2010 8:11 AM
  • What you could do in your data center scenario is to move from RTSP(s) towards HTTP(s) or CIFS/SMB to transfer the SFT file. Both protocols are more "egocentric" then RTSP(s) and should perform better.

    Howeverr, for RDS servrs you should make sure that "streaming" never happens during regular business hours. Instead, use RDS maintenance windows to fill the App-V cache.

    Falko
    Friday, March 12, 2010 11:54 AM
    Moderator
  • hi kirk, i've never really messed with the VAS option, only VMS.  Does the VAS have options for licensing, usage, and update controls that the VMS does?
    Saturday, March 13, 2010 1:53 AM
  • Hello,

    Not really sure where the acronym VAS was brought into the game, but;

    Virtual Application Server was replaced during the 4.5 release with App-v Management Server and App-v Streaming Server.

    The management server is what have the most similiar features as the virtual application server had...

    /Znack
    Saturday, March 13, 2010 10:06 AM
  • We had a "somewhat"' similiar issue with a couple of Terminal Server machines that turned out to be issues with Windows 2008 and some Broadcomm network drivers.  Not sure of your hardware configuration, but a good Wireshark trace should at least illuminate what is going on with the network and your machine.
    Monday, March 15, 2010 12:47 AM
  • Hi Redparadox, your answer is disturbing to me :(.  I am using Win 2008 R2 and unfortunately Broadcom NICs on HP Blade Servers :(.  I'm using the latest drivers from HP.  Do you have a specific driver perchance that worked for you?

    Monday, March 15, 2010 4:04 PM
  • I looked at the servers and the driver we are now using is:

    Driver Provider: Broadcom Corporation
    Driver Date: 1/28/2009
    Driver Version: 4.8.5.0

    Hope this helps.

    • Proposed as answer by znack Tuesday, November 22, 2011 8:13 AM
    • Marked as answer by Aaron.ParkerModerator Tuesday, November 29, 2011 1:19 PM
    Monday, March 15, 2010 10:07 PM
  • Also see this article: http://blogs.technet.com/b/gladiatormsft/archive/2011/11/28/the-default-block-size-of-64kb-in-app-v-4-6-and-later-may-cause-slow-streaming-with-certain-network-configurations.aspx

    This forum post is my own opinion and does not necessarily reflect the opinion or view of Microsoft, its employees, or other MVPs.
    Tuesday, November 29, 2011 1:20 PM
    Moderator
  • Also see this article: http://blogs.technet.com/b/gladiatormsft/archive/2011/11/28/the-default-block-size-of-64kb-in-app-v-4-6-and-later-may-cause-slow-streaming-with-certain-network-configurations.aspx

    This forum post is my own opinion and does not necessarily reflect the opinion or view of Microsoft, its employees, or other MVPs.

    We had the same problem with some of our 2008 RDS servers. Initially we discovered the problem when the communication was slow between the RDS and 2003 servers. We then changed the parameter autotuning=normal (as it says in the blog post) and it helped with the 2003 server problem. Then we noticed, that the App-V apps started to load slowly from the App-V management server. By setting the autotuning=restricted helped us with both problems. There is no need to boot the server, the change will be instant.

    netsh int tcp set glo autotuning=restricted

    Thursday, December 22, 2011 1:36 PM