locked
FIM2010 R2 SP1 and SCSM 2012 RRS feed

  • Question

  • Hello folks!

    Im setting up a lab environment. I have installed SCSM DW and console, did pritty much what Carol did in this blogpost: http://www.wapshere.com/missmiis/installing-reporting-for-fim-r2

    At the stage where Im gonna add FIM Reporting I get a error saying I have to install the KB2561430. This i apparently a hotfix for SCSM 2010 SP1. So, Im not able to install this hotfix in my environment since im running SCSM 2012.. Any ideas ? Im stuck.


    Regards, Remi

    Tuesday, January 29, 2013 7:26 PM

Answers

  • Possible solution is:

    FROM MS:

    There’s been some chatter on this topic internally and I have two pieces of information to share. Firstly a mismatch of versions between SCSM and SCDW can cause this check to fail, so be sure that both the SM instance(s) and the DW are running the same build.
    If the check still fails there is a workaround. A command line installation will work. If you have installed FIM and are enabling reporting be sure to utilise the EXISTINGDATABASE=1 option. If it’s a clean installation just do it as you would normally and the check will be skipped and the installation will succeed.
    • Proposed as answer by Alan Schmarr Thursday, February 28, 2013 7:29 PM
    • Marked as answer by Remi Vandemir Friday, March 1, 2013 10:05 AM
    Wednesday, February 27, 2013 11:29 PM

All replies

  • I got the same problem.  I thought that FIM R2 with SP1 supports SCSM 2012 as written:

    FIM Reporting

    • Support for Windows Server 2012 has been added.
    • Support for SQL Server 2012 has been added.
    • Support for SCSM 2012 has been added.

    http://technet.microsoft.com/en-us/library/jj863246(v=ws.10).aspx

    What on earth is going on here Microsoft? We're all siting ducks here.

    Wednesday, February 6, 2013 8:29 PM
  • Anyone from Microsoft who can help us here??
    Sunday, February 10, 2013 8:47 PM
  • Hi,

    Did you install SCSM 2012 SP1? I just want to see if it might be that FIM 2010 R2 SP1 only supports SCSM 2010 RTM. I'm getting the same issue in my lab. I've installed SCSM 2012 SP1.

    Wednesday, February 20, 2013 12:26 PM
  • Correction SCSM 2010 RTM = SCSM 2012 RTM
    Wednesday, February 20, 2013 12:32 PM
  • Hi,

    Looks like in the release notes http://technet.microsoft.com/en-us/library/jj863245(v=ws.10).aspx You should do an upgrade of SCSM. Just worried that it doesn't work from the install files on a fresh SCSM 2012 and this means you need to install on Windows 2008 R2 first, Then upgrade SCSM to 2012 and then upgrade to Windows 2012 OS.

    I haven't tested the above yet but this is not a good solution.

    Going to see if I can find a Microsoft resource to assist.

    Wednesday, February 20, 2013 12:59 PM
  • Possible solution is:

    FROM MS:

    There’s been some chatter on this topic internally and I have two pieces of information to share. Firstly a mismatch of versions between SCSM and SCDW can cause this check to fail, so be sure that both the SM instance(s) and the DW are running the same build.
    If the check still fails there is a workaround. A command line installation will work. If you have installed FIM and are enabling reporting be sure to utilise the EXISTINGDATABASE=1 option. If it’s a clean installation just do it as you would normally and the check will be skipped and the installation will succeed.
    • Proposed as answer by Alan Schmarr Thursday, February 28, 2013 7:29 PM
    • Marked as answer by Remi Vandemir Friday, March 1, 2013 10:05 AM
    Wednesday, February 27, 2013 11:29 PM
  • Hi,

    Yes thanks I've also logged a call and did a quick wiki on installing everything on Windows 2012, SQL 2012 and SCSM 2012 SP1:

    http://social.technet.microsoft.com/wiki/contents/articles/16173.how-to-install-fim-2010-r2-sp1-on-windows-server-2012-scsm-2012-sql-2012-and-sharepoint-2013.aspx

    Thursday, February 28, 2013 7:29 PM
  • Could you share what the command line install would be if you were trying to do a change rather than a new install to add the reporting feature?
    Tuesday, March 19, 2013 6:11 AM
  • Just add EXISTINGDATABASE=1 in your command line
    Tuesday, March 19, 2013 7:54 AM
  • When I try and install it via command line I get this error 'another version of this product is already installed'. I currently have the portal and fim service installed and trying to add the third part - reporting. Does this look like the correct command line?

    msiexec /i "<D:\Service and Portal\Service and Portal.msi>" ADDLOCAL=CommonServices,WebPortals SQMOPTINSETTING=0 SQLSERVER_SERVER=wgsql3 SQLSERVER_DATABASE=FIMService EXISTINGDATABASE=1 MAIL_SERVER=smtp.walshgroup.com MAIL_SERVER_USE_SSL=1 MAIL_SERVER_IS_EXCHANGE=1 POLL_EXCHANGE_ENABLED=1   /L*v C:\fimservicelog.txt

    Wednesday, March 20, 2013 2:25 PM
  • I ran into this problem today in my Lab.

    From my testing, in order to install FIM Reporting with SCSM 2012, you can only install the Reporting Services from the base "FIM 2010 R2 SP1" installation media via command-line before applying any hotfixes.

    If you apply a hotfix to FIM, then running a change-mode install will either tell you that "another version of this product is already installed" or prompt for the "Service & Portal" installation media (and not the original install media).

    Seems to be the exact opposite of what you want to do according to the hotfix information [support.microsoft.com] described below:


    FIM Reporting

    If you install FIM Reporting on a new server that has Microsoft System Center 2012 Service Manager Service Pack 1 installed, follow these steps:
    1. Install the FIM 2010 R2 SP1 FIM Service component. To do this, clear the Reporting check box.
    2. Install this hotfix rollup to upgrade FIM Service to build 4.1.3559.0.
    3. Run the change-mode installation for FIM Service, and then add Reporting.

    *EDIT* Turns out I accidently mounted a PRE-R2 install media when running the change-mode install. With the right media mounted, I was able to install Reporting as described above.
    Wednesday, July 16, 2014 1:55 AM
  • Hi,

    Been sitting with the same problem this week, and the Unattended mode did not work for me either. The only thing that worked was upgrading FIM to latest build 4.1.3559.0. Then FIM Reporting installed.

    But now, since our Datawarehouse and SQL servers are separate, the FIMPostInstallScriptsForDataWarehouse.ps1 fails. Still looking for answers to this one.

    Wednesday, July 16, 2014 9:09 PM
  • Hi Shim!

    Whats the error?


    Regards, Remi www.iamblogg.com

    Wednesday, July 16, 2014 9:41 PM
  • Everytime I ran this, the MSIEXEC help popped-up, I even retyped everything in case the copy/paste was an issue. This is taken from the FIM Reporting deployment guide (and was updated to my path setup & domain of course):

    msiexec /q /i "D:\Service and Portal\Service and Portal.msi" ADDLOCAL=CommonServices,WebPortals SQMOPTINSETTING=0 SQLSERVER_SERVER=APP1 SQLSERVER_DATABASE=FIMService EXISTINGDATABASE=1 MAIL_SERVER=EX1.corp.contoso.com MAIL_SERVER_USE_SSL=0 MAIL_SERVER_IS_EXCHANGE=1 POLL_EXCHANGE_ENABLED=1 CERTIFICATE_NAME=ForefrontIdentityManager SERVICE_ACCOUNT_NAME=FIMService SERVICE_ACCOUNT_PASSWORD=abc123*2k SERVICE_ACCOUNT_DOMAIN=CORP SERVICE_ACCOUNT_EMAIL=FIMService@corp.contoso.com SERVICE_MANAGER_SERVER=APP2 SYNCHRONIZATION_SERVER=FIM1 SYNCHRONIZATION_SERVER_ACCOUNT=CORP\FIMMA SERVICEADDRESS=FIM1 SHAREPOINT_URL=http://localhost REGISTRATION_PORTAL_URL=https://passwordregistration.corp.contoso.com FIREWALL_CONF=1 SHAREPOINTUSERS_CONF=1 REQUIRE_REGISTRATION_INFO=1 REGISTRATION_ACCOUNT_NAME=FIMPassword REGISTRATION_ACCOUNT_DOMAIN=CORP REQUIRE_RESET_INFO=1 RESET_ACCOUNT_NAME=FIMPassword RESET_ACCOUNT_DOMAIN=CORP  /L*v C:\fimservicelog.txt

    cheers

    Wednesday, July 16, 2014 10:21 PM
  • Shim Kwan,

    I found a couple of issues with above cmd line. From http://technet.microsoft.com/en-us/library/hh322863(v=WS.10).aspx:

    You have parameter REQUIRE_REGISTRATION_INFO, the actual parameter is REQUIRE_REGISTRATIONPORTAL_INFO. You also have parameter REGISTRATION_ACCOUNT_NAME, the actual parameter is REGISTRATION_ACCOUNT. You have REGISTRATION_ACCOUNT_NAME, it should be REGISTRATION_ACCOUNT(this should be domain\account). You have RESET_ACCOUNT_NAME, it should be RESET_ACCOUNT(also domain\account format). You have REGISTRATION_ACCOUNT_DOMAIN and also RESET_ACCOUNT_NAME, neither of these exist or should be necessary as the actual account name parameters use domain\account format.

    This what I have now:

    msiexec /q /i "D:\Service and Portal\Service and Portal.msi" ADDLOCAL=CommonServices,WebPortals SQMOPTINSETTING=0 SQLSERVER_SERVER=APP1 SQLSERVER_DATABASE=FIMService EXISTINGDATABASE=1 MAIL_SERVER=EX1.corp.contoso.com MAIL_SERVER_USE_SSL=0 MAIL_SERVER_IS_EXCHANGE=1 POLL_EXCHANGE_ENABLED=1 CERTIFICATE_NAME=ForefrontIdentityManager SERVICE_ACCOUNT_NAME=FIMService SERVICE_ACCOUNT_PASSWORD=abc123*2k SERVICE_ACCOUNT_DOMAIN=CORP SERVICE_ACCOUNT_EMAIL=FIMService@corp.contoso.com SERVICE_MANAGER_SERVER=APP2 SYNCHRONIZATION_SERVER=FIM1 SYNCHRONIZATION_SERVER_ACCOUNT=CORP\FIMMA SERVICEADDRESS=FIM1 SHAREPOINT_URL=http://localhost REGISTRATION_PORTAL_URL=https://passwordregistration.corp.contoso.com FIREWALL_CONF=1 SHAREPOINTUSERS_CONF=1 REQUIRE_REGISTRATION_INFO=1 REGISTRATION_ACCOUNT=CORP\FIMPassword REQUIRE_RESET_INFO=1 RESET_ACCOUNT=CORP\FIMPassword   /L*v C:\fimservicelog.txt

    When I ran this in my enviornment, i did not get the popup so I think the incorrect parameters were your issue.

    Thursday, July 17, 2014 3:13 AM
  • I had some typos above when I was describing the differences in parameters. However, the actual command line seems to be the right one, try that and see if you can install reporting this way...............
    Thursday, July 17, 2014 3:15 AM
  • Thank you guys, will certainly try the new format :)
    Thursday, July 17, 2014 3:41 AM
  • When you install FIM Reporting on a new server that has Service Manager 2012 SP1
    installed, follow these steps:


    Install the FIM 2010 R2 SP1 FIMService component. To do this,
    clear the Reporting check box.

    Upgrade the FIMService installation to build 4.1.3451.0.

    Run the change-mode installation for the FIMService, and then
    add Reporting.

    http://blogs.technet.com/b/steady/archive/2013/06/12/fim-2010-r2-sp1-reporting-failure-scsm-2012-sp1-you-must-apply-patch.aspx

    Cordialement, Best Regards, مع أجمل تحياتي ESSALIFI Mohamed Faiçal [MCT-MCSE]. If your question is answered please mark the response as the answer so that others can benefit.

    Tuesday, December 9, 2014 4:21 PM