none
MDT 2012 Update 1 USMT RRS feed

  • Question

  • Quick background.  I have Windows 7 working as a deployed OS.  I can also tell it to Capture and Save the User State, Deploy Windows 7 then put back the User Settings.  Which turned out waaaay easier than I expected.  My next challenge was to see if we could back up the User Settings on a Win XP machine.  Then deploy Windows 7 to a separate machine, and put those XP User settings back on.  This would be ideal as we have people moving from an old XP machine to a new Windows 7 machine.  New Machine. New OS.  The catch now is, I can't get MDT to back up settings to the network.  I followed the directions to set the Network and path in the CS.ini file, and even tried creating the separate task sequence for "capture only", but no file end up in the specified network folder.  If I run a normal deployment and tell it to capture to the network, the progress bar says it's doing it.  But no files :(  If I run the "Capture only" sequence, it doesn't run and all and immediately pops up saying it's done.  Also no files.  Is what I'm wanting possible? And what did I miss to send the capture User State to the network? Below is my cs.ini if it helps.  I edited out the server and passwords.

    Monday, July 29, 2013 9:47 PM

All replies

  • Can you post your logs from the full task sequence attempt (not just the "capture only") to a cloud store somewhere so we can take a look?

    David Coulter | http://DCtheGeek.blogspot.com | @DCtheGeek

    Monday, July 29, 2013 11:59 PM
    Answerer
  • So after more playing around with the capture, I got it to successfully capture following some other suggestions.  I had to use the Client Replace template instead of the Capture template.  Anyway, to follow off that, how can I have the network path pre-filled instead of typing it in each time?  The UDShare path isn't filling the field in the Wizard.  Is there another Keyword to put in the CS.ini file that will fill that?
    Tuesday, July 30, 2013 3:50 PM
  • Just to make sure I'm on the same page, what is the title of the Wizard Pane that you are specifically referring to? 

    Whenever something isn't populating that I think should, I look at the files in \Scripts related to the Wizard Pane.  These are typically named DeployWiz_<pane> (both VBS and XML).  You can review these files and normally get an idea of what variables the scripts are using to prepopulate the Wizard Panes (and adjust or customize if needed).


    David Coulter | http://DCtheGeek.blogspot.com | @DCtheGeek

    Tuesday, July 30, 2013 4:10 PM
    Answerer
  • This is the screen I'm trying to get Pre-filled.  I looked at some of the scripts, and knowing VB, I didn't catch anything that I can use. 

     

    Tuesday, July 30, 2013 4:48 PM
  • Ok, I found this forum thread: http://www.minasi.com/forum/topic.asp?TOPIC_ID=39174

    Basically, looks like it's a bit of a known bug.  If you are already setting the values in CustomSettings.ini, maybe just skip this pane (with SkipUserData=YES).  Otherwise, you may need to modify the DeployWiz_UserData.vbs file.


    David Coulter | http://DCtheGeek.blogspot.com | @DCtheGeek

    Tuesday, July 30, 2013 10:47 PM
    Answerer
  • This example shows a User State Migration using a network share:

    UserDataLocation=NETWORK
    UDShare=\\SRV01\MigData$
    UDDir=%OSDComputerName%

    To skip the Lite-Touch wizard pages Specify whether to capture an image andSpecify whether to restore user data enter this property in your customsettings.ini file:

    SkipUserData=YES

    • Proposed as answer by gbillig Tuesday, July 30, 2013 11:34 PM
    Tuesday, July 30, 2013 11:34 PM