Windows 8 Pro x64 NET framework 3.5 standalone not installing (need Net Framework 3.5 prompt) RRS feed

  • Question

  • Hello i have windows 8 pro x64 but every time i try the offline/standalone net framework 3.5 sp1 installer it prompts me to go download it
    Tuesday, November 20, 2012 5:42 AM


All replies

  • Hello,

    try Dism /online /enable-feature /featurename:NetFx3 /All /Source:YOURWin8CD\sources\sxs /LimitAccess

    Best regards
    Andreas Ernst

    • Proposed as answer by Andre.Ziegler Tuesday, November 20, 2012 3:45 PM
    Tuesday, November 20, 2012 8:35 AM
  • i tried it but it stops on 65.8% and error
    Wednesday, November 21, 2012 10:55 PM
  • Hi,

    have u tried it at another machine. I only have 3 Win8VMS but they work fine... No error as you discribed.

    Are u running the Shell with administrator privileges?

    Best regards
    Andreas Ernst

    Thursday, November 22, 2012 6:11 AM
  • I have seen that error before with larger updates. Try running a Check Disk first and rebooting the machine. If that doesn't work, see if you can remove the incompletely installed package (change /enable-feature to /disable-feature). Reboot and try adding the feature again.

    If that doesn't work, add .NETFramework into your install package so that it is enabled by default. You can find the instructions here:


    • Marked as answer by Juke Chou Tuesday, December 4, 2012 7:57 AM
    Thursday, November 22, 2012 4:23 PM