none
SQL Compact 3.5 for windows ce7 RRS feed

  • Question

  • Hello,

    i have an old project for windows CE6 that uses sql compact 3.5 for the database. I've been asked to install it on a device with windowsCE7, but i'm having some compatibility issues. I found some hotfixes (http://erikej.blogspot.com/2010/08/sql-server-compact-35-sp2-downloadable.html) that should solve the problem, but they are discontinued and no longer available for download. Does anyone know if there's a way to get them?

    Thank you.

    Wednesday, April 10, 2019 10:23 AM

All replies

  • See Description of SQL Server Compact 3.5 Service Pack 2 for all available downloads.

    Olaf Helper

    [ Blog] [ Xing] [ MVP]

    Wednesday, April 10, 2019 11:27 AM
  • Hi, I've had the same problem. The link from Olaf Helper is to an installer that warns about possible OS incompatibility (build 8080). The version or patch that is suppose to be compatible with WinCE7 (build 8088) is not available and nowhere to be found.

    But after ingoring this warning it all works fine - at least in my SQLce device project. If your only compatibility issue is the 'unsupported OS version' warning during install you can ignore that.

    For auto-install purposes I've patched the .CAB installers (SQLce and SQLclient for ARM) so that the 'unsupported OS version' warning is suppressed and the install runs and is done silently.


    Tuesday, June 18, 2019 2:07 AM