none
The Backup Job to tape failed for the following reason (ID3311) RRS feed

  • General discussion

  •  Hi,

     We are running System Center 2012 r2 DPM, MS Server 2012 R2 and HP tape library. Device Manager reports that the medium changer is HP LTO Ultrium-6 drive.  

    DPM recognises the tape library and drives and will perform the basic  operations, importing/exporting/moving/erasing media bit will not backup. The full error code is as follows:    Description: The Backup Job to tape failed for the following reason (ID3311)  Detailed Errors: The operation failed because of a protection agent failure  (ID 998 Details: Access is denied (0x80070005))

    Recommended Action: Run Backup to tape job again...

    I have tried changing the default drivers for the tape unit to the Microsoft LTO driver and it made no difference.

    I have run the job again but it still fails. I have reinstalled the agent on the remote computer and have recreated the protection group, all of which fail.

    Anyone have any suggestions to get this going again?

    Thanks

    Bill


    • Edited by Bills150 Friday, September 16, 2016 5:54 PM
    • Changed type Bills150 Friday, September 16, 2016 5:54 PM
    Wednesday, September 14, 2016 9:07 PM

All replies

  • We've had a case open with Microsoft for 3-4 months now with zero success and a LOT of ridiculous suggestions being made by their side.

    We have Dell TL2000 devices (5-10 of them across 10 different offices) with LTO6 drives in them and they are all reporting the same error you're seeing. All are running on Server 2012 R2.

    We've changed firmware, drivers, uninstalled additional software, upgraded to DPM 2016 RU1, been escalated, etc. Still no success.

    If you happen to have any luck please let me know. I won't hold my breath though.

    Thursday, October 27, 2016 4:21 PM
  • Hi Zmottie -

      I never heard anything back from anyone either. What I have found I have to do is do a full erase on the tape(s) before my backup runs. Once I do that they run with no issues. If I do not erase them then I get the same errors as you.

    Regards

    Bill

    Thursday, October 27, 2016 5:20 PM
  • Are you manually erasing tapes or have you configured DPM to erase tapes before re-using them? 

    Anything you could share about your configuration/settings would be helpful.

    Thursday, October 27, 2016 5:28 PM
  • Hi Zmotie - I am doing a manual erase. Only because I trust it and know I can check it before the backups start. I am not even sure where or how to set it to automatically erase the tapes. I sort of fell into this after being very frustrated a couple months ago and tried the erase and it worked. I wish there was a easier way.

    Thursday, October 27, 2016 5:32 PM
  • Hi,

    We have seen some 3rd party tape drivers cause that error, but you should never have to manually erase a tape, so that is weird.

    Please try using the Microsoft in-box ltotape.sys drivers for the tape drive(s).

    1) Open device manager
    2) Locate the tape drive
    3) Right-click and look at the properties.
    4) Under the DRIVER tab, select UPDATE DRIVER
      a) Select the Install from list or specific location (Advanvced) - next.
      b) Select Don't search. I will choose the driver to install. - next.
      c) Uncheck the Show comtabile hardware checkbox.
      d) Highlight LTO under the manufacturer.
      e) Highlight the LTO tape drive under model - then next.
      f) This should install the Microsoft ltotape.sys driver 5.2.3790.0 or higher.
    5) Rescan the tape library in the DPM console, if a duplicate tape drive appears, then run the following utility.

      c:\program files\Microsoft_dpm_Install_path\DPM\DPM\bin\DPMDriveMappingTool.exe to remap the tape drive and remove the duplicate

    6) Now inventory the library and try a new backup.

    If you want to automate erasing expired tapes - you can download the dpmtapeutil script from here and run the following command.

    This will Schedule tapeerase tape for expired tapes every 1 day at 10:00am

    .\dpmtapeutil.ps1 -search "state=recyclable" -tapeerase –schedule “Enable|daily|1|10:00”

    NOTE: Before using the dpmtapeutil.exe to erase tapes, please implement this registry key.

    Short Erase
    http://technet.microsoft.com/en-us/library/ff634195.aspx

    When a user erases a tape, by default, DPM will do a long erase on that tape.  DPM 2010 has introduced the ability to do a short erase now.  Simply navigate to the following registry location and add the DWORD key with the default vale:

    HKLM\Software\Microsoft\Microsoft Data Protection Manager\Agent
    REG_DWORD:UseShortErase:0x0


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread. Regards, Mike J. [MSFT] This posting is provided "AS IS" with no warranties, and confers no rights.

    Thursday, October 27, 2016 7:47 PM
    Moderator
  • Mike Jacquet if it's at all possible can you (or someone on your team) please review case 116061414289056. 

    The number of changes/changes that the support team had to do was, frankly embarrassing. 

    The next step according to them was to completely wipe our servers, upgrade the OS and reinstall DPM from scratch. That's after uninstalling other products, removing antivirus, adding disk based backups, changing libraries, deleting recovery points, etc etc. Baffling.

    You came up with the answer (using in-box drivers) within seconds. Every time I've had a DPM problem the support has been god awful and I'm fairly certain you have solved every single one of my issues after we've dealt with the 'proper channels' for far too long.

    I suppose I should have learned to simply ask here by now... shame on me!

    Wednesday, December 14, 2016 10:55 PM