locked
SFB for Mac unable to initiate chat when external RRS feed

  • Question

  • SFB for Mac unable to initiate chat when external
    • This only happens on the Mac client.  Mobile clients can initiate chat just fine
    • Tested on 16.16.91.0000 and 16.16.102, both on OSX 10.13.3 High Sierra
    • TMG 2010 SP2 as Reverse Proxy. (Does not happen on F5 LTM Reverse Proxy)
    • 2015 Server March 2018 CU enterprise pool with HLB FE and no directors
    2018-04-05 00:34:17.112 0000700008ecd000 INFO TRANSPORT TransportUtilityFunctions.cpp:1109 <ReceivedResponse>
    POST https://pubdnswebsvchostname.pubdnssipdomain.com/ucwa/v1/applications/414177410848/communication/messagingInvitations?continueContext=%257b%2522Subject%2522%253a%2522
            Conversation%2bwith%2bfirst%2blast%2522%252c%2522RemoteParticipantUri%2522%253a%2522sip%253afirstlast%2540pubdnssipdomain.com%2522%252c%2522ThreadId%2522%253a%2522
            AdOxgmD0pQLvOpJAR5WGZetrbWrbPA%253d%253d%2522%252c%2522Importance%2522%253a0%252c%2522ExchangeItemId%2522%253a%2522AAMkADI4NmRiMTIyLWI0MDYtNGZiMi1
            hNmQzLWNlOTIyYWEyNjFiMQBGAAAAAADVEcEtCRAhQKE5JW5nz8w7BwBxiLxEbDAZT7M5zOieUBQ8AAACw1yXAABxiLxEbDAZT7M5zOieUBQ8AABX%252fj0HAAA%253d%2522%257d
    Request Id: 0x7f835b483d70
    HttpHeader:Cache-Control no-cache
    HttpHeader:Connection close
    HttpHeader:Content-Length 2033
    HttpHeader:Content-Type text/html
    HttpHeader:Pragma no-cache
    HttpHeader:StatusCode 500
    HttpHeader:User-Agent SfBForMac/16.16.91.0000 (Mac OSX 10.13.3)
    
    <!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.0 Transitional//EN">
    <HTML dir=ltr><HEAD><TITLE>The page cannot be displayed</TITLE>
    <STYLE id=L_defaultr_1>A:link {
    	FONT: 8pt/11pt verdana; COLOR: #ff0000
    }
    A:visited {
    	FONT: 8pt/11pt verdana; COLOR: #4e4e4e
    }
    </STYLE>
    
    <META content=NOINDEX name=ROBOTS>
    <META http-equiv=Content-Type content="text-html; charset=UTF-8">
    
    <META content="MSHTML 5.50.4522.1800" name=GENERATOR></HEAD>
    <BODY bgColor=#ffffff>
    <TABLE cellSpacing=5 cellPadding=3 width=410>
      <TBODY>
      <TR>
        <TD id=L_defaultr_0 valign=middle align=left width=360>
          <H1 id=L_defaultr_2 style="FONT: 13pt/15pt verdana; COLOR: #000000"><ID id=L_defaultr_3><!--Problem-->The page cannot be displayed
    </ID></H1></TD></TR>
      <TR>
        <TD width=400 colSpan=2><FONT id=L_defaultr_4
          style="FONT: 8pt/11pt verdana; COLOR: #000000"><ID id=L_defaultr_5><B>Explanation: </B>There is a problem with the page you are trying to reach and it cannot be displayed.</ID></FONT></TD></TR>
      <TR>
        <TD width=400 colSpan=2><FONT id=L_defaultr_6 
          style="FONT: 8pt/11pt verdana; COLOR: #000000">
          <HR color=#c0c0c0 noShade>
    
          <P id=L_defaultr_7><B>Try the following:</B></P>
          <UL>
            <LI id=L_defaultr_8><B>Refresh page:</B> Search for the page again by clicking the Refresh button. The timeout may have occurred due to Internet congestion.
    <LI id=L_defaultr_9><B>Check spelling:</B> Check that you typed the Web page address correctly. The address may have been mistyped.
    <LI id=L_defaultr_10><B>Access from a link:</B> If there is a link to the page you are looking for, try accessing the page from that link.
    
          </UL>
          <HR color=#c0c0c0 noShade>
    
          <P id=L_defaultr_11>Technical Information (for support personnel)</P>
          <UL>
            <LI id=L_defaultr_12>Error Code: 500 Internal Server Error. The request was rejected by the HTTP filter. Contact the server administrator. (12217)
    
            </UL></FONT></TD></TR></TBODY></TABLE></BODY></HTML>
    
    
    </ReceivedResponse>
    2018-04-05 00:34:17.112 0000700008ecd000 INFO TRANSPORT CUcwaRequestBase.cpp:227 Got a failed status code in the http header. Error = E_InternalServerError (E2-3-13), Request = 
    2018-04-05 00:34:17.113 0000700008ecd000 INFO TRANSPORT CUcwaRequestBase.cpp:411 Re-mapping non-UCWA error code E_InternalServerError (E2-3-13) to E_UcwaUnavailable
    2018-04-05 00:34:17.113 0000700008ecd000 INFO TRANSPORT CHttpRequestProcessor.cpp:240 Sending event to main thread for request(0x0x7f835b483d70)
    

    Saturday, April 7, 2018 2:58 PM

Answers

  • Hi rwgeach ,

    If the issue only existed on the TMG 2010 SP2 as Reverse Proxy,please unselect "Verify normalization" in the "Configure HTTP policy for rule" like the following screenshot;


    Best Regards,
    Leon Lu


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnsf@microsoft.com.


    Click here to learn more. Visit the dedicated forum to share, explore and talk to experts about Microsoft Teams.

    Wednesday, April 11, 2018 9:43 AM

All replies

  • Hi rwgeach ,

    Which kinds of message than you cannot send in SFB on MAC? instant message?

    Does the issue occur after the recent update?

    Are there no this issue SFB client in Window.

    Based on your log “Error Code: 500 Internal Server Error. The request was rejected by the HTTP filter. Contact the server administrator” ,this record https://pubdnswebsvchostname.pubdnssipdomain.com/ucwa/v1/applications/414177410848/communication/ was blocked by the edge server, could you find the error event id on the edge server?

    This issue only existed on the TMG 2010 SP2 as Reverse Proxy

    Please use Lync 2011 to make a test.


    Best Regards,
    Leon Lu


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnsf@microsoft.com.


    Click here to learn more. Visit the dedicated forum to share, explore and talk to experts about Microsoft Teams.

    Monday, April 9, 2018 9:43 AM
  • Hi rwgeach ,

    If the issue only existed on the TMG 2010 SP2 as Reverse Proxy,please unselect "Verify normalization" in the "Configure HTTP policy for rule" like the following screenshot;


    Best Regards,
    Leon Lu


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnsf@microsoft.com.


    Click here to learn more. Visit the dedicated forum to share, explore and talk to experts about Microsoft Teams.

    Wednesday, April 11, 2018 9:43 AM
  • Hi,

     

    Are there any update for this issue, if the reply is helpful to you, please try to mark it as an answer, it will help others who has similar issue.


    Best Regards,
    Leon Lu


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnsf@microsoft.com.


    Click here to learn more. Visit the dedicated forum to share, explore and talk to experts about Microsoft Teams.

    Wednesday, April 11, 2018 9:43 AM
  • Hi ,

     

    Do you have some updates? If the reply help to you ,please mark the reply as answer.


    Best Regards,
    Leon Lu


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnsf@microsoft.com.


    Click here to learn more. Visit the dedicated forum to share, explore and talk to experts about Microsoft Teams.

    Monday, April 16, 2018 9:48 AM
  • apologies for the delay. verify normalization has been unchecked for as long as this has been in service so that won't help in this case.

    will patch from RU0 to RU5 this weekend and see if that helps.

    Tuesday, April 17, 2018 2:58 PM
  • Ok, waiting for you update

    Best Regards,
    Leon Lu


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnsf@microsoft.com.


    Click here to learn more. Visit the dedicated forum to share, explore and talk to experts about Microsoft Teams.

    Wednesday, April 18, 2018 10:52 AM
  • it was the verification setting.

    for some reason I was looking at the web access policy http filtering before (due to not realizing it wasn't a global system setting).

    changing it in the firewall policy's web publishing rule fixed it immediately.

    at least we're on rollup 5 now.  marked original request to change this setting as answer.

    Monday, April 23, 2018 1:42 AM