2012 AD RMS - error forming a new cluster "The SCP is registered but the root cluster cannot be contacted" RRS feed

  • Question

  • I installed AD RMS role (but did not configure it) on a 2012 Domain controller in my lab then decided to do it instead on a 2012 member server.  I uninstalled AD RMS from the DC but when I tried to configure it on the server, the "create a new AD RMS licensing only cluster" is greyed out and the error  "The SCP is registered but the root cluster cannot be contacted". I suspect something is left over from the old ad rms install - is there a way to clean this up?


    Gary Olsen

    Sunday, January 19, 2014 3:15 AM

All replies

  • Hi Gary,

    probably the SCP registration still exits in AD.

    Go to AD Sites and Services, navigate under Services to RightsManagementServices. 

    Try first to clear the serviceBindingInformation attribute and if this is not enought delete the SCP object.



    Monday, January 20, 2014 2:44 PM
  • Many thanks Lutz, 

    i had the same cause and by deleting the SCP Folder, it worked find. 

    note: a small correction, it is under ADSI edit and not AD sites and Services. 


    Tuesday, August 5, 2014 5:39 AM
  • Hi Gary Olsen,

    Do not remove SCP manually! There is a dedicated tool for that.

    1. Download RMS SP2 Administration Toolkit
    2. Use GetRMScp tool to check if SCP had been already registered
    3. Use ADScpRegister tool to unregister/register SCP as follows:
    a. Open Command Prompt, by clicking Start, Run. In the Run dialog box, type cmd, and then click OK.
    b. At a command prompt type the following command: ADSCPRegister.exe <Operation> <URLtoRegister>

    For <Operation> specify either "registerscp" or "unregisterscp" depending on what you want to achieve. For <URLtoRegister>, type the URL that you want to use as the service connection point, for example, https://my_domain/_wmcs/Certification.

    You can verify that the tool has run correctly by viewing these two objects in Active Directory: objectClass=container with CN=RightsManagementServices

    Did my post help you or make you laugh? Don't forget to click the Helpful vote :) If I answered your question please mark my post as an Answer.

    • Proposed as answer by JTYates Thursday, September 25, 2014 12:54 PM
    Friday, August 8, 2014 1:26 PM
  • which was not worked for me, while executing commands thrown an error :

    i removed it from ADSI EDIT, it worked from CN=Service and CN=RightsManagementServices uner this CN=SCP remove SCP folder, it worked for me.

    Monday, October 13, 2014 4:29 PM