locked
How to fill in RunAs information while using SImulator? RRS feed

  • General discussion

  • I have written a discovery in my SCOM 2012 MP as below:

    --------------------------------------------------------------------------------------------------------------

    <ManagementPackFragment SchemaVersion="2.0" xmlns:xsd="http://www.w3.org/2001/XMLSchema">
      <Monitoring>
        <Discoveries>
          <Discovery ID="TestDemo.TestDemo.Discovery.Test" Target="SNL!System.NetworkManagement.Node" Enabled="true" ConfirmDelivery="false" Remotable="true" Priority="Normal">
            <Category>Discovery</Category>
            <DiscoveryTypes>
              <DiscoveryClass TypeID="TestDemo.Class.Test">
                <Property TypeID="TestDemo.Class.Test" PropertyID="SerialNumber" />
                <Property TypeID="TestDemo.Class.Test" PropertyID="totalCapacity" />
              </DiscoveryClass>
            </DiscoveryTypes>
            <DataSource ID="DS" TypeID="TestDemo.DataSource.TestDiscovery">
              <IPAddress>$Target/Property[Type="SNL!System.NetworkManagement.Node"]/SNMPAddress$</IPAddress>
              <Version>$Target/Property[Type="SNL!System.NetworkManagement.Node"]/SNMPVersion$</Version>
              <CommunityString>$RunAs[Name="SNL!System.NetworkManagement.Snmp.MonitoringAccount"]/CommunityString$</CommunityString>
              <Interval>20</Interval>
            </DataSource>
          </Discovery>
        </Discoveries>
      </Monitoring>
      <LanguagePacks>
        <LanguagePack ID="ENU" IsDefault="true">
          <DisplayStrings>
            <DisplayString ElementID="TestDemo.TestDemo.Discovery.Test">
              <Name>Test Array Discovery</Name>
              <Description>Description for the Test Array</Description>
            </DisplayString>
          </DisplayStrings>
        </LanguagePack>
      </LanguagePacks>
    </ManagementPackFragment>

    --------------------------------------------------------------------------------------------------------------

    Note that the CommunityString is assigned in the way as below:

              <CommunityString>$RunAs[Name="SNL!System.NetworkManagement.Snmp.MonitoringAccount"]/CommunityString$</CommunityString>

    Now, I run this discovery in Simulator, but there is no place to fill in my CommunityString.

    So, I want to know how to give the value of $RunAs[Name="SNL!System.NetworkManagement.Snmp.MonitoringAccount"]/CommunityString$ in the simulator.

    Thanks!

    • Changed type Niki Han Monday, November 4, 2013 2:59 AM
    Thursday, October 24, 2013 4:03 AM