none
DPM 2010 Scheduled Reports via Exchange 2010 Anonymous SMTP - Possible Explanation RRS feed

  • Question

  • Just putting up another customer on DPM 2010 with Exchange 2010.
     
    The SMTP Test works just fine. But the report Service does not.
     
    Thought the server was configured exactly the same as the other customers. After a few hours, I finally realized what was happening.
     
    First, DPM does NOT need an SMTP username and password. This is not a good idea as even typical ESMTP can expose your passwords to those who know how to get them. If you have to use and account/password, never use an administrator account.
    And leave the SQL reporting username as NETWORK. It works just fine.
     
    Other than checking spelling of URLs. etc, that's about it.
     
    However, on the Exchange 2010 side, if you cannot figure out what is happening, turn Protocol Logging on to Verbose and read the receive logs located in "C:\Program Files\Microsoft\Exchange Server\V14\TransportRoles\Logs\ProtocolLog\SmtpReceive".
    I finally set up a separate DPM Receive connector configured as follows:
     
    Name: Inbound Anonymous SMTP
    FQDN: <ExchangeServerName>.<domain>.<tld>
    Port: 25
    IP Addresses: 192.168.xxx.xxx to 192.168.xxx.xxx
    Authentication: Externally Secured
    Permission Group: Exchange Servers
     
    If your DPM Server is also a Hyper-V server with two IPs on the same subnet, you might try adding both IPs.
    Externally secured means "not secured at all".
    Exchange Servers is just another way of saying "not secured at all".
     
    If the SMTP Test works and the scheduled reports do not, take a real close look at the email addresses. They may not have been entered accurately and so will not get validated by Exchange and the entire email will be trashed. This will be obvious in the Exchange logs, but DPM/SQL won't even spit out an event (at least not for me).
     
    Bob.

    • Edited by BobH2 Monday, February 6, 2012 12:14 AM
    Monday, February 6, 2012 12:13 AM

All replies

  • Just noticed:

    In Options |  SMTP Server, you need to save a username/password at least once (probably to created the registry keys), then go and delete the username and password to enable SMTP.

    Another important point:
    If checking scheduled reports on a day that it is not scheduled, you can't expect it to email anything. (Found out the hard way.)

    Bob.


    • Edited by BobH2 Monday, February 20, 2012 3:50 PM
    Sunday, February 19, 2012 1:34 PM