locked
Sharepoint stsadm Restore from Back Up breaks all the deplyed reports link to datasource. RRS feed

  • Question

  • Hello Everyone,

    Hoping to get some solution to the issue we are having.

    We have SSRS reports deployed in Sharepoint 2007. I am trying to restore from a back up of a site collection into another blank site collection. Site backup and restore all works fine and completes successfully using STSADM utility. But after restore the deplyed reports looses the link to datasource.

    Can somebody please guide on it?

     

    Thanks,

    Pulkit Ojha

     


    • Edited by Mike Walsh FIN Tuesday, May 3, 2011 4:04 PM Do not shout in Titles
    • Moved by Mike Walsh FIN Tuesday, May 3, 2011 4:05 PM questions involving SSRS go to the BI forum (From:SharePoint - Setup, Upgrade, Administration and Operation (pre-SharePoint 2010))
    Tuesday, May 3, 2011 2:47 PM

Answers

  • Hi Pulkit,

    According to your description, from your scenario, please check your report server configuration in “SharePoint Central Administration website->Application Management –>Configure Reporting Services Integration”.

    Please type available Report Server Website Service URL and same Authentication as SSRS. Then, type correct Report Server name and instance in “SharePoint Central Administration website->Application Management –>Grant Database Access”. Finally, if you use Windows Authentication Mode, please make sure Windows Integrated Security has been Enabled in “SharePoint Central Administration website->Application Management –>Set Server Defaults”.

    For detail information, please check http://msdn.microsoft.com/en-us/library/bb969100.aspx.Please have a try.

    If this don't workout then check whether your application pool pointing to central admin.


    ------------------------------------ Happy Workaround :) Vivek
    • Marked as answer by Peng Lei Tuesday, May 10, 2011 4:53 AM
    Friday, May 6, 2011 10:05 AM

All replies

  • Hi Pulkit,

    According to your description, from your scenario, please check your report server configuration in “SharePoint Central Administration website->Application Management –>Configure Reporting Services Integration”.

    Please type available Report Server Website Service URL and same Authentication as SSRS. Then, type correct Report Server name and instance in “SharePoint Central Administration website->Application Management –>Grant Database Access”. Finally, if you use Windows Authentication Mode, please make sure Windows Integrated Security has been Enabled in “SharePoint Central Administration website->Application Management –>Set Server Defaults”.

    For detail information, please check http://msdn.microsoft.com/en-us/library/bb969100.aspx.Please have a try.

    If this don't workout then check whether your application pool pointing to central admin.


    ------------------------------------ Happy Workaround :) Vivek
    • Marked as answer by Peng Lei Tuesday, May 10, 2011 4:53 AM
    Friday, May 6, 2011 10:05 AM
  • Thanks Vivek.

    I will try your suggestion and post back the results.

     

    Regards,

    Pulkit Ojha


    Thanks, Pulkit Ojha Microsoft Business Intelligence Developer
    • Edited by Mike Walsh FIN Friday, May 20, 2011 1:43 PM reference to deleted (spam) post removed
    Monday, May 16, 2011 9:04 AM
  • Hey Vivek,

    We have a sharepoint server which host the sharepoint application, we have reporting services server which hosts SSRS services, a dedicated sharepoint db server and a dedicated reporting services db server.

    I just saw in my Live sharepoint Central Admin >> Appln Management >> Grant Database Access...

    In server name field, it specifies sharepoint application server name and default instance is selected.

    I am confused over you asking to specify reporting services server name in above field. And in live reporting services integration services runs just fine.

    Please correct me if I am wrong.

    Thanks a lot Vivek for helping out.

    Regards,

    Pulkit Ojha


    Thanks, Pulkit Ojha Microsoft Business Intelligence Developer
    Friday, May 20, 2011 9:32 AM