none
Shedule of reports by email not working on DPM 2010 RRS feed

  • Question

  • I have one DPM 2010 configured, with 3 protections groups, 1 group for exchange, 1 for sql , 1 for folders.


    In My SMTP Server config, i set my remote SMTP Server, is the exchange mail server. The user that i use to authenticate, is one i created one my AD and have on mailbox on my exchange server.

    i use "sending TEST email" and everything work fine. In the menu "notifications" i test and recive the email.


    At moment everythnig work fine, but when i go to menu "REPORTING" i configure 2 types of reporting to sent by email. They generate a daily report, but NEVER send the report on email. I dont know why.


    on my file: "C:\Program Files\Microsoft DPM\SQL\MSRS10.MSDPM2010\Reporting Services\ReportServer\reportserver\rsreportserver.config" i changed the field "Authenticate" to 2 and restart the service of reporting services and dont work.

    I made some changes on the acc running the service running the Reporting services, for the same account do the authenticate on my SMTP Server, and the problem still happen.

    I made many configs to resolve this problem, and nothing help me to resolve this issue.


    My server windows 2008 server R2 Data center + DPM 2010 with 2 license enterprise. SQL Isntance installed by default on DPM. My user used to athenticate is fine, coz i set him on OUTLOOK and sent emails without problem.

    PLZ someone can help me about this ?

    Friday, May 4, 2012 4:27 AM

All replies

  • Hi,

    Please see if any of these solutions work for you.

    Troubleshooting Reporting Issues
    http://technet.microsoft.com/en-us/library/ff399667.aspx


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread. Regards, Mike J. [MSFT] This posting is provided "AS IS" with no warranties, and confers no rights.

    Saturday, May 5, 2012 12:39 AM
    Moderator
  • i saw the link, and all that solutions doesnt work.

    I dont understand, why i do a EMAIL TEST on DPM, i recive the email. But with schedule, i never recive the email.

    to do a Test, i already add my user to domain accs. And i need know the minimum requeriments for this task.

    Monday, May 7, 2012 1:02 AM
  • in my event log show:

    Log Name:      Application
    Source:        SQLAgent$MSDPM2010
    Date:          5/7/2012 2:30:00 PM
    Event ID:      208
    Task Category: Job Engine
    Level:         Warning
    Keywords:      Classic
    User:          N/A
    Computer:      myserver.domain.com
    Description:
    SQL Server Scheduled Job '33017DC1-A449-4639-9693-616329BF97C8' (0x66A20C0AF985C54387C67651320B6DAA) - Status: Failed - Invoked on: 2012-05-07 14:30:00 - Message: The job failed.  Unable to determine if the owner (mydomain\report) of job 33017DC1-A449-4639-9693-616329BF97C8 has server access (reason: Could not obtain information about Windows NT group/user 'mydomain\report', error code 0x5. [SQLSTATE 42000] (Error 15404)).
    Event Xml:
    <Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
      <System>
        <Provider Name="SQLAgent$MSDPM2010" />
        <EventID Qualifiers="16384">208</EventID>
        <Level>3</Level>
        <Task>3</Task>
        <Keywords>0x80000000000000</Keywords>
        <TimeCreated SystemTime="2012-05-07T17:30:00.000000000Z" />
        <EventRecordID>2593</EventRecordID>
        <Channel>Application</Channel>
        <Computer>myserver.mydomain.com</Computer>
        <Security />
      </System>
      <EventData>
        <Data>33017DC1-A449-4639-9693-616329BF97C8</Data>
        <Data>0x66A20C0AF985C54387C67651320B6DAA</Data>
        <Data>Failed</Data>
        <Data>2012-05-07 14:30:00</Data>
        <Data>The job failed.  Unable to determine if the owner (mydomain\report) of job 33017DC1-A449-4639-9693-616329BF97C8 has server access (reason: Could not obtain information about Windows NT group/user 'mydomain\report', error code 0x5. [SQLSTATE 42000] (Error 15404)).</Data>
      </EventData>
    </Event>

    Tuesday, May 8, 2012 1:49 AM
  • into my SQL Server on SQL Server Agent > Errors log, have this log:

    Date  5/7/2012 12:30:00 PM
    Log  SQL Server Agent (Current - 5/2/2012 2:30:00 PM)

    Message
    [298] SQLServer Error: 15404, Could not obtain information about Windows NT group/user 'mydomain\report', error code 0x5. [SQLSTATE 42000] (ConnIsLoginSysAdmin)

    Tuesday, May 8, 2012 2:15 AM
  • Hi,

    Where did "report" user come from, and how is it being used this is not an account that DPM creates. 

    In a default installation DPM uses a local instance of SQL and SSRS. DPM creates the following group and user account on the DPM server.

    DPMDBReaders$[machine name] - local group containing the following user account.
    DPMR$[machine name] - local user account used by the SQL Server Reporting Services to generate DPM reports.

    The DPMR$[machine name] account is granted the Allow log on locally user right.

    Make sure the SQL Server Reporting Services (MSDPM2010) Service account is configured for "Network Service".


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread. Regards, Mike J. [MSFT] This posting is provided "AS IS" with no warranties, and confers no rights.

    Tuesday, May 8, 2012 3:23 PM
    Moderator
  • When I configured the DPM , the service was running with default accounts and wasn’t working. Finding some solutions in forums and blogs, I saw the service need be run on the same acc used to authenticate on remote STMP server, then I tried it.

    Now I back the config of Reporting Services to run on Network Service.

    after i do all that, the warning on my Windows Event log dissapeared.

    Now i have this event happened on the same time I scheduled the Report to be send by email.

    The warning event on my windows Event log occurs stopped. But into my SQL Server have this event:

    Date                      5/9/2012 2:00:00 PM

    Log                        SQL Server Agent (Current - 5/7/2012 2:30:00 PM)

    Message

    [162] Internal request (from SetJobNextRunDate [reason: schedule will not run again]) to deactivate schedule 107

    and i keep not reciving the report by email.

    Wednesday, May 9, 2012 5:46 PM
  • I stoped all schedules of reporting. And another day i tried do the configs again, and made new schedules and the emails begin work. I dont have sure what made this work, coz i made many configurations, but i think for the last was i restart the jobs on DPM remaking the configs.

    Thx Mike and everybody tried to help.

    Monday, May 21, 2012 2:29 PM