none
Connection to Microsoft Exchange is unavailable for one user RRS feed

  • Question

  • On one users computer I am having an issue where I get the follow error "Connection To Microsoft Exchange is Unavailble"

    I have deleted the users Outlook profile and the bad part is when I try to readd the profile it says the connection to Microsoft Exchange is Unavailble.  I retried like 7 times in a row, then all of a sudden it went through and started loading the outlook profile and downloading emails.  Then no more than 2 minutes later when i click the TO: button in an email it says it cant connect to Microsoft Exchange again.  

    So there is an issue with pulling up the GAL as well as even configuring the profile for first use.  Its not just this one mailbox because I had the same issue on multiple mailboxes. 

    1.  I have uninstalled and reinstalled outlook 2007

    2. I tried Installing outlook 2010 

    3. Deleted the users windows profile and recreated it from scratch and configured outlook.  

    None of these have helped.  This problem is really driving me nuts I have spent over 40 hours on it.  

    Monday, June 4, 2012 4:36 PM

Answers

  • If this is Exchange 2010, multiple issues can cause this, here is what I went through with this same problem:

    1)  Check the users login account login count: if the user is over their throttling policy, that can cause a similar issue.

    Get-LogonStatistics <user> | ft UserName,ClientName,LogonTime,LastAccessTime
    
    (Get-LogonStatistics <User>).count

    Look at the logontime and last access time and see how old they are.  If they are old, then you need to clear them, unfortunately, the only way to clear these is to either restart the Information Store on the mailbox server or to move the mailbox to another database on a different mailbox server.

    2) The KeepAliveTime on the exchange servers needs to be reduced, the registry key is

    HKLM\SYSTEM\CurrentControlSet\Services\TCP\Parameters

    New DWORD KeepAliveTime set it to 493e0(HEX)/300,000(DEC)

    This will change the KeepAliveTime from the 2 hour default to 5 minutes.  (Does require reboot).  This setting will allow for quicker session termination for orphaned connections.

    3)  Turn off TCP Chimney on Exchange 2010 Servers, utilizing

    netsh int tcp set global chimney=disabled 

    4)  Increase the NSPI max sessions on your 2008 R2 domain controllers.  As of Windows 2008 R2, windows restricts the max number of MAPI sessions to 50.  The registry key for this is:

    HKLM\System\CurrentControlSet\Services\NTDS\Parameters

    New DWORD of ‘NSPI max sessions per user’ set to 12c(HEX)/300(DEC)

    These settings will change the number of sessions to 300 per user (Also requires reboot).  This is critical if you have more than 50 blackberry devices connected to your Exchange because the service account could hit the limit and BES stops working because there are not any more connections available to it.

    Try some of these out and let me know how it goes.

    • Marked as answer by pslager Monday, June 4, 2012 7:10 PM
    Monday, June 4, 2012 7:07 PM

All replies

  • Can the mailbox be opened by OWA?  Can you open a different mailbox on the Outlook instance?  Can you open the mailbox on an Outlook client on a different PC?

    Ed Crowley MVP "There are seldom good technological solutions to behavioral problems."


    Monday, June 4, 2012 6:38 PM
    Moderator
  • If this is Exchange 2010, multiple issues can cause this, here is what I went through with this same problem:

    1)  Check the users login account login count: if the user is over their throttling policy, that can cause a similar issue.

    Get-LogonStatistics <user> | ft UserName,ClientName,LogonTime,LastAccessTime
    
    (Get-LogonStatistics <User>).count

    Look at the logontime and last access time and see how old they are.  If they are old, then you need to clear them, unfortunately, the only way to clear these is to either restart the Information Store on the mailbox server or to move the mailbox to another database on a different mailbox server.

    2) The KeepAliveTime on the exchange servers needs to be reduced, the registry key is

    HKLM\SYSTEM\CurrentControlSet\Services\TCP\Parameters

    New DWORD KeepAliveTime set it to 493e0(HEX)/300,000(DEC)

    This will change the KeepAliveTime from the 2 hour default to 5 minutes.  (Does require reboot).  This setting will allow for quicker session termination for orphaned connections.

    3)  Turn off TCP Chimney on Exchange 2010 Servers, utilizing

    netsh int tcp set global chimney=disabled 

    4)  Increase the NSPI max sessions on your 2008 R2 domain controllers.  As of Windows 2008 R2, windows restricts the max number of MAPI sessions to 50.  The registry key for this is:

    HKLM\System\CurrentControlSet\Services\NTDS\Parameters

    New DWORD of ‘NSPI max sessions per user’ set to 12c(HEX)/300(DEC)

    These settings will change the number of sessions to 300 per user (Also requires reboot).  This is critical if you have more than 50 blackberry devices connected to your Exchange because the service account could hit the limit and BES stops working because there are not any more connections available to it.

    Try some of these out and let me know how it goes.

    • Marked as answer by pslager Monday, June 4, 2012 7:10 PM
    Monday, June 4, 2012 7:07 PM