locked
ACPI and Dual Core probem, plz respond RRS feed

  • Question

  •  

    Hey,


    I have a Toshiba P105-6227 laptop. I was trying to update my ACPI driver. So I clicked on let me chose from a list. It was called "ACPI x86-based computer" and now it's called "Advanced Configuration and Power Interface (ACPI) PC". I can't get the first driver, and now my "Texas Instruments OHCI Compliant IEEE 1394", "Texas Instruments PCIxx12 Integrated FlashMedia Controller", and my "SDA Standard Compliant SD Host Controller" are not working: This device cannot find enough free resources that it can use. (Code 12).

    Also, in my device manager, my computer detects the Intel Core 2 CPU but only one is actually working. My computer is very slow and it only works on 1 processor. The Intel processor identification utility says that the other core is disabled. I'm guessing the ACPI driver is causing this; I think the second core "can't find enough free resources that it can use".

    Is there a way I can fix all this?


    Thank you,
    Gab
    Monday, November 26, 2007 4:58 PM

Answers

  •  

    First of all, thx a lot for your response.

     

    What you suggested is not the solution to the problem although it helped me a lot.

    When I ran msconfig and tried to set the number of processors to 2, I could only check 1. Moreover, trying to update the ACPI driver from the Vista DVD didn't work also.

     

    However, I just had to uncheck "number of processors" and check "Detect HAL". I restarted the PC, and both cores came back and the ACPI driver was back to normal. I unchecked detect HAL, checked number of processors and set it to 2.

     

    Now my pc is back to normal and I'm so glad. It has been 1 month I've been trying to fix it.

     

    Thx a lot

    Gabriel

    Thursday, November 29, 2007 3:01 PM

All replies

  • Hi Gab,

    I’d like to suggest you initialize the ACPI driver from Windows Vista Installation CD:

    1.    Navigate to “Control Panel”, choose “Device Manager”.

    2.    Select “Computer” – “Advanced Configuration and Power Interface (ACPI) PC”.

    3.    Click “Driver” tab and choose “Update Driver”

    4.    Select “Browse my computer for driver software” – speciy your DVD drive location

    5.    Search and update the ACPI driver.

    Also, I’d like to suggest you download and install the latest version of ACPI BIOS from TOSHIBA website:

    ACPI Flash BIOS version 4.20 for Satellite P100:
    http://www.csd.toshiba.com/cgi-bin/tais/su/su_sc_dtlViewDL.jsp?soid=1903197&moid=1598605&rpn=PSPADU&BV_SessionID=@@@@0370684654.1196233387@@@@&BV_EngineID=cccdaddmjfgejefcgfkceghdgngdgnn.0&ct=DL&all_docs=false

    For the Dual Core CPU issue, please run “msconfig”, choose “Boot” tab, select “Advanced Option”, make sure the “number of processors” has been set to “2”

    --------------------
    Regards,
    Eric Zhang
    Microsoft Online Community Support



    Thursday, November 29, 2007 6:38 AM
  •  

    First of all, thx a lot for your response.

     

    What you suggested is not the solution to the problem although it helped me a lot.

    When I ran msconfig and tried to set the number of processors to 2, I could only check 1. Moreover, trying to update the ACPI driver from the Vista DVD didn't work also.

     

    However, I just had to uncheck "number of processors" and check "Detect HAL". I restarted the PC, and both cores came back and the ACPI driver was back to normal. I unchecked detect HAL, checked number of processors and set it to 2.

     

    Now my pc is back to normal and I'm so glad. It has been 1 month I've been trying to fix it.

     

    Thx a lot

    Gabriel

    Thursday, November 29, 2007 3:01 PM
  • Hi Gabriel,

    Thanks for your reply, I'm glad that the problem has been resolved and your experience will help other community members.

    --------------------
    Regards,
    Eric Zhang
    Microsoft Online Community Support



    Friday, November 30, 2007 9:50 AM
  • I found the answer!!!

    I had the same problem and I googled variants of "cpu 2 disabled" core 2 duo cpu disabled; task manager cpu graph... etc.

     

    Vista apparently sets the Hardware Abstraction Layer (wikipedia.org has a good article explaining this) only on install.  I think back then I had the Max CP1d value in the bios set to enabled.  (spelling?  this is in bios for old operating systems that can't handle the new CPU values in their full lenght).

     

    The answer was to update HAL.  run msconfig.  got to boot menu and to advanced.  You'll probably only be able to do one cpu but don't worry about the cpu checkbox.  Check the Detect HAL.  reboot.  Run MSConfig again and uncheck it, also make sure you're doing a normal boot and not a safe mode or diagnostic boot (this is the first msconfig tab) then reboot and you're set.

     

    The difference that the Updating the HAL is that in device manager, under the Computer category, you go from one ACPI instruction to an new one that supports multiple processors.  (mine says ACPIx86-based PC)

     

     

    Here's the copy and paste of the article I found that told me this:

    btotheeck
    October 5th, 2007, 02:22 AM
    Just wanted to post that I ran into the same problem but it was not BIOS related.

    I first updated my BIOS (always a good idea)
    I went into Hardware Manager and uninstalled the previous processor(s)
    Rebooted
    Vista found new processors, installed automatically, then required reboot
    Rebooted
    Went to start>run>msconfig
    Boot Tab
    Advanced Button
    I had set my startup number of processors to 2 (upgraded to quad core, only 2 showed in vista)
    Unchecked the number of processors checkbox
    Marked the Detect HAL
    Click Apply and Reboot

    All 4 cores showed now. Hope this helps!
    Tuesday, January 8, 2008 6:08 AM
  • Thx for you response but that's what I said two posts earlier.

    Tuesday, January 8, 2008 1:01 PM
  • Try reinstalling drivers on each individual processor in device manager. System information may also be helpful in helping you to determine your problem. I can't guarantee anything but it's worth a try. If all else fails, you can always do an upgrade of the OS with the option to keep all of your files. Good Luck !

     

    Thursday, April 3, 2008 7:49 PM
  • I'd just like to say thanks, this finally helped me to fix my x's computer. It is fresh from hp as a package deal, ok if you don't build your own.I've been trying to fix this on and off for a couple weeks. really slow and not much sense in having x2 if it doesn't work. I swapped out the processor to test cpu and that was fine. Actually got a link from John on the hp forum to here in a long sort of route but I searched long enough to find this article. The only thing different was I started with the dectect hal already checked, so I unchecked it booted and no diff so I checked it booted,still no luck.Okay at this point I figured do it one more time, uncheck reboot expecting to be ticked, I ran amd power monitor and hoooyahhh! glory halleluyah! 2 processors popped up. I then checked the task manager and bam two processors. I had to go one more step but it was worth it what a difference! Thanks again, got to go to hp forum and let them know I'm good

    Friday, April 4, 2008 9:22 PM
  • Gab,

     

    What about in XP with SP2. I have a Core duo, but HAL will only detect or enable a single processor although in device manager both processor are listed. I tried your msconfig, but cannot get to a HAL detect option in the advanced option to select and deselect the number of processors.

     

     

    Wednesday, September 24, 2008 9:53 PM
  • I didn't quite understand what you mean but you should check detect HAL, restart your computer, uncheck detect HAL and check number of processors and select 2

    Feel free to ask me again if you still need help.
    Wednesday, September 24, 2008 9:59 PM
  • Hi I have the same problem only running XP sp3.
    Sysinternals Process Explorer does not report a Dualcore being available (although it should be).
    Also some other applications report: "single processor detected" or similar.

    Yet device manager says there a two processors in the device list.

    Is there a similar way to force XP to redetect a dualcore processor?

    greetings,
    Job.
    Wednesday, December 24, 2008 4:22 PM