How to stop links in Excel files in SP folders from changing to the local drive? RRS feed

  • Question

  • I have excel files linked together and all in the same sharepoint folder.  I open the files and then check via "data" that they are all linked correctly (still in my sharepoint site). Note that I only open them (do not check them out locally or to sharepoint).   Then i run calculate manually and most times all is fine.  But sometimes the links end up pointing to my local drive sharepoint drafts folder (reminder, I am not checking them out at this time). 

    So I was hoping someone could help me with best practices to keep the links from changing to my local drive.  I was thinking maybe I had a check out that I disgarded or something like that kept a copy of the file in my local drive and that may somehow be a priority check for excel when deciding where the data link is established...



    • Edited by Mike Walsh FIN Saturday, June 11, 2011 7:35 AM Original title of "Sharepoint and linked excel files " was not specific.
    • Moved by Mike Walsh FIN Saturday, June 11, 2011 7:35 AM more admin than general (From:SharePoint - General Question and Answers and Discussion (pre-SharePoint 2010))
    Friday, June 10, 2011 9:14 PM


  • Tom,

    You have to uncheck the "Update links on save" checkbox BEFORE adding hyperlinks, then only it works as expected.

    Follow the below mentioned steps to uncheck "Update links on save" checkbox:

    • Save the excel file to your local machine.
    • Delete existing hyperlinks, if any (If it is already in SharePoint folder or document library else skip this step).
    • Now in Excel go to Options and under General tab click Web Options and on the Files tab uncheck the "Update links on save". Click ok.
    • After this add the hyperlinks again.
    • Upload the spreadsheet back to SharePoint folder or document library
    • Close IE. Now open IE and your SharePoint site. See it works !


    Veera Reddy Kolan
    SharePoint Consultant
    Wednesday, June 15, 2011 1:51 PM