locked
Deploy SQL Server 2008 R2 Native Client x64 with dependency of .NET Framework 4.0 RRS feed

  • Question

  • I added the MSI file for SQL Server 2008 R2 Native Client x64 into Software Library=> Application

    However this SQL Native client required .NET Framework 3.5 SP1 or higher as a prereq.

    What are the steps to do this?

    I have tried to add the dotNetFx40_Full_x86_x64.exe as a package using the command "dotNetFx40_Full_x86_x64.exe /q /norestart /ChainingPackage ADMINDEPLOYMENT"   as suggested on http://sccmadministrator.wordpress.com/2012/06/25/net-framework-4-0-deployment/   and it didn't work.

    Thanks for any help.

    Tuesday, March 5, 2013 5:04 PM

Answers

  • Updates: Solved

    Objective: Deploy SQL Server 2008 R2 Native Client x64 via SCCM 2012

    1. Created application in SCCM 2012 with the MSI

    2. Right click properties and select "Deployment Types" tab

    3. click on highlight the MSI package and click edit

    4. In the Program tab

    5. Installation program:  added the line  " IACCEPTSQLNCLILICENSETERMS=YES" so should look slike this

    msiexec /i "sqlncli_X64(2008 R2).msi" /q IACCEPTSQLNCLILICENSETERMS=YES


    • Marked as answer by Voev Tuesday, March 5, 2013 5:46 PM
    • Edited by Voev Tuesday, March 5, 2013 5:47 PM
    Tuesday, March 5, 2013 5:46 PM

All replies

  • Updates: Solved

    Objective: Deploy SQL Server 2008 R2 Native Client x64 via SCCM 2012

    1. Created application in SCCM 2012 with the MSI

    2. Right click properties and select "Deployment Types" tab

    3. click on highlight the MSI package and click edit

    4. In the Program tab

    5. Installation program:  added the line  " IACCEPTSQLNCLILICENSETERMS=YES" so should look slike this

    msiexec /i "sqlncli_X64(2008 R2).msi" /q IACCEPTSQLNCLILICENSETERMS=YES


    • Marked as answer by Voev Tuesday, March 5, 2013 5:46 PM
    • Edited by Voev Tuesday, March 5, 2013 5:47 PM
    Tuesday, March 5, 2013 5:46 PM
  • Just a quick note, .NET Framework  4.0 does not include 3.5
    If you need .NET Framework 3.5 you will need to install that.
    .NET Framework 3.5 however includes 2.0


    Best Regards
    Claus Codam
    Consultant, Developer
    Coretech - Blog

    Tuesday, March 5, 2013 8:21 PM
  • This works for SQL Native Client 2012 on SCCM 2012 R2 as well =)
    Friday, August 21, 2015 2:16 PM