locked
NON EMPTY disappears when we publish reports to PAS RRS feed

  • Question

  •  

    Hi! We are running PAS 6.3 and have identified a problem with reports published to PAS with NON EMPTy activated for rows or columns.

     

    If I save a report in a briefingbook to my local hard drive NON EMPTY will be activated when I reopen the book or report.

     

    If I publish the same book to PAS and reopen the report with Web Professional the NON EMPTY will be gone.

     

    Anyone else who have seen this behaviour?

     

    BR

    Thomas Ivarsson

    Tuesday, May 6, 2008 9:20 AM

Answers

  • I have tried it with 6.2 as I am between 6.3 installs at this point, but I have asked a couple of other engineers to test it (who are using 6.3) and none of us has been able to replicate the behavior when we set the view to filter non-empty rows and columns using the buttons next to the Rows and Columns fields.

     

    Thanks,

     

    Bob

     

    Wednesday, May 7, 2008 7:56 PM

All replies

  • I can't say that I'm familiar with this issue Thomas.  Have you verified that the PAS and Professional clients are at the same hotfix levels?  If you run pdc (the ProClarity Diagnostic Tool can be run from the Program Files ProClarity menu) logs on the respective machines, you will be able to compare the versions installed on each.  Also, if you aren't already, have you installed the latest hotfixes across your environment?  6.3.2214 is the latest release, and they can be downloaded here:

     

    http://www.microsoft.com/Downloads/results.aspx?pocId=&freetext=proclarity%206.3.2214&DisplayLang=en

     

    Please let us know your results.

     

    Thanks,

     

    Bob

     

    Wednesday, May 7, 2008 2:29 PM
  • Thanks for the reply Bob.

     

    I will check this first thing tomorrow but I have already tried with different versions of ProClarity Professional and Web Professional. Still it remains to check different versions of the PAS server. This will take some time but I will return with the result.

     

    Have you tried this scenario with the most recent version of the clients and the PAS Server?

     

    BR

    Thomas Ivarsson

     

    Wednesday, May 7, 2008 6:44 PM
  • I have tried it with 6.2 as I am between 6.3 installs at this point, but I have asked a couple of other engineers to test it (who are using 6.3) and none of us has been able to replicate the behavior when we set the view to filter non-empty rows and columns using the buttons next to the Rows and Columns fields.

     

    Thanks,

     

    Bob

     

    Wednesday, May 7, 2008 7:56 PM
  • Thanks Bob,

     

    This saves a  lot of time.

     

    BR

    Thomas Ivarsson

     

     

     

     

     

    Thursday, May 8, 2008 5:45 AM
  •  

    After checking this issue once more it seems like the problem depends on the server name, that is not showing correctly in Web Professional, when you open a briefing book, on a different server in PAS.

     

    We have two servers, let us call them PAS1(production) and PAS2(development). When I open a published report on PAS1, in Web Professional, and change the server to PAS2, by Analytics Server "Retrive book" and "change server", the indicator, down to the left in the window will still show PAS1. If I change anything in a report on PAS2(the server I have switched to) I can get the illusion that I have changed a setting on PAS1, according to the information down to the left. The change is done on PAS2 and if you open that report on PAS2 all the changes will be there.

     

    So this issue seems to be caused by human error and that ProClarity does not show the correct server name when you change servers, by the menu in web professional.

     

    BR

    Thomas Ivarsson

     

    Friday, May 9, 2008 11:46 AM