locked
Remove Cache-control no-cache from headers on a my SSL SharePoint site RRS feed

  • Question

  • I have a site that has SSL set-up on it. Usres are unable to dlownload a PDF from this site. I have found this information concerning the issue:

    PDF download over SSL does not work with cache control headers in Internet Explorer

    When trying to download a PDF file generated through a web page using an HTTPS Url in Internet Explorer (all versions from 5.01 through 8) you will recieve the following error message:

    Unable to download 'xxxxxxx'. Internet Explorer was unable to open this site. The requested site is either unavailable or cannot be found. Please try again later.

    This is caused when the header of the response that sends the file (PDF or Office document) contains a 'Cache-control:no store' or 'no-cache' element. One of the work arounds is editing the client registry. For a web application this is not an option.

    A more permanent solution is not using the Cache-control header when using HTTPS Urls. SSL pages are not cached, so a simple check if the request starts with https ascertains you do not need the cache-control header.

    This feature does not occur when browsing with other explorer brands.

    I can access this site internally using the HTTPS URL and I can download the PDF. Hitting the HTTPS externally creates the problem. I have looked in IIS and I don't see the No-Cache header. Where do I remove this header from?

    Monday, December 20, 2010 8:30 PM

Answers

  • Hi,

     

    I suggest that you should have a try to download a PDF with FireFox. In my opinion,
    HTTP connection 
    IE: Embedding and downloading works fine and the displayed (or downloaded) PDFs seems up-to-date.
    Firefox: Downloading works fine and that PDFs seems up-to-date. But embedding PDFs are cached.

    HTTPS connection
    All browsers: Embedding and downloading works fine and the displayed (or downloaded) PDFs seems up-to-date.
     

    I wish you every success in your important work.

    Best regards,

    David Hu

     

    • Marked as answer by Peng Lei Monday, December 27, 2010 8:38 AM
    Wednesday, December 22, 2010 2:45 AM

All replies

  • check this article: http://support.microsoft.com/kb/815313

     

    or another Kb which may helpful: http://support.microsoft.com/kb/812935

     

    hope this help

    thanks

    -ws


    SharePoint administrator, MCTS,MCITP
    • Marked as answer by pmccoy46 Monday, December 20, 2010 9:33 PM
    • Unmarked as answer by pmccoy46 Monday, December 20, 2010 9:34 PM
    Monday, December 20, 2010 9:05 PM
  • Did you try this fix http://support.microsoft.com/kb/323308 ?
    Oleg
    • Marked as answer by pmccoy46 Monday, December 20, 2010 9:33 PM
    • Unmarked as answer by pmccoy46 Monday, December 20, 2010 9:34 PM
    Monday, December 20, 2010 9:06 PM
  • Very helpful. It appears that the solution is specific to the clients version of IE. I still don't see where the server is sending the header from. If you can tell me that, it would be helpful. From I read here the fix is to be installed on the clients machine and not the server. Is that right?
    Monday, December 20, 2010 9:34 PM
  • I think thois article is extremely helpful. To clarify though, I can't seem to locate where the server is sending the header from. Is the web.config (i didn't see anything there), is the ISS HTTP Header tab for the Web App ( Ididn't see it there either). So it appears that the solution and this fix is for the individual client machine to update the registry. Is that correct?
    Monday, December 20, 2010 9:36 PM
  • Hi,

     

    I suggest that you should have a try to download a PDF with FireFox. In my opinion,
    HTTP connection 
    IE: Embedding and downloading works fine and the displayed (or downloaded) PDFs seems up-to-date.
    Firefox: Downloading works fine and that PDFs seems up-to-date. But embedding PDFs are cached.

    HTTPS connection
    All browsers: Embedding and downloading works fine and the displayed (or downloaded) PDFs seems up-to-date.
     

    I wish you every success in your important work.

    Best regards,

    David Hu

     

    • Marked as answer by Peng Lei Monday, December 27, 2010 8:38 AM
    Wednesday, December 22, 2010 2:45 AM