locked
DAG MULTIPLE ROLE RRS feed

  • Question

  • Hello,

       Server A= Hub,Cas and Mailbox

       ServerB= Hub,Cas and Mailbox

    I dont have load balancing and I am ready to point my clients once again. Now all the clients are connecting to Server A

    and I am shuting down the Server A to Simulate a failover. I tried to point my clients once again to Server B but they cannot be pointed with a Error "Server name cannot be resolved' Please help

     

    Tuesday, September 6, 2011 4:39 PM

Answers

    1. Do what Anil has said and set the RPCClientAccess value on the Server B - http://technet.microsoft.com/en-us/library/bb123971.aspx

    Sukh
    • Marked as answer by Sabresquad Thursday, September 8, 2011 5:56 AM
    Tuesday, September 6, 2011 9:39 PM
  •  

    I did this

    Added Authenticated with read permission on OAB folder.(C:\Program Files\Microsoft\Exchange Server\V14 >client access >

     and every thing started working

    My great thanks to Sukh and Jason for guiding me with patience.

    • Marked as answer by Sabresquad Thursday, September 8, 2011 5:56 AM
    Thursday, September 8, 2011 5:56 AM

All replies

  • As you don't have load balancing, you can not do failover. why not creating WNLB which will do failover but not load balacing.

    For now to shift clients to server B, You need to go each mailbox databse and change RPCClientaccess value to server B and restart outlook.


    Anil MCC 2011,ITIL V3,MCSA 2003,MCTS 2010, My Blog : http://messagingschool.wordpress.com
    • Proposed as answer by Anil K Singh Tuesday, September 6, 2011 5:03 PM
    • Unproposed as answer by Sabresquad Tuesday, September 6, 2011 9:12 PM
    Tuesday, September 6, 2011 5:03 PM
  • Hello,

    with a DAG in place you can't use Windows Load Balancing for creating a CAS array. So you have to point your users manually to the other CAS.

    What you can do is:

    1.) Install a hardware load balancer.

    2.) Create a CAS array on different servers than the DAG.

    Greetings,

    Toni

    Tuesday, September 6, 2011 5:56 PM
  • my company has limited budget so I cannot buy the Load balancer nor new servers for load balancing, I am ready to point my clients manually which I did but unfortunately I cannot it says cannot resolve the name , Do I have to run certain commands on the server to show it as a active server ?

     

    Tuesday, September 6, 2011 9:15 PM
    1. Do what Anil has said and set the RPCClientAccess value on the Server B - http://technet.microsoft.com/en-us/library/bb123971.aspx

    Sukh
    • Marked as answer by Sabresquad Thursday, September 8, 2011 5:56 AM
    Tuesday, September 6, 2011 9:39 PM
  • I type this on my server

    Set-MailboxDatabase SKAK -RpcClientAccessServer "SEVERB.CONTOSO.COM"

    Still my clients are not able to resolve the address do I have to restart some services ??


    Wednesday, September 7, 2011 5:56 AM
    1. How many AD sites?  Exch deployed all in one AD site?
    2. Have you configured a CAS array (has nothing to do with load-balancing).
    3. Clients cant reslve address, what exactly do you mean, what fails?

    Sukh
    Wednesday, September 7, 2011 9:10 AM
    1. How many AD sites?  Exch deployed all in one AD site?

    ONLY ONE SITE "Default First Site"  Yes both Exchange Servers are deployed in one site.

    2.Have you configured a CAS array (has nothing to do with load-balancing).

    No I haven't configured CAS ARRAY and I know the consequences and I am ready to point my clients once more.( Already Mentioned Cant get a hardware and a new server for wlnb)

    3.Clients cant resolve address, what exactly do you mean, what fails?

    As mentioned Above My Server A went down and I wanted to Point my Clients to Server B and it gives me a error saying "The name cannot be Resolved"

    Wednesday, September 7, 2011 11:45 AM
  • Hello,

    have you checked your DNS settings on the client? Can you ping Server B? Does nslookup give back the correct address?

    Greetings,

    Toni

    Wednesday, September 7, 2011 12:16 PM
    1. Checked DNS as per Toni suggestions?

    Sukh
    Wednesday, September 7, 2011 1:08 PM
  • yeah now works fine its resolving but my clients are getting errors while sending and receiving

    0x80190194

    The above error seems to be from offline address book and its obvious because my previous clients were pointing to Server A and Offline Address book was generated from there now I want to point the OAB to server B so that clients can donload it 

     

    Wednesday, September 7, 2011 2:35 PM
    1. Your OAB needs to be avaliable on Server B then as clients will try to download the OAB from server A which isnt avaliable.

    Sukh
    Wednesday, September 7, 2011 3:34 PM
  • alrite how do i do that ?

     

    Wednesday, September 7, 2011 3:56 PM
  • already did the but getting the same error
    Wednesday, September 7, 2011 6:54 PM
  • Hi,

    1. Check if the OAB file generate on the hub and cas server.

    Program files>Microsoft>Exchange Server>Client Access Server>OAB

    Programfiles>Microsoft>Exchange Server>ExchangeOAB

    2. Incrase OAL Generate Diagnosting level to 7 Then restart MSExchangeSA service and Update Offline Addres Book

    Any error message?

    3.  EMC=>Organization Configuration=>Mailbox Database Properties=>Client Settings

    The field of OAB is setting correctly?

    4. Use outlook "Test e-mail AutoConfiguration" check if OAB URL is correct. Try to browse the OAB.xml. Any error?

    The URL should be the ServerB. If the URL is incorrect you need correct it.

    # Set-ClientAccessServer -Identity ServerB -AutodiscoverServiceInternalUri https://serverB.domain.com/autodiscover/autodiscover.xml

    # Set-WebServicesVirtualDirectory -Identity "ServerB\EWS (Default Web Site)" -InternalUrl https://serverB.domain.com/ews/exchange.asmx

    # Set-OABVirtualDirectory -Identity "ServerB\oab (Default Web Site)" -InternalUrl https://ServerB.domain.com/oab

    5. Check the authentication on the EWS and Autodiscover virtual directories on CAS server.

    The EWS -> Integrated windows authentication and Autodiscover -> Basic & Integrated windows authentication


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    Thursday, September 8, 2011 2:20 AM
  •  

    I did this

    Added Authenticated with read permission on OAB folder.(C:\Program Files\Microsoft\Exchange Server\V14 >client access >

     and every thing started working

    My great thanks to Sukh and Jason for guiding me with patience.

    • Marked as answer by Sabresquad Thursday, September 8, 2011 5:56 AM
    Thursday, September 8, 2011 5:56 AM