none
unable to load self-signed cert into Windows 2008 and get IE to like it, still gives error RRS feed

  • Question

  • I'm trying to load a self signed certificate (in our case, from vCenter) - into Windows 2008 using the mmc/certifcates add-in or by going to https://siteURL../ in IE and installing.

    Neither work.  I loaded the cert into Trusted People/Local Computer as I've always done, but when going to this site the certificate error still shows in IE.  For kicks, I tried loading it into various other stores - same result.

    What is strange is that when you browse with IE to the site, you should be able to click on "Continue" and view/install the certificate, but you can't.  Clicking on "Continue...." doesn't do anything.

    Was unable to resolve this, so we took the machine off the domain to ensure there were no GPO rules preventing this from happening, rebooted, tried again - same result.

    So we tried with Firefox...initial error, but we were able to view the cert, install it, and it was happy thereafter.

    But IE simply will not working, and I think this problem is causing downstream problems with our other app integrations.  Until IE is happy, I don't think many other things will be either.

    I can view this certificate in Trusted People/Local Computer and the name is correct, but it does say "this certificate cannot be verified....has an invalid signature".

    Anyone have any ideas?  I'm almost out of them all. :)

    Thanks


    • Edited by meddle01 Thursday, April 11, 2013 7:21 PM updating subject for clarity
    Wednesday, April 10, 2013 9:30 PM

All replies

  • I've verified cert is not loaded into Untrusted store, etc.   

    The machine was removed from the domain, site added to Trusted Sites, tried various Administrative users.

    Thursday, April 11, 2013 7:23 PM