locked
Search function not working correctly? RRS feed

  • Question

  • Since installing build 9926, the live search functionality of the start menu seems to have stopped for me. This problem is also extending to the fact I can no longer run programs from the Start Menu.

    Opening the start menu and typing anything results in nothing but a blank, empty list being displayed.

    This is also stopping me from running programs - for example, if I want to run cmd.exe, it greets me with the same blank page rather than letting me run anything.

    I've checked my indexing settings, which state that the computer is indexed across all drives.

    Any ideas for how to fix it?

    Monday, January 26, 2015 4:35 PM

All replies

  • Hi,

    Does the search function work in other locations? Such as File Explorer or the right search charm bar?

    Though you have checked the indexing settings, I recommend you rebuild the index (control panel\Indexing Options\Advanced\Rebuild)

    Or use the built-in troubleshooter: control panel\Troubleshooting\system and security, select search and Indexing Options.


    Yolanda Zhu
    TechNet Community Support

    Wednesday, January 28, 2015 6:05 AM
    Moderator
  • The search function doesn't seem to work at all. Windows+Q doesn't do anything, unless I've got the search box as the active 'window' in which case I hear the Cortana beep. Windows+R still works, and lets me run things, thankfully.

    Searching within an explorer window does search, but it's not a live search - it takes its time and I can hear my hard drives being accessed/searched. The charms bar seems to be disabled for me. I can't access it and Win+C doesn't do anything. The troubleshooter doesn't help at all, no matter what boxes I tick it says that it is "Unable to find any problem" and asks me to explore additional options.

    I've given rebuilding a shot (as well as moving the location of the index files about about, just in case it helped) and that didn't change anything.


    • Edited by Zcomutwo Wednesday, January 28, 2015 3:15 PM
    Wednesday, January 28, 2015 2:36 PM
  • Dear Zcomtwo,

    I faced a similar issue after updating my TP Build! It is a common issue, should be resolved in the near future!

    Workaround - Right click on the application you wish to launch either from start or even search bar and run as administrator! That's how I have been going about it! Remember to leave your feedback in the app too!

    Cheers,
    Prashant
    Wednesday, January 28, 2015 3:25 PM
  • Dear Zcomtwo,

    I faced a similar issue after updating my TP Build! It is a common issue, should be resolved in the near future!

    Workaround - Right click on the application you wish to launch either from start or even search bar and run as administrator! That's how I have been going about it! Remember to leave your feedback in the app too!

    Cheers,
    Prashant

    The problem is more finding any application to begin with to right click - the search doesn't function at all, literally it's a blank list.

    Wednesday, January 28, 2015 3:41 PM
  • It seems like there are indexing problems on your pc!
    Follow the below instructions in the below link:-

    http://www.tomsitpro.com/articles/windows-8.1-index-files,2-748.html

    So, indexing will take a bit of time, refrain from using PC for about 20-30 mins max. Disk usage will be 100% which is normal and will return to its original state once indexing is complete! After that do a restart and try again using the search

    Wednesday, January 28, 2015 4:03 PM
  • It seems like there are indexing problems on your pc!
    Follow the below instructions in the below link:-

    So, indexing will take a bit of time, refrain from using PC for about 20-30 mins max. Disk usage will be 100% which is normal and will return to its original state once indexing is complete! After that do a restart and try again using the search

    I've tried rebuilding the index multiple times now, as well as putting it in different drives and folders, waiting for it to fully build and trying again. I've also tried fiddling with the service, it also doesn't change the problem.

    As a side note, 

    press the WinKey +w, type 'index' in the search and you will see the 'Indexing Options' icon.
    does not work for me - i manually have to find the indexing options control panel (or just use an alias). Literally, trying anything into the start menu/search box doesn't work, and Win+Q likewise doesn't work.
    Wednesday, January 28, 2015 5:17 PM
  • Zcomutwo,

    Try rolling back to a previous version of Windows and then reinstall the latest version?
    Thursday, January 29, 2015 9:45 AM
  • Zcomutwo,

    Try rolling back to a previous version of Windows and then re-install the latest version?

    I'd been wanting to avoid this, but I just tried it with a completely fresh install and the problem persists.

    Thursday, January 29, 2015 6:12 PM
  • ok! I've found an update to my problem, but not a solution.

    Installing windows 10 fresh, from scratch on a new partition resulted in the same thing happening - a blank start with me enable to search. Nothing was similar here - the only thing I used in common was my Microsoft account o login.

    So, on my fresh install, and my existing install that I'm currently using, which I upgraded from 8.1 and first notice the problem on, I created a new local user account. Both searched perfectly!

    So there seems to be a problem linked to my Microsoft account preventing me from searching. This did not exist on the previous windows 10 build I rolled back to, but persisted after re-installing 9926.

    Is there a way to purge Bing/Internet search history or setting on the account itself, or in some way reset it?

    Thanks again for the suggestions.

    • Edited by Zcomutwo Thursday, January 29, 2015 6:51 PM
    Thursday, January 29, 2015 6:46 PM
  • To update, this is what happens when I search. My account has been validated so I can finally post a picture.

    Sunday, February 1, 2015 8:30 PM
  • Hi,

    Apologize for the delay, for search settings about web browser, in previous os such as Windows 8.1, you can launch Chnage PC settings\OneDrive\Sync setttings\other settings\web browser, turn off this setting, or in preview build 9926, go to "Settings"\Accounts\Sync Settings, turn off web browser settings or turn off all sync settings for the Microsoft Account, then wait for some time or restart explorer.exe, check this issue again.

    To manually clear the Bing search history, go to bing.com/profile/history to manage your tracked searches.


    Yolanda Zhu
    TechNet Community Support

    Monday, February 9, 2015 1:58 AM
    Moderator
  • I'm having the same problem. Searching with Windows explorer works fine. Just searching for programs has become annoying (been using Windows+R for now)

    Tried the methods suggested. Didn't work

    Using a Surface Pro 3

    Is this a common problem with Build 9926?

    Tuesday, February 10, 2015 9:05 PM