none
Failed but not blocking correlation - project server 2013 not creating project site using custom site tempalte RRS feed

  • Question

  • Hi,

    I'm trying to Create a Project using a custom Project Site Template with project server 2013.Everything is working in DEV server.But project site is failed to create when PWA is deployed in UAT  server.

    Queue Job Error Details:

    General•CreateWssSiteContent: Creating project site failed! Project Uid=45c3b712-bfeb-e311-bc7e-005056990064, site URL=http://.../PWA/GDP Project Site, site name=GDP Project Site. Microsoft.SharePoint.SPException: The site template requires that the Feature {81da7fc5-df02-4f8a-9f0f-0e50fa1d2638} be installed in the farm or site collection. at Microsoft.SharePoint.Utilities.SPUtility.ThrowSPExceptionWithTraceTag(UInt32 tagId, ULSCat traceCategory, String resourceId, Object[] resourceArgs) at Microsoft.SharePoint.SPWebTemplateElement.VerifyFeatures(XmlNodeList xmlNodeFeatures, SPWeb applyTemplateToThisWeb, SPFeatureScope featureScope, SPFeatureDependencyErrorBehavior featureDependencyErrorBehavior, List`1& featureDependencyErrors) at Microsoft.SharePoint.SPWebTemplateElement.VerifyFeaturesInWebTemplate(SPWeb applyTemplateToThisWeb, SPFeatureDependencyErrorBehavior featureDependencyErrorBehavior, ICollection`1& featureDependencyErrors) at Microsoft.SharePoint.SPWeb.LoadFeatureWebTemplateContent(SPFeatureWebTemplate featureWebTemplate, SPFeatureDependencyErrorBehavior featureDependencyErrorBehavior, ICollection`1& featureDependencyErrors) at Microsoft.SharePoint.SPWeb.ProvisionWebTemplate(SPWebTemplate webTemplate, String webTemplateToUse, SPFeatureWebTemplate featureWebTemplate, Page page, SPFeatureDependencyErrorBehavior featureDependencyErrorBehavior, ICollection`1& featureDependencyErrors) at Microsoft.SharePoint.SPWeb.ApplyWebTemplate(SPWebTemplate webTemplate, Page page, SPFeatureDependencyErrorBehavior featureDependencyErrorBehavior, ICollection`1& featureDependencyErrors) at Microsoft.SharePoint.SPSite.CreateWeb(String strUrl, String strTitle, String strDescription, UInt32 nLCID, String strWebTemplate, Boolean bCreateUniqueSubweb, Boolean bConvertIfThere, Guid webId, Guid rootFolderId, Boolean createSystemCatalogs, Guid appInstanceId, String appWebDomainId) at Microsoft.SharePoint.SPSite.SPWebCollectionProvider.CreateWeb(String strWebUrl, String strTitle, String strDescription, UInt32 nLCID, String strWebTemplate, Boolean bCreateUniqueSubweb, Boolean bConvertIfThere, Guid appInstanceId) at Microsoft.SharePoint.SPWebCollection.Add(String strWebUrl, String strTitle, String strDescription, UInt32 nLCID, String strWebTemplate, Boolean useUniquePermissions, Boolean bConvertIfThere, Guid appInstanceId) at Microsoft.Office.Project.Server.BusinessLayer.AdminProjectSiteAllocator.CreateSPWeb(ProjectSiteConfigurationInfo configInfo, SPSite topSite):◦WSSCreateSiteFailure (16400). Details: id='16400' name='WSSCreateSiteFailure' uid='8cf0e016-bfeb-e311-bc7e-005056990064' projectUID='45c3b712-bfeb-e311-bc7e-005056990064' workspaceUrl='http://nsh111:9191/PWA/GDP Project Site/GDP Project Site' projectWorkspaceName='GDP Project Site'. 

    •Queue:◦GeneralQueueJobFailed (26000) - CreateWssSite.CreateWssSiteMessage. Details: id='26000' name='GeneralQueueJobFailed' uid='8df0e016-bfeb-e311-bc7e-005056990064' JobUID='88c3b712-bfeb-e311-bc7e-005056990064' ComputerName='57adf328-208d-4601-984b-a53ea80cdfdb' GroupType='CreateWssSite' MessageType='CreateWssSiteMessage' MessageId='1' Stage='' CorrelationUID='6b81979c-1b83-202b-cdfd-bc72c417e4b3'. For more details, check the ULS logs on machine 57adf328-208d-4601-984b-a53ea80cdfdb for entries with JobUID 88c3b712-bfeb-e311-bc7e-005056990064. 

    Thanks&Regards,

    Kusuma

    Wednesday, June 4, 2014 10:04 AM

All replies

  • Kusuma,

    It seems like that the feature that this project site depends on, is not available. You will need touse PowerShell to actiavte this specififc feature.

    Is this custom template 'migrated' from a different environment?

    A simpletr way could be to jusr recreate the custom template, if it is simple enough.


    Prasanna Adavi,PMP,MCTS,MCITP,MCT TWitter: @prasannaadavi Blog: http://www.prasannaadavi.com

    Wednesday, June 4, 2014 2:37 PM
    Moderator

  • Hi Prasanna,

    Thank you so much for the Response.

    I have activated the feature which was not installed before.Now am facing different error while creating the site.i.e.

    General•Queue:◦GeneralQueueJobFailed (26000) - CreateWssSite.CreateWssSiteMessage. Details: id='26000' name='GeneralQueueJobFailed' uid='2c360636-90ec-e311-8abd-005056990064' JobUID='387a7e2a-90ec-e311-8abd-005056990064' ComputerName='57adf328-208d-4601-984b-a53ea80cdfdb' GroupType='CreateWssSite' MessageType='CreateWssSiteMessage' MessageId='1' Stage='' CorrelationUID='10d7979c-3b7e-202b-cdfd-bed8071b9e8f'. For more details, check the ULS logs on machine 57adf328-208d-4601-984b-a53ea80cdfdb for entries with JobUID 387a7e2a-90ec-e311-8abd-005056990064. 



    I have checked the sitecontents page the site has created but its not activated the Enterprise Project Feature in Connected SharePoint Sites page(UAT Server).



    Regards,

    Kusuma
    Thursday, June 5, 2014 9:47 AM
  • Kusuma,

    COuld you please turn on verbose loggings in ULS and post the results?

    Also, is it psisble for you to 1) create a quick custom template in the UAT server, and make sure that it is not an issue with server itself 2) may be just recreate your custom template in UAT server?


    Prasanna Adavi,PMP,MCTS,MCITP,MCT TWitter: @prasannaadavi Blog: http://www.prasannaadavi.com

    Thursday, June 5, 2014 12:37 PM
    Moderator