none
Sage 2014 Error when trying to publish

    Question

  • Hello, I'm getting the following error after sequencing the latest version of Sage Accounts 2014:

    Windows Error: 0x800736FF - The supplied assembly identity is missing one or more attributes which must be present in this context

    Error module: Virtualization Subsystem. Internal error detail: A460142A800736FF.

    The sequence runs fine, it all launches ok, the error I am seeing when I try and load it into SCCM for delivery or also using Tim's

    App-V Manage tool. I don't know where to start as the event logs aren't telling me anything.

    I've tried adding manually through powershell, it doesn't error but nothing is being published.

    I'm running app-v 5 sp2 hotfix 4.



    • Edited by IanC97 Monday, June 9, 2014 2:13 PM
    Monday, June 9, 2014 2:12 PM

Answers

All replies

  • Can you send me the package to look at?  Any kind of cloud storage will do.

    Tim Mangan


    Tim Mangan MVP for App-V and Citrix CTP Author of AppV books: "The Client Book" and "OSD Reference Book" (http://www.tmurgent.com/Books )

    Monday, June 9, 2014 4:31 PM
    Moderator
  • Hi Tim, thanks for your message, can you email me directly  and I'll send you a link to the package.

    Regards

    Ian


    • Edited by IanC97 Tuesday, June 10, 2014 11:18 AM
    Tuesday, June 10, 2014 8:19 AM
  • Ian,

    I looked at the package and the failure.  I smell an App-V bug and have reported it into the development team.  All my tool can do is report the client publishing error. If you want prompter action on the bug, you should consider opening a support ticket with Microsoft directly as those ensure you get someone to look at it right away.

    I believe the cause is likely to be a couple of side-by-side components from Sage that were captured for local installation during the publishing process, along with all of those VC Runtimes.

    A possible workaround would be to install the Sage components natively, first on the sequencer before sequencing and then on any clients getting the package as a dependency.  It's not a bad thing to do the same with the VC Runtimes, but not related to your issue.  You should probably test that theory before opening the ticket.

    Tim


    Tim Mangan MVP for App-V and Citrix CTP Author of AppV books: "The Client Book" and "OSD Reference Book" (http://www.tmurgent.com/Books )

    Tuesday, June 10, 2014 1:23 PM
    Moderator
  • Hello, I have tried disabling the following option:

    Package pre-installed VC runtime dependencies and side-by-side assemblies.

    I still get the same error.

    Wednesday, June 11, 2014 12:00 PM
  • You should open a ticket with Microsoft.  They really seemed adamant about that.

    Tim Mangan MVP for App-V and Citrix CTP Author of AppV books: "The Client Book" and "OSD Reference Book" (http://www.tmurgent.com/Books )

    Wednesday, June 11, 2014 3:11 PM
    Moderator
  • Hi.

    Was there any solution to this issue. Just tried to package the program and got the same error myself.

    Thanks in advance!

    Thursday, July 17, 2014 3:24 PM
  • For any additional readers of this thread, the suggested solution that is reported to work by IanC97 in this thread is to delete the SBDDesktop.exe.config file.

    Brandon
    MDOP on the Springboard Series on TechNet

    Thursday, August 7, 2014 3:00 PM
    Moderator
  • Deleting "SBDesktop.exe.config" sounds like a great answer for someone getting this error with "Sage" but is absolutely useless for anyone getting the same exact error message virtualizing a different application.

    Perhaps an explanation on how it was determined what is causing the problem or how it was concluded that "SBDesktop.exe.config" should be deleted would be more worthy answers.


    • Edited by connpatd18 Tuesday, September 23, 2014 3:41 AM
    Tuesday, September 23, 2014 3:40 AM
  • Well you will have to ask Microsoft for that, they spent 2 weeks troubleshooting this for us and their conclusion was this file is not there in a local install so deleting it from the virtual package was our solution.

    Tuesday, September 23, 2014 8:16 AM
  • Hi Ian,

    I had the same issue with Sage Payroll v16 and I've tried removing SBDesktop.exe as couldn't find a SBDDesktop.exe.config file in the same location but didn't help. Any ideas is it the same or am I missing SBDDesktop.exe.config on My package. Thanks. 

    Kind Regards

    Ash

    Sunday, March 20, 2016 9:18 PM
  • Hello All

    I am also having this same issue.

    Once again my application is Sage:

     - Sage Accounts 50 v23

     - Sage Payroll 50 v21 & v22

    I have made multiple attempts to package these apps, packaging with and without the c++ redistributables and .net framework 3.5.

    I like ash do not have the SBDDesktop.exe.config file and therefore cannot remove it from the package.

    Cannot someone shed some light on this issue?

    Thursday, July 6, 2017 9:11 PM
  • Hi AndrewJacques99, 

    Did you ever get to the bottom of this ?

    I have the exact same issue when trying to package sage 50 Accounts V24.068.0 I am trying to package using App-v5.1 ( with the latest hotfix). I have tried all the dependencies and don't have the file called SBDDesktop.exe.config. I even tried creating one as per one website but I still fails when I try and publish, it appears to sequence okay. When I try and publish in the normal way it all seems good except the app does not appear on in the app-v client and therefore not on the desktop. There are no errors in the event viewer. When I tried to publish via PowerShell I found the error but can't find a root cause or a solution. The error I see is

    Publish-AppvClientPackage : Application Virtualization Service failed to complete requested operation.
    Operation attempted: Publish AppV Package.
    Windows Error: 0x800736FF - The supplied assembly identity is missing one or more attributes which must be present in
    this context
    Error module: Virtualization Subsystem. Internal error detail: A460142A800736FF.
    Please consult AppV Client Event Log for more details.
    At line:1 char:1
    + Publish-AppvClientPackage
    + ~~~~~~~~~~~~~~~~~~~~~~~~~
        + CategoryInfo          : InvalidResult: (:) [Publish-AppvClientPackage], ClientException
        + FullyQualifiedErrorId : PublishPackageError,Microsoft.AppV.AppvClientPowerShell.PublishAppvPackage

    I did raise this with Sage but I received a reply to say Sorry but they do not support the packaging of Sage 50 so cannot offer any further assistance :(

    Thanks in Advance

    Thursday, June 21, 2018 1:26 PM
  • I feel your pain. I'm trying to sequence Sage 50Accounts v22 (released in 2016 I believe) with App-V 10.0.15063.0 and I am unable to publish with the same unhelpful 'Supplied assembly identity is missing one or more attributes'. This newer Accounts release does not have a SDBdesktopexe.config file to remove. Such as shame this problem persists to this day. I've tried the advice here with no success. My client will be really disappointed if I can't get this working in App-V. How can it still be an issue for such a major app?
    Friday, August 31, 2018 12:52 PM
  • Yes same in v22 on sequencer 10.0.15063.0. Even if I delete all the assemblies and configs from the sequence, it still fails to publish with the same error. Come on MS! Fix this so it packages like it used to!
    Friday, August 31, 2018 12:53 PM
  • I also had issues with every version of sage from 2014 to 2018 (2019 version works fine)
    They all had the same problem for me and after a lot of trial and error I narrowed it down to the architecture type missing from sage controls in winSxS in many <appv1.1:ExtensionCategory="AppV.SxSAssembly"> sections

    I exported the manifest file, opened with notepad++ and replaced all entries of "<appv1.1:ProcessorArchitecture />" with "<appv1.1:ProcessorArchitecture>none</appv1.1:ProcessorArchitecture>"

    I then re-imported the manifest file, saved the App-V package and deployed it successfully

    Hope this helps

    Tuesday, November 6, 2018 11:31 AM
  • Dave,

    The schema defines the value of the ProcessorArchitecture element for assemblies simply as a string (in contrast to SequencingStationProcessorArchitecture which is a enum of "x86", "x64", or "x86x64combined").  The schema does not define a default value when not specified.

    How did you determine the value "none"? If this came from Microsoft I'd like to add this to my tools to automatically correct the manifest when I see it.

    Tim


    App-V MVP & CTP Fellow. Author of AppV books: PowerShell with App-V 5, The Application Book, & Window Caching (http://www.tmurgent.com/Books)

    Tuesday, November 6, 2018 12:06 PM
    Moderator
  • Hi Tim

    I went with "none" based on an assumption because of the naming convention of the manifest files
    Unfortunately this hasn't come from any official Microsoft or Sage source, as it appears to be in the classic grey area where each company has "done their bit", leaving us to fill in the gaps
    The only source is classic trial and error of chopping bits out of the manifest file until I found the section that was failing, then realising the ProcessorArchitecture element was empty

    For example:
    x86 = {Windows}]\WinSxS\Manifests\x86_microsoft.vc80.atl_1fc8b3b9a1e18e3b_8.0.50727.6195_none_d1cb102c435421de.manifest 
    none = {Windows}]\WinSxS\none_sagesystemcontrols_8a15c0b120b2bbf9_14.0.54.0_none_092aaad6bd74ff94\SGWebBrowser.dll

    From this I had assumed that app-v or sage hadn't interpreted the word "none" correctly, but i'm not an expert on either product or how things are registered in WinSXS
    I also tried using x86 instead of none, which also worked (assumed it would as the Sage program is 32bit)

    Sage 2019 doesn't appear to have any of the sagesystemcontrols entries in its manifest file, so I'm guessing that's why it's not broken too

    Dave


    Tuesday, November 6, 2018 12:35 PM
  • OK. Thanks.   

    Adding some additional details for others finding this post...

    An exe or dll can be compiled for x86 or x64, and in the case of .Net components there is something called "AnyCPU" (in the developer tooling) which can run as x86 or x64.  AnyCPU will run as x86 on an x86 system.  On a x64 system, it can run as either: 

    • The AnyCPU dll component will always run in the architecture (I like the word "bitness") of the process that is loading it.
    • The AnyCPU exe component has a developer settable setting that indicates if it should run in x86 or x64 by default. But this setting can be overridden by a system-wide GPO that tells the system to load in the bitness specified there.

    I am guessing that the component in question is an AnyCPU, and it isn't clear what the syntax should be for this. Setting the value to "none" works for you, so others should go with it for this app.  I suspect that removing the element completely may also work, but that would need to be tested.  

    I'll do some playing around and provide automatic fixes in both the AppXManifestEditor and TMEdit tools in the future.


    App-V MVP & CTP Fellow. Author of AppV books: PowerShell with App-V 5, The Application Book, & Window Caching (http://www.tmurgent.com/Books)

    Tuesday, November 6, 2018 12:50 PM
    Moderator