none
Sage 2014 Error when trying to publish

    Question

  • Hello, I'm getting the following error after sequencing the latest version of Sage Accounts 2014:

    Windows Error: 0x800736FF - The supplied assembly identity is missing one or more attributes which must be present in this context

    Error module: Virtualization Subsystem. Internal error detail: A460142A800736FF.

    The sequence runs fine, it all launches ok, the error I am seeing when I try and load it into SCCM for delivery or also using Tim's

    App-V Manage tool. I don't know where to start as the event logs aren't telling me anything.

    I've tried adding manually through powershell, it doesn't error but nothing is being published.

    I'm running app-v 5 sp2 hotfix 4.



    • Edited by IanC97 Monday, June 09, 2014 2:13 PM
    Monday, June 09, 2014 2:12 PM

Answers

All replies

  • Can you send me the package to look at?  Any kind of cloud storage will do.

    Tim Mangan


    Tim Mangan MVP for App-V and Citrix CTP Author of AppV books: "The Client Book" and "OSD Reference Book" (http://www.tmurgent.com/Books )

    Monday, June 09, 2014 4:31 PM
    Moderator
  • Hi Tim, thanks for your message, can you email me directly  and I'll send you a link to the package.

    Regards

    Ian


    • Edited by IanC97 Tuesday, June 10, 2014 11:18 AM
    Tuesday, June 10, 2014 8:19 AM
  • Ian,

    I looked at the package and the failure.  I smell an App-V bug and have reported it into the development team.  All my tool can do is report the client publishing error. If you want prompter action on the bug, you should consider opening a support ticket with Microsoft directly as those ensure you get someone to look at it right away.

    I believe the cause is likely to be a couple of side-by-side components from Sage that were captured for local installation during the publishing process, along with all of those VC Runtimes.

    A possible workaround would be to install the Sage components natively, first on the sequencer before sequencing and then on any clients getting the package as a dependency.  It's not a bad thing to do the same with the VC Runtimes, but not related to your issue.  You should probably test that theory before opening the ticket.

    Tim


    Tim Mangan MVP for App-V and Citrix CTP Author of AppV books: "The Client Book" and "OSD Reference Book" (http://www.tmurgent.com/Books )

    Tuesday, June 10, 2014 1:23 PM
    Moderator
  • Hello, I have tried disabling the following option:

    Package pre-installed VC runtime dependencies and side-by-side assemblies.

    I still get the same error.

    Wednesday, June 11, 2014 12:00 PM
  • You should open a ticket with Microsoft.  They really seemed adamant about that.

    Tim Mangan MVP for App-V and Citrix CTP Author of AppV books: "The Client Book" and "OSD Reference Book" (http://www.tmurgent.com/Books )

    Wednesday, June 11, 2014 3:11 PM
    Moderator
  • Hi.

    Was there any solution to this issue. Just tried to package the program and got the same error myself.

    Thanks in advance!

    Thursday, July 17, 2014 3:24 PM
  • For any additional readers of this thread, the suggested solution that is reported to work by IanC97 in this thread is to delete the SBDDesktop.exe.config file.

    Brandon
    MDOP on the Springboard Series on TechNet

    Thursday, August 07, 2014 3:00 PM
    Moderator
  • Deleting "SBDesktop.exe.config" sounds like a great answer for someone getting this error with "Sage" but is absolutely useless for anyone getting the same exact error message virtualizing a different application.

    Perhaps an explanation on how it was determined what is causing the problem or how it was concluded that "SBDesktop.exe.config" should be deleted would be more worthy answers.


    • Edited by connpatd18 Tuesday, September 23, 2014 3:41 AM
    Tuesday, September 23, 2014 3:40 AM
  • Well you will have to ask Microsoft for that, they spent 2 weeks troubleshooting this for us and their conclusion was this file is not there in a local install so deleting it from the virtual package was our solution.

    Tuesday, September 23, 2014 8:16 AM
  • Hi Ian,

    I had the same issue with Sage Payroll v16 and I've tried removing SBDesktop.exe as couldn't find a SBDDesktop.exe.config file in the same location but didn't help. Any ideas is it the same or am I missing SBDDesktop.exe.config on My package. Thanks. 

    Kind Regards

    Ash

    Sunday, March 20, 2016 9:18 PM