none
How To Stop Internet Explorer 11 Prompting To Display Full-screen Mode RRS feed

  • Question

  • Is there a way to stop the desktop version of Internet Explorer 11 in Windows 8.1 from prompting whether you want a website to display content in full-screen mode?

    When it displays the prompt "Do you want to view youtube.com in full screen?  (Press Esc to exit.)", if you select 'Always Allow', it doesn't permanently remember this setting, as it will be reset when the browsing history is deleted.  Surely there must be a setting somewhere to prevent it from displaying this prompt every time?

    And I said hey, what's going on...
    Friday, January 3, 2014 5:38 PM

Answers

All replies

  • Surely there must be a setting somewhere to prevent it from displaying this prompt every time?

    Ask YouTube?



    Robert Aldwinckle
    ---

    Saturday, January 4, 2014 5:38 PM
    Answerer
  • Ask YouTube?



    Robert Aldwinckle
    ---


    Why ask YouTube?  I never realised YouTube made Internet Explorer?

    You do realise this message is an Internet Explorer prompt and it doesn't just happen with YouTube, but other sites that offer full-screen content, such as Vimeo, etc?


    • Edited by AnaBna Saturday, January 4, 2014 6:11 PM
    Saturday, January 4, 2014 6:11 PM
  • You do realise this message is an Internet Explorer prompt and it doesn't just happen with YouTube, but other sites that offer full-screen content, such as Vimeo, etc?


    In fact, I suspect it is something that a Flash programmer would know but YouTube would know for that reason.


    Robert Aldwinckle
    ---

    Saturday, January 4, 2014 11:20 PM
    Answerer
  • In fact, I suspect it is something that a Flash programmer would know but YouTube would know for that reason.



    Robert Aldwinckle
    ---

    I disagree, as far as I'm concerned it's a Microsoft problem, not a Flash programmer problem. In fact, more specifically it's an Internet Explorer 11 problem, as it doesn't occur in IE10 and before. And it's not a problem specific to YouTube either as it doesn't just occur on YouTube, it happens on other sites as well.

    It almost seems as though Microsoft changed something in IE11 and forgot to put a setting in either the Internet Zone Settings, Advanced Internet Options or IE Group Policy settings.  Something along the lines of:

    Allow display of full-screen content
    Enable
    Disable
    Prompt (Default)

    Meanwhile, unless there's a setting somewhere to disable the prompts that I can't find, the end user has to put up with these stupid prompts with no way of permanently disabling them?  What was wrong with how it was before with just a semi-transparent message that faded out after a couple of seconds which said "Press ESC to exit full screen mode"?  Why the need for an annoying distracting prompt that requires user interaction as well?  And even if there is a reason (which I'd be fine with), why is there no option to disable it like you can with other prompts?

    If it's something that a Flash programmer would know, then maybe someone needs to let Microsoft's own Flash programmer's know about it:

    Sunday, January 5, 2014 2:37 AM
  • Your image shows a drop down menu on the right "Options for this site".  What does it provide?   FWIW I'm using IE11 on W7sp1 ATM and do not see your prompt in it.  Perhaps I have already used those mysterious options?   <eg>



    Robert Aldwinckle
    ---

    Sunday, January 5, 2014 9:31 AM
    Answerer
  • Your image shows a drop down menu on the right "Options for this site".  What does it provide?   FWIW I'm using IE11 on W7sp1 ATM and do not see your prompt in it.  Perhaps I have already used those mysterious options?   <eg>



    Robert Aldwinckle
    ---

    The options listed in the prompt are 'Allow Once', 'Always Allow' and 'Deny Once'.  The problem is if you select 'Always Allow' it won't permanently remember this setting. 

    The reason seems to be that instead of storing the option you selected in the Windows Registry (like it does with Active X Filtering whitelists, Tracking Protection List whitelists, Pop-up Blocker whitelists, Cookie white/blacklists, etc.) it instead saves the setting somewhere with the Temporary Internet Files.  Therefore, when you delete your browsing history, the 'Always Allow' settings that you set are all deleted and then you're back to square one.

    How on earth can a prompt that essentially just tells you to press Esc to exit full screen (even though you've just pressed a button to make it full screen in the first place) be so important that Microsoft felt the need to make this prompt so prominent with no option to disable it?  It's not like the webpage it trying to do something like install an Active X control.




    • Edited by AnaBna Sunday, January 5, 2014 1:27 PM
    Sunday, January 5, 2014 1:24 PM
  • The registry location where sites that are set to 'Always Allow' are stored is as follows. 

    HKEY_CURRENT_USER\Software\Microsoft\Internet Explorer\FullScreen\AllowDomains

    So why have Microsoft made it so the entries that are stored in this location are deleted when the browsing history is deleted?  It makes no sense.



    • Edited by AnaBna Sunday, January 5, 2014 3:22 PM
    • Proposed as answer by Mark Cywinski Wednesday, February 24, 2016 12:59 AM
    Sunday, January 5, 2014 3:02 PM
  • So why have Microsoft made it so the entries that are stored in this location are deleted when the browsing history is deleted?  It makes no sense.

    See if making it a Favorite and leaving Preserve Favorite... checked in the Delete Browsing History dialog keeps it around longer?   (Ctrl-Shift-Delete)

    I recently became aware that the same problem occurs for people who use the Compatibility View Settings dialog.  Same kind of surprise there.  And the same kind of usability defect too--because in both cases you are really more interested in a host name as a pattern than in a specific URL as a Favorite.   See if it would help to create a dummy Favorite for just the host name?



    Robert Aldwinckle
    ---

    Sunday, January 5, 2014 5:16 PM
    Answerer
  • That crossed my mind earlier, so seeing your post prompted me to try it.  However I found it still deletes the registry entries for the allowed sites even after adding both the video link & website homepage to favourites and checking 'Preserve Favourites Websites Data'.  Although, even if it had worked it wouldn't have been very practical anyway as I have a couple hundred shortcut links in favourites that I keep for future reference, but that doesn't mean I would want to keep cookies and temp internet files for all those sites.

    Anyhow, I went one step further and unchecked items in the 'Delete Browsing History' one by one to see which setting was actually removing the settings and it is the 'History' one that does it.  With 'History' (list of websites you have visited) unchecked, the FullScreen\AllowDomains registry entries are remembered and not deleted, but obviously unchecking 'History' kind of defeates the point of deleting the browsing history.

    So, I'm kind of at a dead end at the moment.

    Sunday, January 5, 2014 7:13 PM
  • Hi,

    Have you tried in No Add-on mode to check if it will display this prompt?

    To find out what was happening and locate the reason, you can monitor this process  when this prompt appears and you choose the settings in pop-up box with process monitor and then save the result to PML file.

    Following this, please upload this file to help us fix this issue.

    http://technet.microsoft.com/en-us/sysinternals/bb896645.aspx

    Thanks!


    Andy Altmann
    TechNet Community Support

    Monday, January 6, 2014 11:29 AM
    Moderator
  • Hi,

    Have you tried in No Add-on mode to check if it will display this prompt?

    Who are Pactera?  Do you get paid to post on Microsoft support forums?

    Monday, January 6, 2014 10:57 PM
  • @AnnaBanna....

    ticket at connect https://connect.microsoft.com/IE/feedback/details/813205/the-popup-dialog-do-you-want-to-view-youtube-on-fullscreen-allow-deny-is-meaningless

    FullScreenAPI documentation - http://msdn.microsoft.com/en-us/ie/dn254939(v=vs.80).aspx

    To submit bugs or feedback to the IETeam (MSFT) post to http://connect.microsoft.com/ie.

    To view a poster/answer's profile click on their profile link in a thread.

    Post consumer questions about IE to http://answers.microsoft.com (Help>Online Support menu from IE).

    These are 'Community' forums funded by MS and Moderated by MSFT.


    Rob^_^

    Saturday, January 11, 2014 2:54 AM
  • Thanks Rob for the heads up.
    Saturday, January 11, 2014 12:35 PM
  • I clicked always allow and it saved but now I want to switch it back. Any idea how to do that? I searched the settings but couldn't see anything that allowed me to change it.

    Tuesday, April 15, 2014 3:07 AM
  • I clicked always allow and it saved but now I want to switch it back. Any idea how to do that?

    Have you read the whole thread?  According to the OP simply clearing some part of History (e.g. the TIF) would be enough to make IE forget that you had made such a choice.



    Robert Aldwinckle
    ---

    Tuesday, April 15, 2014 5:28 AM
    Answerer
  • The registry location where sites that are set to 'Always Allow' are stored is as follows. 

    HKEY_CURRENT_USER\Software\Microsoft\Internet Explorer\FullScreen\AllowDomains

    So why have Microsoft made it so the entries that are stored in this location are deleted when the browsing history is deleted?  It makes no sense.



    I had the same annoying problem, WIN 8.1 x64 - All Updates..

    Youtube is always asking for fullscreen, yes, for privacy reason I always clear my IE Temp on exit..

    But according the HKCU Key I tried the HKLM key.. and it works.. after closing, and cleaning IE.. youtube isn't asking anymore.. try this:

    [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Internet Explorer\FullScreen\AllowDomains]
    "youtube.com"=dword:00000001

    worked for me on IE11 (on the desktop) with Win8.1 x64 - all updates (06.12.2014)

    • Proposed as answer by m4k Saturday, December 6, 2014 3:47 AM
    Saturday, December 6, 2014 3:46 AM
  • I totally agree. and so does everyone in the world.

    "Full-screen view

                  Internet Explorer allows websites to display portions of their web content in full-screen mode. Internet Explorer will inform you if a website wants to display content in full-screen mode. You may allow this full-screen experience for the current visit to the site or all visits to the site. You may also decline for the current visit. Internet Explorer stores the addresses of the websites on which you have chosen to allow the full-screen experience for all visits. You can delete this data at any time with Delete Browsing History.

    You can exit the full-screen view on any site by clicking on the Esc key, selecting the Windows key on your device or selecting the Windows charm from the Charms bar."

    Can't post links, account not verified???? 10 years and my payment details is not enough?

    Thanks, but no thanks. It serves no purpose at all, as fullscreen can be quit at anytime.Lose it please, thanks.

    Wednesday, October 7, 2015 1:15 AM
  • The registry location where sites that are set to 'Always Allow' are stored is as follows. 

    HKEY_CURRENT_USER\Software\Microsoft\Internet Explorer\FullScreen\AllowDomains

    So why have Microsoft made it so the entries that are stored in this location are deleted when the browsing history is deleted?  It makes no sense.



    I had the same annoying problem, WIN 8.1 x64 - All Updates..

    Youtube is always asking for fullscreen, yes, for privacy reason I always clear my IE Temp on exit..

    But according the HKCU Key I tried the HKLM key.. and it works.. after closing, and cleaning IE.. youtube isn't asking anymore.. try this:

    [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Internet Explorer\FullScreen\AllowDomains]
    "youtube.com"=dword:00000001

    worked for me on IE11 (on the desktop) with Win8.1 x64 - all updates (06.12.2014)


    Is there a way to replace "youtube .com" with something that covers any website? (noob, not a tech head, sorry)
    Wednesday, October 7, 2015 1:19 AM
  • This non-functioning IE behaviour annoyed me - being more like "allow once" rather than "always allow".

    After a while I stopped bothering to select and click "always allow" and then found it wasn't even necessary since if you DO NOTHING you remain in full-screen mode and after a few seconds the nag message disappears anyway.

    Wednesday, October 14, 2015 2:27 AM
  • Is there any ready build-in gpo option for this yet?
    Friday, October 23, 2015 9:20 AM
  • The registry location where sites that are set to 'Always Allow' are stored is as follows. 

    HKEY_CURRENT_USER\Software\Microsoft\Internet Explorer\FullScreen\AllowDomains

    So why have Microsoft made it so the entries that are stored in this location are deleted when the browsing history is deleted?  It makes no sense.



    I had the same annoying problem, WIN 8.1 x64 - All Updates..

    Youtube is always asking for fullscreen, yes, for privacy reason I always clear my IE Temp on exit..

    But according the HKCU Key I tried the HKLM key.. and it works.. after closing, and cleaning IE.. youtube isn't asking anymore.. try this:

    [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Internet Explorer\FullScreen\AllowDomains]
    "youtube.com"=dword:00000001

    worked for me on IE11 (on the desktop) with Win8.1 x64 - all updates (06.12.2014)


    Is there a way to replace "youtube .com" with something that covers any website? (noob, not a tech head, sorry)

    Perhaps you could try:

    *.com

    maybe that would work.  I have not tried that myself so I don't know if it would work, probably not.  You can always delete it later.  Since I don't use IE11 a lot, I don't need to.  I use FireFox for most browsing.

    Friday, October 30, 2015 5:37 AM
  • The registry location where sites that are set to 'Always Allow' are stored is as follows. 

    HKEY_CURRENT_USER\Software\Microsoft\Internet Explorer\FullScreen\AllowDomains

    So why have Microsoft made it so the entries that are stored in this location are deleted when the browsing history is deleted?  It makes no sense.



    I had the same annoying problem, WIN 8.1 x64 - All Updates..

    Youtube is always asking for fullscreen, yes, for privacy reason I always clear my IE Temp on exit..

    But according the HKCU Key I tried the HKLM key.. and it works.. after closing, and cleaning IE.. youtube isn't asking anymore.. try this:

    [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Internet Explorer\FullScreen\AllowDomains]
    "youtube.com"=dword:00000001

    worked for me on IE11 (on the desktop) with Win8.1 x64 - all updates (06.12.2014)

    For anyone who is interested, in Windows 7-64 Pro, the above key does NOT exist on my system:

    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Internet Explorer\FullScreen\AllowDomains

    This key does exist:

    HKEY_CURRENT_USER\Software\Microsoft\Internet Explorer\FullScreen\AllowDomains

    I followed AnaBna advice.  I added youtube.com to HKCU and it worked.  However, instead of using HTML5, YouTube.com switched to Flash.  I don't really care.  As long as I don't get that annoying prompt anymore, I'm fine.  I hope that the system will not delete the youtube.com key I added.  There were other domains already there such as amazon.com, vimeo.com, etc...

    Friday, October 30, 2015 5:47 AM
  • The registry location where sites that are set to 'Always Allow' are stored is as follows. 

    HKEY_CURRENT_USER\Software\Microsoft\Internet Explorer\FullScreen\AllowDomains

    So why have Microsoft made it so the entries that are stored in this location are deleted when the browsing history is deleted?  It makes no sense.



    AnaBna,

    thanks for the post.  I followed your advice.  I added youtube.com to HKCU and it worked.  However, instead of using HTML5, YouTube.com switched to Flash.  I don't really care.  As long as I don't get that annoying prompt anymore, I'm fine.  I hope that the system will not delete the youtube.com key I added.  There were other domains already there such as amazon.com, vimeo.com, etc...  My main browser is FireFox.  I don't use IE11 a lot.  I don't clear the browsing history for IE11 very often, perhaps once a year at most.

    Friday, October 30, 2015 5:51 AM
  • In Windows 10, there is no hive FullScreen\AllowDomains existing in HKLM or HKCU.
    Friday, October 30, 2015 8:57 AM
  • Big whoop.  Not interested in Windows 10 anytime soon, until all the bugs are worked out, and Microsoft removes all their spyware and control-freak methods.  This post has to do with IE 11, and non-GWX versions.  Why not read the thread and answer the issue posted?
    Sunday, February 21, 2016 4:51 PM
  • Enough about Windows 10 already.  Microsoft has crammed that down everyone's throat by now.  That's what we need an option to turn off, the GWX crap.  I deleted it  all from my PC, including files in SysWow, winsxs, and the reg keys.  I also read the "More Information" whitepaper for any "Update for Windows 7" updates, and I hide any that refer to updates, because those load more GWX crap.  Hey, Microsoft.....'NO' means 'NO', so go away.  I've used Microsoft products my entire adult life, but I'm getting very sick of your ways, and my next move will be to a competing product.  You guys stopped giving customers what THEY want, and you're trying to control us and you invade our privacy horribly.  Hear this, Microsoft:  OPTIONS ARE GOOD.
    Sunday, February 21, 2016 5:01 PM
  • Thank you for providing this registry (HKEY_CURRENT_USER\Software\Microsoft\Internet Explorer\FullScreen\AllowDomains).

    I had the same problem with Netflix (Do you want to view Netflix in full screen?). I had allowed permanently to run in full screen. Great!, but... on the first time when I was starting the video, I had two rows of white line on the bottom of the screen (just like the message was there, but not visible). When I went off full screen and went back to full screen again, I was having only black screen. I did go off and on again and finally I was getting the video I want in full screen, with no with bars. Now I only had to restart the video to have it from the beginning. I was looking for a white to the answer how to undo my permission. It is much easier for me to click red X on the question banner, than keep switching between full screen and window mode until everything works.

    I am using Internet Explorer from Win 8.1 on Surface Pro 2 machine. It's all MS products so is why at first I had allowed permanent full screen for my convenience, just to realize hassle with switching.

    Now, thanks to the register location, I took Netflix off the list, and I have the banner with red X again on the screen, which I can strike with one click and keep watching happily.

    Thank you again.

    Mark

    Wednesday, February 24, 2016 1:10 AM
  • Dear Microsoft,

    This is a stupid STUPID bug.

    Why is that you can't fix stupid bugs?

    All you need is a stupid programmer.

    You've got plenty of those, don't  you?

    • Proposed as answer by Gregdddddddddd Sunday, December 31, 2017 3:17 AM
    Monday, August 14, 2017 12:43 AM
  • I think I got it in internet explorer add site to apps (youtube spectrum etc. then take delete bowsing history off go to google thew internet explorer you can take bowsing history off the app then you can turn it back on in google then go to the app it will go to the site and not delete the app history so you wont see the message on the site page.
    Monday, December 11, 2017 9:30 PM