locked
Add new column to Content Type but do not see new columns when adding new item to library RRS feed

  • Question

  • I have a a document library (Incoming) that contains multiple content types:

    1. Invoice
    2. SupportingDocument
    3. DeleteInvoice
    4. Document

    I used the GUI to add six columns to the Invoice content type, ans esured that the Update all content types inheriting from this type? option was selected for each column added.

    When I go to my Incoming library and select New to create an Invoice document, MS Word opens up allowing me to enter the text into the document and the Invoice content type columns appear, but not the six new columns I added.

    If I go to the Advanced Setting for this library and select it to not use multiple content types, select a New Invoice document will laucnh MS Word and display all the required columns including the six new ones added.

    I need this library to use mulitple content types.

    Can anyone clue me into what the problem is?

    Tuesday, January 29, 2013 4:14 PM

All replies

  • Hi,

    How many Content Types are you using, this is more for my personal interest than supporting multiple Content Types.

    To help resolve the issue:

    Is the content type the default Content Type?

    When you click new, does the Content Type show up under the New Button > Drop Down so you can choose the Content type > Invoice to use (As an Example where Invoice is the name of your Content Type)?

    -Ivan


    Ivan Sanders My LinkedIn Profile, My Blog, @iasanders, Business Intelligence in SharePoint 2013.


    • Edited by Ivan Sanders Wednesday, January 30, 2013 2:03 AM
    Wednesday, January 30, 2013 1:58 AM
  • Three of the four content types are being used: Invoice, SupportingDocument and DeleteInvoice.

    Clicking the dropdown on the New button displays the content types Invoice and SupportingDocuments. I set it so only these two would be displayed.

    In the corect usage of this document library, a user would not insert a document into this library be clicking New. There is document scanning software (KnowledgeLake) that plugs into this Incoming library to upload PDFs and the correct metadata for each document.

    I am using the New button to proof out why the new colum data submitted through KnowledgeLake wasn't appearing in the library when a document was submitted. What I found out was that even clicking the New and selecting the needed content type (Invoice), the new columns I created weren't being presented. So that leads me to believe it is a configuration issue.

    Wednesday, January 30, 2013 1:43 PM
  • Hi,

    If the columns appear in the library, its a form issue. In other words if the columns appear in Library settings and you have not set them to hidden. Hidden will mean they do not show up in forms..

    Then the issue is most likely an issue with the New or Upload form, have there been any designers changing those forms? or could the columns be hidden?

    Have you ever used SharePoint Manager? there is a 2013 version on Codeplex that allows you to see the XML Schema for each object, don't make any changes with it, its very powerful... But you can use it to view any differences from a list with eth CTypes applied other than the one you are having issues with and compare them.

    -Ivan


    Ivan Sanders My LinkedIn Profile, My Blog, @iasanders, Business Intelligence in SharePoint 2013.

    Wednesday, January 30, 2013 6:22 PM
  • No, there wouldn't be any designers changing the forms. I will look into the hidden settings for columns.

    I have used SharePoint Manager, I have the 2007 version that I was using to peek into the XML schema.  Nothing jumped out at me when I first used it, but I will use t again and really look into it. I'll ook into downloading the 2013 version as well.

    I guess if it is a form issue, I am wondering why the KnowledgeLake software is unable to populate the six new columns with data, but can populate the other columns. Thingsd are exposed corectly to the KnowledgeLake system.

    Thanks for the help so far.

    Thursday, January 31, 2013 5:10 PM