Windows Server 2016 TP5 Virtual Ethernet initialization problem RRS feed

  • Question

  • Hello All:

     I have a problem with Windows server 2016 TP5 (that's happend too in TP4). I have the following configuration:

    4 Physical NICs attached to the server in a Team in LACP mode . Over the team we have a Virtual Switch and a virtual ethernet for the management host. After boot, the interface is showed UP, and the tcp/ip protocolo (and others) are correctly bounded and attached to the device, but the adapter doesn't work. The server is unable to send/receive any packets until a disable+enable of the virtual nic.

    Someone can help me with this or howto debug that? Maybe a problem with the team? with the virtual switch or the virtual ethernet?

    Thank you in advance, regards. Luis.

    Wednesday, May 11, 2016 1:34 PM

All replies

  • Hi Luis,

    Thanks for posting here.

    >>Someone can help me with this or howto debug that? Maybe a problem with the team? with the virtual switch or the virtual Ethernet?

    Please check if the following methods is helpful:

    Method1: check the figure below if you used hyper-v to manage the VMs

    Method2: change the teaming mode to "Switch Independent"

    Method3: check the illustration below:

    Best regards,


    Thursday, May 12, 2016 9:30 AM
  • Thanks for the reply Andy:

    The virtual ethernet is not on a VM. Is an adapter attached to the "ManagementOS". Otherwise i do a test changing Team mode from LACP to Switch independent some times, after that change, the machine boot up with network correctly. The problem seems to be related to LACP Teaming boot up procedure :-?

    Thursday, May 12, 2016 10:02 AM
  • Hi Luis,

    Thanks for your feedback.

    >>Over the team we have a Virtual Switch and a virtual ethernet for the management host

    As stated, the environment has a virtual switch and Ethernet, why we not consider using Switch independent mode?

    Switch Independent would work well for you I think because it works by balancing outbound traffic across NICs, not inbound.

    It works for you because 99% of your traffic will be outbound.

    When configuring NIC Teaming in “Switch Independent” mode, the teaming configuration will work with any Ethernet switches – even non-intelligent switches.

    I suppose the following blog might be helpful for us, for your reference:


    Best regards,


    Friday, May 13, 2016 2:10 AM
  • Hello Andy:

     Thanks for the reply. We need to configure the team in LACP mode. We have several Hyper-V cluster with a high density VM. This is the reason that we need lacp teaming. Using a failover "Switch independent" is not aceptable in our environment.

    Friday, May 13, 2016 12:54 PM
  • LACP shouldn't be an issue for you as long as you've configured LACP correctly on the physical switch you are connecting to.  We'll investigate this and get back to you soon.

    Can you please tell me what distribution mode the LACP team is in?  Is it Dynamic or HyperVPort mode?

    Don Stanwyck, Sr. PM, Windows Server Networking, Microsoft

    Friday, May 13, 2016 8:32 PM
  • Hello Don Stanwyck:

    First at all, thanks for your help. I'm contacting our networking team in order to verify the teaming capabilities and configuration of our Cisco Nexus switch, at all seams to be ok.

    Even, i can confirm that Lacp Timeout short is correctly handle by our switchs.

    The configuration that we are tested and expose the problems are in "Hyper-V Port" mode.
    Tuesday, May 17, 2016 7:46 AM
  • Today i conducted some tests againts our W2K16 TP5 servers and LACP i found that with the others Load Balacing algorithms de problem persist. Disabling the other 3 cards in team and leaving only 1 the problem persists, that makes me think that the problem is not related to load balancing algos.

    One thing to take care is that if you have been set the LacpTimeout value for enable long timings in lacp, the registry key is lost after team reconfiguration, and you will need to is needed to be set manually.

    Wednesday, May 18, 2016 9:24 AM