none
Error running dashboard in share point services 3.0 RRS feed

  • Question

  • My dashboard deployed successfully, however when I try to access it in sharepoint, I get an error.

     

    "The control type 'Microsoft.PerformancePoint.Scorecards.WebParts.ScriptManagerLoader' is not allowed on this page. The type is not registered as safe. "

     

    I followed the link here(http://forums.microsoft.com/TechNet/ShowPost.aspx?PostID=2978079&SiteID=17), edited the config file and ran the stsadm utility successfully, but it still get this error now:

     
    "Web Part Error: An unexpected error has occurred. "
     
    Changing the config file is the only thing that changed the error.  The stsadm utility and uploading master file to the site didn't make a difference.

    This might be a silly question, but could it be because the dashboard was deployed to a shared library that's not in the site collection?
     

    Thanks in advance.

    Friday, March 21, 2008 4:48 AM

Answers

  •  

    It was a silly question.  Once I wrote it out, I realized it was plain common sense.  I just had to test it out by publishig to my web part library in the site collection.  It works.
    Friday, March 21, 2008 4:57 AM

All replies

  •  

    It was a silly question.  Once I wrote it out, I realized it was plain common sense.  I just had to test it out by publishig to my web part library in the site collection.  It works.
    Friday, March 21, 2008 4:57 AM
  • MikeLR

    Can you share with us what you did to get your site to work by publishing to web part library in the site collection?

     

    We are using WSS 3.0 and trying to deploy dashboards to our site: http://owa2k3dwdev02:16216/sites/PPS/DASHBOARD/Forms/AllItems.aspx

     

    We cannot view dashboards.

    We were recieving the following error until we read blogs about modifying webconfig and following steps in below blog.

    The control type 'Microsoft.PerformancePoint.Scorecards.WebParts.ScriptManagerLoader' is not allowed on this page

    http://blogs.msdn.com/performancepoint/archive/2007/11/12/how-do-i-deploy-the-monitoring-web-part-on-a-separate-sharepoint-web-application-on-the-same-sharepoint-web-server.aspx

     

     We are still receiving following errors after following the blog steps and we are rookies with PPS and WSS 3.0 just to clarify. Help anyone???????   

     

    Thank you..  Barne

    Server Error in '/' Application.

    Runtime Error

    Description: An application error occurred on the server. The current custom error settings for this application prevent the details of the application error from being viewed.

    Details: To enable the details of this specific error message to be viewable on the local server machine, please create a <customErrors> tag within a "web.config" configuration file located in the root directory of the current web application. This <customErrors> tag should then have its "mode" attribute set to "RemoteOnly". To enable the details to be viewable on remote machines, please set "mode" to "Off".

    <!-- Web.Config Configuration File -->
    
    <configuration>
        <system.web>
            <customErrors mode="RemoteOnly"/>
        </system.web>
    </configuration>

    Notes: The current error page you are seeing can be replaced by a custom error page by modifying the "defaultRedirect" attribute of the application's <customErrors> configuration tag to point to a custom error page URL.

    <!-- Web.Config Configuration File -->
    
    <configuration>
        <system.web>
            <customErrors mode="On" defaultRedirect="mycustompage.htm"/>
        </system.web>
    </configuration>

     

     

    Friday, November 14, 2008 3:55 PM
  • We have fixed the following errors by adding the remote only then going through each error and fixing webconfig that pop up. No more errors occurred and we were able to get to our site.http://owa2k3dwdev02:16216/sites/PPS/DASHBOARD/OilGas-Operations/Operations.aspx

     

    We double click on dashboard and we receive these error now..

     

    PerformancePoint ‭[1]‬

    The database connection failed. Please contact an administrator.

    PerformancePoint ‭[2]‬

    The database connection failed. Please contact an administrator.

    PerformancePoint ‭[3]‬

    The database connection failed. Please contact an administrator.
     

    Friday, November 14, 2008 4:56 PM
  • An unexpected error occurred fixed wth..

     

    Solved the problem.

     

    Updated webcong with the following after httpModules:

     

    </httpModules>

        <webServices>

         <protocols>

         <add name="HttpGet" />

         <add name="HttpPost" />

       </protocols>

      </webServices>

     

    Tuesday, November 18, 2008 7:25 PM