locked
this computer can't connect to remote computer RRS feed

  • Question

  • Hi all,

    I have installed Terminal Services role and then I installed "Remote Desktop Connection v6-RC1" on my windows XP client.

    When I try to connect to my server I get this message : this computer can't connect to remote computer

    Any idea why ?

     

    Thank you,

    Aleks

    Thursday, November 2, 2006 8:29 PM

Answers

  • Check the remote computer firewall has the remote desktop port open.

    Make sure you server is also RC1.

    Friday, November 3, 2006 8:35 PM
  • Check the following:

    • check that the terminal services service is running
    • check the firewall port *really* is open (disable the firewall if you want to make sure)
    • ensure that your client and server are both running the matched version of TS and TS client
    • try turning the server to 'less secure; mode in the remote tab

     

    Monday, November 6, 2006 7:27 PM
  • I already tried the IPv4  address but nothing better.

    Moreover, some times, my server has ONLY an IPv6 address ... really strange (the dhcp has an IPv4 range configured but not an IPv6).

    If I found a solution I will post it here.

     

    Thank you.

    Friday, November 17, 2006 6:06 PM

All replies

  • Check the remote computer firewall has the remote desktop port open.

    Make sure you server is also RC1.

    Friday, November 3, 2006 8:35 PM
  • Hi Alex,

    The port is open (for domain, public and private network) and the server is a RC1.

    Saturday, November 4, 2006 1:47 PM
  • Aleks,

    Check authentication options on clients and Server, are you using TLS ?

    Saturday, November 4, 2006 2:21 PM
  • Where should I look to see these informations ?

    On the Client, the option is set to "Always connect, even if authentification fails"

     

    Thx

    Monday, November 6, 2006 9:16 AM
  • Check the following:

    • check that the terminal services service is running
    • check the firewall port *really* is open (disable the firewall if you want to make sure)
    • ensure that your client and server are both running the matched version of TS and TS client
    • try turning the server to 'less secure; mode in the remote tab

     

    Monday, November 6, 2006 7:27 PM
  • OK, I check everything but allways de same message.

    I just didn't find the "less secure" mode in remote tab.

     

    Now my client is running Vista RC2 and I have allways the same message.

     

    Someting else : Every time I reboot my server, the local network interface is set as Public. I have to manually change it as Private.

    Sunday, November 12, 2006 4:21 PM
  • It's hard to tell, usually this issue is caused by a comms failure (firewall, IPSEC, etc).  It is going to be tough to troubleshoot this over the forum.  The issue you talka bout the network makes me think you have an issue with the network card driver or IP stack.

    Try connecting with the IPv4 address instead of name - it could be an IPv6 issue.

    Thursday, November 16, 2006 10:08 AM
  • I already tried the IPv4  address but nothing better.

    Moreover, some times, my server has ONLY an IPv6 address ... really strange (the dhcp has an IPv4 range configured but not an IPv6).

    If I found a solution I will post it here.

     

    Thank you.

    Friday, November 17, 2006 6:06 PM
  • I am having the exact same issue under the same conditions.  I have tried all previous suggestions, but to no avail.  Any more thoughts?
    Saturday, December 2, 2006 12:42 PM
  • If you also can't see the less secure option on the tab of the host machine please upgrade to the RTM of vista on the host or the latest beta on LH Server.

    We can not replicate these issues, without netmon traces it is almost impossible to diag your whole network setup.

    All i can say is every time i have seen this issue it has been one of several things:

    • The RDP listener is not up on the host (qwinsta.exe can be used to check)
    • The firewall is enabled
    • IPSEC is enabled
    • There is some other networking / comms issue issue

    If you have RTM Vista client and a longhorn host, please bug your scenario through the LH bugging tool with as much info as possible.

     

    Alex

    Saturday, December 2, 2006 7:51 PM
  • I had the same problem and tried all of the suggestions without any help. 

    For some reason after installing TS Client 6 the "Allow users to connect remotely to this computer" under the Remote tab had become unchecked. Rechecking it fixed it.
    Thursday, December 7, 2006 7:22 PM
  • I had a similar problem getting the client to connect to the server.  On the server my "Allow users to connect remotely to this computer" was already checked.  So I unchecked it "clicked apply" then rechecked it and "clicked apply". Went to the client clicked connect and it started working.
    • Proposed as answer by BlaneUSC Monday, June 21, 2010 3:14 PM
    Saturday, February 24, 2007 5:42 PM
  • Came across another possible fix for this problem - disable the Routing and Remote Access service on the client machine.
    Tuesday, July 10, 2007 8:24 PM
  •  

    run  remote desktop and used

     

    <hostname>:3389    to access remote

     

     

    Thursday, November 8, 2007 4:20 AM
  • I had the same problem and tried all of the above.  Discovered that the system was waiting for a restart.  Restarted the server and I could then connect without any more problems.

    Wednesday, December 12, 2007 6:33 PM
  • Check the terminal services configuration under admin tools. Make sure the RDP connection is enabled and has a NIC selected or using any available.
    Friday, July 18, 2008 8:43 PM
  • Try this:
    1. Open Regedit and find the following key:

      HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Ext\Settings
    2. Within the Settings sub-key, delete the following sub-keys:

      {4eb89ff4-7f78-4a0f-8b8d-2bf02e94e4b2}
      {7390f3d8-0439-4c05-91e3-cf5cb290c3d0}

    I only had the first ket but it worked.  We went from a Win2k terminal server to 2008 and ran into the same issue.  Should only need for XP machines.  Here is the source :

    http://www.msterminalservices.org/articles/Windows-Server-2008-Terminal-Services-Web-Access-Part2.html

    Friday, October 31, 2008 12:02 AM
  • Yeah..old post, but another possibility. Ensure the local IPs (PC, router/firewall, etc.) are NOT the same IP as the Remote Server....been there done that!
    Thursday, September 3, 2009 4:04 PM
  • Found another reason why this occurs.  Kaspersky virus scanner holds the remote session in limbo when a remote session is closed and prevents others from remoting in. It is possible to kill the pid but it is wiser to modify Kaspersky settings and make it a little less aggressive by allowing other processes to stop it. In particular the svchost needs to be able to stop the kaspersky process when the session is closed. This may also be an issue with other virus scanners.

     

    Monday, May 17, 2010 7:09 AM
  • Another reason - wrong entry in the hosts file of your machine referencing the remote server. check that.
    philip
    Thursday, January 13, 2011 9:34 PM
  • Hi,

    Please help me

    I am useing Windows multipoint server 2010 on 1 computer & I can remote desktop to it normaly

    I installed this windows on new computer which didn't recognize my LAN card so I installed it's driver.

    every thing works normaly I just can't remote desktop to this new computer.

    I checked & understood this computer listen to ipv6 port 3389 but don't listern to ipv4 3389 port!

    what can I do to make this computer to listen to post 3389 on ipv4 also?

    every thing elseworks normaly & firewall is off.

    thanks 

    Wednesday, June 8, 2011 11:47 AM
  • A restart fixed my problem. This started after a Windows update occurred.

     

    Wednesday, August 24, 2011 5:57 PM
  • Same error message, when chkin the tcp\ip dns properties on the on the machine I was running the rdp from saw the domain name put in there manually, removed that, flushed dns and it works now.  
    Friday, December 7, 2012 10:18 PM
  • Wish that would have been in engilsh for non IT Tech folks.
    Friday, April 10, 2015 3:51 AM