locked
IC 3.2 on CentOS 6.1, synthetic network adapters cannot be detected RRS feed

  • Question

  • Hello,

    I tried IC 3.2 on a clean CentOS 6.1 today. Everything is great (simple installer, mouse driver, etc.), but after the installation and reboot, synthetic network adapters cannot be detected. There is only a loopback (lo) adapter after running ifconfig.

    This occurs on IC 3.1/CentOS 6.0 too.

    Can anyone give some hints to activate the synthetic network adapter?

    Thanks in advance.

    Wednesday, December 21, 2011 8:03 AM

Answers

  • Did you disable NetworkManager? That is the easiest way to get it working.

    As far as the DVD - the solution for that is included in the read me. In order to get the fastpath IDE channel working, we need to blacklist the loading of the ata_piix module. You can manually load ata_piix as root to gain access to the DVD drive in the VM, or copy the ISO file into the VM and mount it using -o loop.


    This posting is provided "AS IS" with no warranties, and confers no rights.
    Sunday, December 25, 2011 7:55 PM

All replies

  • I have the same question.

    Not only the network cannot be detected, but also the cdrom /dvd  has not be detected  .

     

    Wednesday, December 21, 2011 1:10 PM
  • Did you disable NetworkManager? That is the easiest way to get it working.

    As far as the DVD - the solution for that is included in the read me. In order to get the fastpath IDE channel working, we need to blacklist the loading of the ata_piix module. You can manually load ata_piix as root to gain access to the DVD drive in the VM, or copy the ISO file into the VM and mount it using -o loop.


    This posting is provided "AS IS" with no warranties, and confers no rights.
    Sunday, December 25, 2011 7:55 PM
  • // Did you disable NetworkManager? That is the easiest way to get it working.

    I tried two ways to disable NetworkManager. The 1st one is to follow this instruction to disable NM in config file of eth0: http://www.convirture.com/ee_wiki/index.php?title=RedHat_6_Networking, but it does not work.

    The 2nd way is to stop and disable the NM service, but it looks there is no NM service on my VM (as a CentOS 6.2 minimal installl):

    #service NetworkManager stop
    NetworkManager: unrecognized service

    #chkconfig NetworkManager off
    error reading information on service NetworkManager: No such file or directory

    Wednesday, December 28, 2011 7:58 AM
  • Same as Vista Xia, networkmanager isn't installed, so the problem persists. 

     

    Using Centos 6.2 minimal install and LIC 3.2.

    Any ideas?

    Sunday, January 22, 2012 12:06 PM
  • Add a file /etc/sysconfig/network with the following:

    NETWORKING=yes

    Then, add a file called /etc/sysconfig/network-scripts/ifcfg-eth0 with the following (assuming you're using DHCP):

    DEVICE=eth0

    ONBOOT=yes

    BOOTPROTO=dhcp


    This posting is provided "AS IS" with no warranties, and confers no rights.
    • Proposed as answer by Chris-Smith Thursday, March 8, 2012 9:53 PM
    Sunday, January 22, 2012 4:39 PM
  • About the optical drive: Most often current linux kernels will recognize the first optical drive as /dev/sr0

    I can confirm that sometimes you need to create the ifcfg-eth0

    Also have a look at the following file: /etc/udev/rules.d/70-persistent-net.rules

    If you did boot with both a legacy and a paravirt NIC, you might see that your additional NIC was recognized by udev as eth1

    Monday, January 23, 2012 10:22 PM
  •   I found the same problem with RHEL6 & CentOS6.  Once I assigned a static MAC address to the NIC, eth0 showed up.


    • Edited by CWarner1974 Sunday, February 5, 2012 2:37 PM
    Sunday, February 5, 2012 2:32 PM