locked
XP sp3 and Remote Web Workplace RRS feed

  • Question

  •  

    I installed XP SP3 and was unable to gain access to my workstation at work via Remote Web Workplace.  Whenever I select a computer from the list of available clients, it is unable to download the Remote Desktop Activex Control because of security settings preventing the download.  I set the security to allow all activex controls (which shows a nag about unsafe security settings) This kills the Remote Desktop Activex....message but then an "invalid server name" error pops up. Only resolution offered was to delete a registry key that was non-existant in my registry.

     

    I am able to use RWW with my XP SP2 laptop with no issues.

     

    Home Computer

     

    AthlonXP 3200+

    1gb ram

    2x120gb ide hdd

    1x320gb usb hdd

    nvidia 7600gs 512mb

    Windows XP SP3 RC1 IE7 WMP11 .NET3.5

    BitDefender 2008 AntiVirus

    Office 2007

     

    Server at Work

     

    Dell Poweredge SC430 P4 3.0ghz

    3gb ram

    2x 80gb SATA HDD

    2x 500gb USB HDD

    Vexira Anti-Virus

    Windows Server 2003 SBE

    Exchange disabled

    Latest updates and service packs

     

     

    Tuesday, January 22, 2008 10:52 PM

Answers

  • Wutty3:

     

    There is a problem with Service Pack 3 and Remote Web Workplace.  You will need to use System Restore to return the pc back to the state that it was before the SP3 install (uninstalling SP3 through add/remove programs will not remove the problem).

     

    I installed SP3 on my work pc 2 weeks ago.  Last week I tried to access a customer's pc using Remote Web Workplace (which I may have to do once or twice a month) and got the message: "This portion of the Remote Web Workplace requires the Microsoft Remote Desktop ActiveX control. Your browser's security settings may be preventing you from downloading the ActiveX controls. Adjust these settings, and try to connect again."  I tried adjusting the security settings to allow everything and added the server's URL to the trusted sites list but I could not get the ActiveX control to install.  I uninstalled SP3 through add/remove programs and the problem still existed.  I could get it to work with a Vista pc (yuck!) and on 3 other XP systems with SP2.  I tried another system belonging to another engineer with SP3 installed and I got the same error message.  I searched forums and blogs for days to only find the same resolution about removing a sub-key but nothing else.  It wasn't until I did a system restore (today) on my pc back to the point before SP3 was installed that I was able to get it to work again.  I have since searched Microsoft and have not found anything about this issue.  As a Micro$oft Provider, my company will probably file a report with them tomorrow.

     

    So, performing a system restore back to before the SP3 installation should fix your problem.  Oh and be sure to add your server to the trusted sites list and set the settings to enable or prompt for Download signed ActiveX controls and Download unsigned ActiveX controls if you haven't already.

     

    Good Luck,

    James

    Wednesday, January 23, 2008 2:33 AM

All replies

  • Wutty3:

     

    There is a problem with Service Pack 3 and Remote Web Workplace.  You will need to use System Restore to return the pc back to the state that it was before the SP3 install (uninstalling SP3 through add/remove programs will not remove the problem).

     

    I installed SP3 on my work pc 2 weeks ago.  Last week I tried to access a customer's pc using Remote Web Workplace (which I may have to do once or twice a month) and got the message: "This portion of the Remote Web Workplace requires the Microsoft Remote Desktop ActiveX control. Your browser's security settings may be preventing you from downloading the ActiveX controls. Adjust these settings, and try to connect again."  I tried adjusting the security settings to allow everything and added the server's URL to the trusted sites list but I could not get the ActiveX control to install.  I uninstalled SP3 through add/remove programs and the problem still existed.  I could get it to work with a Vista pc (yuck!) and on 3 other XP systems with SP2.  I tried another system belonging to another engineer with SP3 installed and I got the same error message.  I searched forums and blogs for days to only find the same resolution about removing a sub-key but nothing else.  It wasn't until I did a system restore (today) on my pc back to the point before SP3 was installed that I was able to get it to work again.  I have since searched Microsoft and have not found anything about this issue.  As a Micro$oft Provider, my company will probably file a report with them tomorrow.

     

    So, performing a system restore back to before the SP3 installation should fix your problem.  Oh and be sure to add your server to the trusted sites list and set the settings to enable or prompt for Download signed ActiveX controls and Download unsigned ActiveX controls if you haven't already.

     

    Good Luck,

    James

    Wednesday, January 23, 2008 2:33 AM
  • Hi,

     

    Can you please confirm if the machine was running IE6 or IE7?

     

    Thanks

    Shashank

     

    Thursday, January 24, 2008 4:18 AM
  • My  install is IE7 Version 7.0.5730.11

    Monday, January 28, 2008 2:17 AM
  • Actually you can run SP3 and RWW but you probably need to do several steps. I have found though that a follow up SP3 release broke RWW again and this time I am still searching for a full fix.

     

    You can try these steps (use at own risk but what could it break Wink

     

    1. Click Start-->Run, type following command and click OK.


    regsvr32 /u "%windir%\downloaded program files\msrdp.ocx"


    2. Click Start-->Run, type regedit and click OK.
    3. Search for msrdp.ocx, export and then delete all the keys found.
    4. Restart the client and check if the issue persists.


    Other possible fixes:

    Please click Start-->Run, type CMD and click OK. Then run following
    commands:


    regsvr32 urlmon.dll /s
    regsvr32 hlink.dll /s
    regsvr32 msjava.dll /s
    regsvr32 mshtml.dll /s
    regsvr32 jscript.dll /s
    regsvr32 vbscript.dll /s
    regsvr32 shdocvw.dll /s
    regsvr32 browseui.dll /s
    regsvr32 actxprxy.dll /s
    regsvr32 softpub.dll /s
    regsvr32 scrrun.dll /s
    regsvr32 shell32.dll /s
    regsvr32 Oleaut32.dll /s
    regsvr32 wintrust.dll /s
    regsvr32 dssenh.dll /s
    regsvr32 rsaenh.dll /s
    regsvr32 cryptdlg.dll /s
    regsvr32 dssenh.dll /s
    regsvr32 rsaenh.dll /s
    regsvr32 gpkcsp.dll /s
    regsvr32 sccbase.dll /s
    regsvr32 slbcsp.dll /s
    regsvr32 cryptdlg.dll /s
    regsvr32 schannel.dll /s
    regsvr32 wuapi.dll /s
    regsvr32 wuaueng.dll /s
    regsvr32 wuaueng1.dll /s
    regsvr32 wucltui.dll /s
    regsvr32 wups.dll /s
    regsvr32 wuweb.dll /s
    regsvr32 atl.dll /s
    regsvr32 wucltui.dll /s
    regsvr32 initpki.dll /s

    I'll post back if I find the fix to the fix Wink

     

    James

    MCTS-SharePoint, MCTS-Vista, MCP, SBSC

     

    (Update Fix)

    Fix: You attempt to connect to a Desktop or Server via RWW and you get the following:

    "This portion of the Remote Web Workplace requires the Microsoft Remote Desktop ActiveX Control. Your browser's security settings may be preventing you from downloading ActiveX controls. Adjust these settings and try to connect again."

    1. Internet Options, Security, Internet, Custom Level, ActiveX Controls and Plug-ins:

    "Allow previously unused ActiveX controls to run without prompt"

    Set to enabled, restart IE, try RWW again, make a server or desktop connection and you will be prompted to reinstall the RWW ActiveX control, install it and finish connection to server or desktop. Set the control to default and you should be fine.

    http://ms-smallbizspecialist.spaces.live.com/blog/cns!9E987AEC92625AB9!345.entry

    Sunday, February 10, 2008 2:59 AM
  • BTW I've noticed if you update SP3 to the later builds it will break RWW again but all I had to do was repeat Steps 1-3.

     

    Friday, February 22, 2008 3:33 AM
  •  

    After you get connect to computer page on RWW, do following steps:

    1) go to Tools->Manage Add-ons->Enable or Disable add-ons..

    2)You would see "Microsoft Terminal Services Client Control" ActiveX disabled. Please select it and enable it.

     

    Now try connecting to remote computer using RWW. It should work fine.

     

    If it still does not work please let me know following things:

    1) On Manage Addon tab do you see "Microsoft Terminal Services Client Control" or "microsoft RDP Client Control" ?

    2) Scroll the Manage Addon tab to right and check what file name is associated with above ActiveX. Is it msrdp.ocx or mstscax.dll?

     

    If it is msrdp.ocx, pls do the following:

    1) del "%windir%\downloaded program files\msrdp.ocx"

    2) reload RWW page.

    3) After you get connect to computer page on RWW

    4) go to Tools->Manage Add-ons->Enable or Disable add-ons..

    5)You would see "Microsoft Terminal Services Client Control" or "Microsoft RDP client Control" ActiveX disabled. Please select it and enable it.

     

    RWW should work fine now.

     

    Please update if things work fine.

    Saturday, February 23, 2008 4:17 PM
  • After you get Connect to computer page on RWW, please do the following steps:
    1)go to tools->Manage Add-ons->Enable or Disable add-ons..
    2)On manage addons tab you will see "Microsoft Terminal Services Client control" ActiveX disabled. Please select the ActiveX and enable it.

    After this you should be abled to connect to remote computers using RWW.

    If it still doesnt work please let me know the following things:
    1)On Manage Addon Tab do you see "microsoft terminal Services Client Control" ActiveX or "Microsoft RDP client Control" ActiveX?
    2)Corresponding to above activeX, what is the value in file column in manage addon tab? is it mstscax.dll or msrdp.ocx?


    If it is msrdp.ocx, do the following:
    1) del "%windir%\downloaded program files\msrdp.ocx"
    2) reload RWW page.
    3) After you get Connect to computer page on RWW,go to tools->Manage Add-ons->Enable or Disable add-ons..
    4)On manage addons tab you will see "Microsoft Terminal Services Client control" or "Microsoft RDP client control" ActiveX disabled. Please select the ActiveX and enable it.


    RWW problem should go away now.
    Please update the thread if it works fine.

    Saturday, February 23, 2008 4:34 PM
  •  

    After you get Connect to computer page on RWW, please do the following steps:
    1)go to tools->Manage Add-ons->Enable or Disable add-ons..
    2)On manage addons tab you will see "Microsoft Terminal Services Client control" ActiveX disabled. Please select the ActiveX and enable it.

    After this you should be abled to connect to remote computers using RWW.

    If it still doesnt work please let me know the following things:
    1)On Manage Addon Tab do you see "microsoft terminal Services Client Control" ActiveX or "Microsoft RDP client Control" ActiveX?
    2)Corresponding to above activeX, what is the value in file column in manage addon tab? is it mstscax.dll or msrdp.ocx?


    If it is msrdp.ocx, do the following:
    1) del "%windir%\downloaded program files\msrdp.ocx"
    2) reload RWW page.
    3) After you get Connect to computer page on RWW,go to tools->Manage Add-ons->Enable or Disable add-ons..
    4)On manage addons tab you will see "Microsoft Terminal Services Client control" or "Microsoft RDP client control" ActiveX disabled. Please select the ActiveX and enable it.


    RWW problem should go away now.
    Please update the thread if it works fine.

    Saturday, February 23, 2008 5:02 PM
  • Neither msrdp.ocx or mstscax.dll are listed in the Manage Add ons lists tried downloading and installing but no go.

     

    STILL NOT WORKING

     

    Sunday, February 24, 2008 9:18 PM
  •  

    What is the XPSP3 build? you can get it by typing "winver" in run command.
    Monday, February 25, 2008 10:06 AM
  • I have the same issue (SP3 RC2 - build 3311 and IE7 7.0.5730.13). I loaded a fresh copy of XP SP2 and installed SP3 RC1. I went to use RWW and the ActiveX control would not work. I removed RC1 and installed the ActiveX control just fine. I then went to RC2 and removed the ActiveX control to see if the problem with installing the ActiveX control still exists with RC2 and it does. Now I am trying the fixes from the posts above to see if I can get the ActiveX control to install with RC2. It sure would be nice if this issue is resolved by the release of SP3 so that way I don't have to visit all of my RWW users' PCs.

     

    -Dan

     

    Monday, February 25, 2008 4:15 PM
  • Unregistering the .OCX file and removing every instance of it in the registry fixed my problem.

     

    -Dan

     

    Monday, February 25, 2008 4:19 PM
  •  

    As Wutty3 mentioned that nither mstscax.dll nor msrdp.ocx in visible in manage addons tab... This was a know bug in RC1 build and has been fixed in RC2.

    So if you install RC2 build, then all you have to do is, go to manage addon tab and enable "Microsoft RDP client control" activeX. After this RWW must work fine.

     

    Hi Dan, you mentioned "see if the problem with installing the ActiveX control still exists with RC2 ". Can you please elaborate on installing ActiveX contol. How did you try installing ActiveX and what problem did you face?

     

    Thanks

    Wednesday, February 27, 2008 4:48 AM
  • Downloaded and installed Build 3311 and rebooted. Opened IE7 and went to Tools-- Internet Options--Advanced-- Reset Intenernet Explorer Settings and hit reset. Went to my RWW url and IT WORKED :-))  Build 3311 fixed the problem.

     

    Active X control downloads and am able to access my computer at work

    Friday, February 29, 2008 3:13 AM
  •  

    I am Happy that RWW is working fine for you.

    Did you try the steps I had suggested? I do not recommend using reset option in IE.

     

    The method i have mentioned (to enable TS client Control ActiveX in Manage addons) is by design. The idea behind it is to promote security.

    Friday, February 29, 2008 7:11 AM
  • Here are the steps I took that produced the problem.

     

    1) Uninstalled RC1 (ActiveX control never worked in RC1)

    2) Installed all updates while running with SP2.

    3) Installed ActiveX control to see if it would work after uninstall of RC1 - it did.

    4) Removed ActiveX control through Downloaded Program Files folder in Windows directory.

    5) Installed RC2

    6) Tried to install ActiveX control again (from RWW page). No dice.

    7) Removed registry keys as noted above and rebooted. Installed ActiveX control and it worked.

    Sunday, March 2, 2008 2:55 AM
  •  Never could download, install, or enable the activex control with the build prior to 3311, whichever that was. In my case whatever was broke in the previous build was fixed after the installation of the standalone version of 3311. Be advised that The Windows Update Script that was released earlier wouldn't download 3311. Had to get the standalone version.

     

    Wutty3

    Sunday, March 2, 2008 3:52 AM
  • Hi

    I am experiencing the same /similar problem This has just started after I have been able to access work server remotely and making no major recent changes that may have caused this issue 

    I'm have been running XP SP3 for some time My version details: 5.1 2600 v.3264 Build 2600 

    The error msg "The pre-release version of Remote Desktop connection has expired To down load the full version of 'RDC' go toWindows Update or contact your system administrator" 

    I have checked Windows Update & cannot find an appropriate download 

    Any suggestions or can you advise link to help?

     

    Thanks

     

    Friday, April 11, 2008 11:36 PM
  •  Kowhai53 wrote:

    I'm have been running XP SP3 for some time My version details: 5.1 2600 v.3264 Build 2600 

    The error msg "The pre-release version of Remote Desktop connection has expired To down load the full version of 'RDC' go toWindows Update or contact your system administrator" 

    I have checked Windows Update & cannot find an appropriate download 

    Any suggestions or can you advise link to help?

    Yes, uninstall the outdated RC build of SP3 you've installed and install RC2 refresh build 5508 to resolve (not only) this issue. See http://forums.microsoft.com/TechNet/ShowPost.aspx?PostID=3132696&SiteID=17 (atul bhartia [MSFT]) for your reference and http://forums.microsoft.com/TechNet/ShowPost.aspx?PostID=3061999&SiteID=17 on how to get RC2 refresh build 5508 (in case you can't wait unintil the final version of SP3 will be released).


    Bye,

    Freudi

    Saturday, April 12, 2008 6:23 AM
  • This worked for me...

     

    James

    MCTS-SharePoint, MCTS-Vista, MCP, SBSC

     

    (Update Fix)

    Fix: You attempt to connect to a Desktop or Server via RWW and you get the following:

    "This portion of the Remote Web Workplace requires the Microsoft Remote Desktop ActiveX Control. Your browser's security settings may be preventing you from downloading ActiveX controls. Adjust these settings and try to connect again."

    1. Internet Options, Security, Internet, Custom Level, ActiveX Controls and Plug-ins:

    "Allow previously unused ActiveX controls to run without prompt"

    Set to enabled, restart IE, try RWW again, make a server or desktop connection and you will be prompted to reinstall the RWW ActiveX control, install it and finish connection to server or desktop. Set the control to default and you should be fine.

    http://ms-smallbizspecialist.spaces.live.com/blog/cns!9E987AEC92625AB9!345.entry

    Thursday, May 29, 2008 2:41 AM
  • There seems to be a huge amount of confusion on this subject but no one seems to state the real issue, which is that the Object Model between MSRDP version 5 and 6x has changed.

     

    If you have upgraded to sp3 then you need to use the new object model.

     

    I have posted information on my blog with examples of using each object model.

     

    http://www.aboutmeadows.com/archive/2008/07/12/rdp-rww-remote-desktop-remote-web-workplace-sp3-again.aspx

     

    I hope this helps.

     

    Larry Meadows

    http://www.AboutMeadows.com

     

    Tuesday, July 22, 2008 6:48 PM
  • where did you find build 3311?  windowsupdate is of no help, and I have only found the ISO file of service pack 3.

     

    Thanks!

     

    Thursday, October 9, 2008 4:39 PM
  • Hi

     

    Was wondering did you find a solution to the problem as I have wasted 4 hours getting to this blog and finding its a microsoft issue. Has a fix been posted to your knowledge. all help gratefully accepted

     

    ta

     

    Thursday, October 16, 2008 2:38 PM
  • I don't know if your problem has been fixed with all the things that have been said but just go into the registry and delete the following

     

    HKCU\Software\Microsoft\Windows\CurrentVersion\Ext\Settings\{7390f3d8-0439-4c05-91e3-cf5cb290c3d0} HKCU\Software\Microsoft\Windows\CurrentVersion\Ext\Settings\{4eb89ff4-7f78-4a0f-8b8d-2bf02e94e4b2)

     

    This is will fix the problem for the current user. If you add a new profile to the computer you will have to do the same thing over again.....

     

    Daniel

    Friday, October 24, 2008 11:00 PM
  • Dude,
    Guys this is a lot easier than it seems. If you are running IE7 just reset it, reinstall your plugins and activex controls and you will be fine.

    How do you reset?
    In Internet Options select the Advanced tab and click the Reset button. This isn't a major ordeal.

    Don't do a system restore, re-register services, etc. You will only be asking for more issues.

    I have many many clients that use RWW and XP SP3 and this has worked 100% of the time.


    Good luck.
    • Proposed as answer by MarcTACC Friday, February 6, 2009 4:55 PM
    Friday, February 6, 2009 4:54 PM
  • Sometimes I find these posts a little vague, so I want to clarify. Do you preform this "reset" on the target machine you are trying to access, or on the initiating box.

    Example of my confusion is also the post above yours, do you make the registry edit on the target machine?

    I am having the same problem several express in that I was able to do both RWW and RDP to my office desktop with no problems under XP SP2, but the instant I installed SP3 I lost both. As simple explanation/instruction from those trying to help would be "do this on the target machine" and/or "do this on the initiating machine."

    Thanks for the help!
    Bill
    Friday, February 6, 2009 5:19 PM
  • Put the domain in the username like so: domain\username .

    Then enter password of course.

    Tuesday, October 11, 2011 9:52 PM
  • "Remote Desktop Web Connection ActiveX control could not be installed. A connection cannot be made without a working installed version of the control. Please contact the server administrator. Verify that the RDP ActiveX is not disabled."

    Hi, this is the issue with XP SP3. If you install XP SP3 right after fresh XP install then this issue is observed even if you try to add from yellow bar appears and suggesting to install activeX in some cases due to strict security policies is not helpful. If you have upgrade SP2 to SP3 then this issue is not observed.  

    Solution : To get rid of this issue you can install RDP client 7.0. It will create all necessary registry entries, ActiveX and RDP web component. You can obtain the RDP client 7.0 from http://www.microsoft.com/download/en/details.aspx?displaylang=en&id=20609


    Sunday, March 18, 2012 6:10 PM