none
Applications failed to install on VM during OSD TS

    Question

  • Hi Folks

    I'm facing a weird issue. I'm using SCCM 2012 (Without SP1) along with MDT 2012 Update 1. I have an OSD TS which is running absolutely fine & successfully installing applications on desktop & laptops. When I tried to run the same TS on a VM, OS got installed however none of the applications got installed. I'm not using dynamic variables to install applications.

    I'm getting a generic error in TS when it tried to install applications. Below is the snippet of smsts.log file

    CAppMgmtSDK::GetEvaluationState ScopeId_091F899A-C6B6-4B09-A045-06FDB3940EDE/RequiredApplication_1f2b05f0-f779-4051-a1a1-16116d6ea94b.9 = EnforcementFailed DCMAgent 16/04/2013 11:35:16 2320 (0x0910)
    Installation job completed with exit code 0x00000000 InstallApplication 16/04/2013 11:35:16 2320 (0x0910)
    Execution status received: 4 (Application failed to install ) InstallApplication 16/04/2013 11:35:16 2320 (0x0910)
    Installation failed. InstallApplication 16/04/2013 11:35:17 2320 (0x0910)
    Setting TSEnv variable 'SMSTSInstallApplicationJobID__ScopeId_091F899A-C6B6-4B09-A045-06FDB3940EDE/Application_1f2b05f0-f779-4051-a1a1-16116d6ea94b'='' InstallApplication 16/04/2013 11:35:17 2320 (0x0910)
    Completed installation job. InstallApplication 16/04/2013 11:35:17 2320 (0x0910)
    Step 8 out of 9 complete InstallApplication 16/04/2013 11:35:17 2320 (0x0910)
    Install application action failed: 'Adobe Reader v11 x32'. Error Code 0x80004005 InstallApplication 16/04/2013 11:35:17 2320 (0x0910)

    I know this error may relate to access/name resolution/content not found etc however I do not suspect any thing related either to name resolution or access or content availability.

    Another interesting thing is that the same applications are being installed on VMs independently i.e. outside of OSD TS.

    I also checked DCMAgent.log & CIAgent.log files during OSD however nothing suspicious found in these log files. AppEnforce.log file is not created on the client during OSD. There is no error reported in AppDiscovery.log file against the applications present in OSD TS.

    Is there anything special that I need to define in OSD TS so that applications can be installed on VM?

    Any ideas experts!!!


    Cheers | Navdeep Sidhu

    Tuesday, April 16, 2013 12:33 PM

All replies

  • While digging further in CIStateStore.log file, I found below information against one of the application which failed to install

    [ScopeId_091F899A-C6B6-4B09-A045-06FDB3940EDE/RequiredApplication_1f2b05f0-f779-4051-a1a1-16116d6ea94b.9] CIEnforceState changed: Downloading Content --> DownloadContentSuccess

     [ScopeId_091F899A-C6B6-4B09-A045-06FDB3940EDE/RequiredApplication_1f2b05f0-f779-4051-a1a1-16116d6ea94b.9] AreDetailsUpdated:No

    [ScopeId_091F899A-C6B6-4B09-A045-06FDB3940EDE/RequiredApplication_1f2b05f0-f779-4051-a1a1-16116d6ea94b.9] CIEnforceState changed DownloadContentSuccess --> EnforcementExecutionFailure

    [ScopeId_091F899A-C6B6-4B09-A045-06FDB3940EDE/RequiredApplication_1f2b05f0-f779-4051-a1a1-16116d6ea94b.9] CIEnforceError changed: 0x0 --> 0x87d00317

    Let me know if anybody faced this similar issue


    Cheers | Navdeep Sidhu

    Tuesday, April 16, 2013 5:44 PM