none
DPM 2007 Tape Backup Failure ID 998 RRS feed

  • Question

  • When trying to back up user folders on a terminal server the tape backup fails:

    The operation failed because of a protection agent failure. (ID 998 Details: An existing connection was forcibly closed by the remote host (0x80072746))

    After looking at the logs on DPM and the terminal server the problem seems to be related to McAfee Virus 8.7.0.570.  If the McAfee On-Access Scan detects a file it thinks it is a threat, it tries to automatically clean the file.  DPM stops synchronizing after that and the only way to get a complete backup is to go in and manually clean the file and then start the backup again.

    Has anyone else had this problem? Is there a fix for this?

    • Moved by Praveen D [MSFT] Monday, July 19, 2010 6:25 AM Moving to DPM Tape Protection Forum (From:Data Protection Manager)
    Wednesday, July 14, 2010 1:27 PM

Answers

All replies

  • I had the same error on one of my DPM 2007 servers writing user folders to tape from disk backup.  The tape backup would get to the same point in the amount of data transfered (in my case 260GB) and fail with the error you mentioned.  After several retries on the same job, I received a new error, an "ID 2033: The media is write protected" and it gave me a specific path in the Replica to a file in a user's directory that apparently it was having trouble writing to tape; even though the disk backups were working fine. 

    What ended up working for me was using the mountvol command to mount the Replica for the resource that kept failing to tape.  Once mounted, I simply went to the directory of the user that the error mentioned having an issue backing up and deleted the file that it could not backup.  Once I deleted the file and disconnected the mountvol, I retried the tape job a few more times and it worked on the second pass and every subsequent pass.  I happen to have SEP installed on both servers but nothing in my logs indicated SEP as blocking anything but rather the DPM error indicated it was getting stuck on a file in the Replica and then ultimately timing out.

    Thursday, July 15, 2010 3:45 PM
  • closing post to clean house.
    Regards, Mike J. [MSFT] This posting is provided "AS IS" with no warranties, and confers no rights.
    Saturday, January 8, 2011 1:08 AM
    Moderator
  • Hi Jeff

    I'm facing the same issue. I disabled the SEP on my DPM server but still no success. I am not able to find the directory where it would stop, DPM is not indicating anything in the console. Please help with the mountvol command.

    Regards

    Pavit


    Pavit Bhutani

    Wednesday, September 12, 2012 6:49 AM