locked
Server 2003 R2 Crippled after latest WSUS updates RRS feed

  • Question

  • I'm posting this because I'm stuck with a problem that has affected all Windows Servers (both 2003 and 2008) that I've installed the latest group of WSUS patches on. 

    After installation of these updates, the server hangs on restart at "Applying computer settings...". It hangs at that dialogue for between one and two hours. Eventually if I'm patient I can get to the desktop, but the server is incredibly slow. One of my servers can't be logged onto and is hung at "Logging off..." after I attempted to restart it through the Windows interface.

    This has also affected several of my Server 2008 servers, but eventually I was able to log onto them, then shut them down, then when they started back up they seem to be functioning normally.

    It appears I am able to restart in Safe Mode, so if there are any suggestions as to a fix that can be implemented in Safe Mode that is an option.

    Has this happened to anyone else and is there anything I can do to get my servers back in operation?

    Tuesday, April 7, 2015 10:17 PM

All replies

  • The patches, kernel and servicing methods between server 2003 and 2008 are completely different structure. What happens if the network cable is unplugged? This sounds typical of DNS config or related issues.

     

     

     


    Regards, Dave Patrick ....
    Microsoft Certified Professional
    Microsoft MVP [Windows]

    Disclaimer: This posting is provided "AS IS" with no warranties or guarantees , and confers no rights.

    Wednesday, April 8, 2015 1:57 AM
  • The server in question affected yesterday is a physical server 2003 R2 that is also an AD DC. The other servers were virtual servers running on ESXi 4.1 

    Until the physical server was affected yesterday I was troubleshooting it as a VMware problem. Not until I installed this batch of patches on the physical and it began having the same symptoms did I begin to realize it had to do with the patches and not ESXi.

    However today and tomorrow I have pre-scheduled training events that will have me away from the server room. We have fail-over servers that have not been patched or affected by this running for now.

    Another thing is that most services still seem to work despite this. One of the VM's is a web server and IIS is still fully operational.

    SCCM client agents are not working though, as daily programs by SCCM are not running on the affected servers.

    It may be several days before I am able to do followup troubleshooting due to the frenzied nature of my schedule this week but I will report back what I find when I get back there.

    Thank you for your patience and I do appreciate any tips and suggestions on this.

    Wednesday, April 8, 2015 8:55 AM
  • Posting an unedited ipconfig /all of problem server and DC/DNS server may help. For SCCM issues I'd try them over here.

    https://social.technet.microsoft.com/Forums/en-us/home?category=systemcenter2012configurationmanager

     

     

     


    Regards, Dave Patrick ....
    Microsoft Certified Professional
    Microsoft MVP [Windows]

    Disclaimer: This posting is provided "AS IS" with no warranties or guarantees , and confers no rights.

    Thursday, April 9, 2015 12:14 AM
  • Hi Highspeedlane,

    Did you try to remove all the GPO for this servers, if you are using roaming profile please switch it to local profile or backup your personal files then delete your local profile then monitor this issue again.

    Switch between a roaming and local user profile

    https://technet.microsoft.com/en-us/library/cc736736%28v=ws.10%29.aspx?f=255&MSPPError=-2147217396

    I’m glad to be of help to you!


    Please remember to mark the replies as answers if they help and unmark them if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com

    Friday, April 10, 2015 5:51 AM
  • A little update from today.

    This is a closed network not connected to the WWW so I am unable to post any config info. I have the physical server back up but the virtual server is only partly working (I have a work around that lets me log on locally).

    To refresh, these are both Server 2003 R2 Ent. One is physical and is DC/AD/DNS. The other is virtual, is a web server, and is hosted on ESXi 4.1. Servers were performing normally until a group of 6 WSUS updates were applied. Once that happened and the servers were restarted, they both would hang at the "Applying computer settings..." screen and stay there for days. Some services would still be available to the network and others were not (IIS still worked on the web server).

    What I did today on the physical server:

    1. Cold booted with network adapter disconnected - result: no change

    2. Booted into Safe Mode and removed all updates that were applied last from WSUS - result: no change

    3. Booted into Safe Mode and disabled the service Network Location Awareness - result: server would complete boot up and let me log in normally, but NIC was not functioning (it's a single NIC). I was able to enable the Network Location Awareness service but the NIC was still not functioning, no network connectivity (tried to repair through Windows, no change)

    4. Then while logged on, disconnected the network adapter cable from the NIC and plugged it back in, and then it seems the NIC started working again. 

    All servers, both physical and virtual, connect to a 12 port Cisco 3750 using MM fiber NICs.

    On the virtual server with this problem, I did not remove the WSUS updates that were applied. I booted it into safe mode, disabled the Network Location Awareness service but it would not boot normally until I removed the virtual NIC through ESXi.

    Once the virtual NIC was removed, I could log on locally, but I could not restart the NLA service. When I try to restart this service, the services.msc snap-in stops working and the server appears to partly "freeze" (example: I can change screen resolution but the Start button does not respond).

    While logged on locally and with NLA service still disabled, I reinstalled the virtual NIC through ESXi and the server re-established connectivity to the network. 

    At this point I can only log out, because if I restart it with the virtual NIC attached it goes back to hanging at the "Applying computer settings..." screen.

    I'm not too worried about the virtual Server 2003 because we plan to move web services to Server 2008, but I still don't know why this is happening, what the relationship is to the WSUS updates that were applied (none of this happened before that), or how to prevent this from happening in the future.

    Thanks for your patience and advice.

    Sunday, April 12, 2015 8:41 PM