none
DPM 2010 Secondary Protection Problem RRS feed

  • Question

  • I am cleaning up a DPM 2007 to DPM 2010 upgrade.  I had 2 DPM 2007 SP1+ servers.  The Primary server was running on Server 2003 R2 64 Bit.  The Secondary server is running Server 2008 R2.  Per the DPM Upgrade Advisor, I upgraded the secondary server to DPM 2010 first.  I then did an in-place upgrade of the OS to Server 2008 R2 on the Primary server followed by an in-place upgrade to DPM 2010.  The server was not working correctly, so I decided to move the installation to a new installation on different hardware with the same server name.  After a clean install of Server 2008 R2 and DPM 2010, I did a DB restore, moved the SAN disk to the server, and ran dpmsync.  After some work with Premier Support involving improper shadow storage settings on the DPM volumes, I have a mostly working DPM 2010 primary server.

    Originally, the secondary server was showing an error communicating with the agent on the primary server.  I was able to run Setdpmserver.exe (copied from another client install, not present on the primary server) on the primary server to point at the secondary server.  The agent status for the primary server is now OK on the secondary server.  I was able to start consistency checks for previously protected data, but only the Exchange sources are moving data.  The rest (file shares and SQL) show 0 mb for data transferred.  Also, if I try to create a protection group, access is denied to the primary server with below error:

    Access denied on the primary DPM server icbackup.icsystem.com. (ID: 32671)

    1) Make sure that icbackup.icsystem.com is not protected by another DPM server.
    2) Reinstall agent on icbackup.icsystem.com using Install Agent wizard.

    I have made sure that the secondary server is in the DPMDRTrustedMachines group on the primary server.  Any suggestions?  Any DPM Secondary protection documentation available?

    Tuesday, June 22, 2010 8:25 PM

Answers

  • Try doing a Install Agent from the Secondary DPM to the primary DPM. These should solve all the permission issues. Running SetDPMServer does not add the Secondary to all the req essential Trusted Groups. 

     

    --

    [Parag]

    This posting is provided "AS IS" with no warranties, and confers no rights.

    • Marked as answer by Johnnynjr Thursday, June 24, 2010 8:43 PM
    Wednesday, June 23, 2010 12:58 PM
    Moderator

All replies

  • Just a thought here...

    You mention that you had to copy the setdpmserver.exe from another server, does that mean that you didn't install the agent from the secondary server to the primary?

    Just my 2 cents

    Cheers,

    Mike Resseler


    Visit System Center User Group Belgium @ http://scug.be and http://scug.be/blogs/scdpm
    Wednesday, June 23, 2010 12:25 PM
    Moderator
  • Try doing a Install Agent from the Secondary DPM to the primary DPM. These should solve all the permission issues. Running SetDPMServer does not add the Secondary to all the req essential Trusted Groups. 

     

    --

    [Parag]

    This posting is provided "AS IS" with no warranties, and confers no rights.

    • Marked as answer by Johnnynjr Thursday, June 24, 2010 8:43 PM
    Wednesday, June 23, 2010 12:58 PM
    Moderator
  • That worked by installing through DPM Management GUI.  It seemed too simple.  I'm used to having to do a manual install on WS 2008 R2 servers because of the firewall.  Manual install says that client can't be installed on a DPM server.  Where is the DPM 2010 documentation?

    Thursday, June 24, 2010 8:46 PM
  • I am having the same issue. However he agent is showing as already installed on the primary server, so I do not have an option to install it again. Do I have to kill all the protetction groups on he secondary server, then uninstall reinstall the agent on the primary?

    Thanks!

    Bill

    Friday, November 5, 2010 3:02 PM