locked
Business Intelligence and performance point problem RRS feed

  • Question

  • Hi Everyone,

    Please does anyone know why creating a dashboard from a Sharepoint list is such a hassle. I have configured performance point services, a secure store and a business intelligent website that has a data connection library and  Performance Point content list . Unfortunately anytime I try to use dashboard designer to create a new data source and specify the site settings(using unattended account method) I can't save it. It gives me an error claiming that I either don't have permissions or the data source doesn't exist.

    A search around the web for answers doesn't seems to solve my problem as it suggests that the problem is associate with many things which I'm not clear about. Please could someone who is good at this at least tell me the critical things to check and the clearest way to set this up.

    Thanks,

    Dominic

    Thursday, April 2, 2015 12:49 PM

Answers

All replies

  • Hi Dominic,

    According to your error " I either don't have permissions or the data source doesn't exist", it should be related to the unattended account permission.

    Once the unattended service account has been configured, you must grant that account access to your data sources:

    • For SQL Server data, the account must have a SQL logon with db_datareader permissions on each database that you want to access.

    • For SQL Server Analysis Services data, the account must have read access to the cube or an appropriate portion of the cube, depending on your needs.

    • For Excel Services data, the account must have access to the Excel workbook in a SharePoint document library.

    • For data in a SharePoint list, the account must have read access to the list.

    Reference:

    https://technet.microsoft.com/en-us/library/ee836145.aspx

    Also you can have a look at the blog:

    http://www.chrismcnulty.net/blog/Lists/Posts/Post.aspx?ID=74

    https://yossidahan.wordpress.com/2012/08/14/cant-get-ssas-databases-to-appear-in-performance-point-dashboard-designer-check-you-adomd-net-version/

    Best Regards,

    Eric


    TechNet Community Support
    Please remember to mark the replies as answers if they help, and unmark the answers if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com.

    • Marked as answer by dnanna Tuesday, April 21, 2015 11:33 AM
    Friday, April 3, 2015 7:00 AM
  • Hi Eric,

    Thanks for the tip.I will give it a try and give you a feedback in a bit.

    Thanks,

    Dominic

    Monday, April 6, 2015 10:07 AM
  • Hi Eric,

    After spending the whole of yesterday and today configuring and tweaking I'm still having problems with performance point services.

    For simplicity sake I have created a SharePoint list of which I have tried creating a data source using dashboard designer. I have used the Farm administrator account as the unattended account and check permission for the site,the list and the data connections. I have generated a new secure store key and made sure that the unattend account (The Farm administrator) is specified within the performance point service section within the Sharepoint CA site.

    Despite all that I have done, when ever I launch dashboard designer through the data connections page in Sharepoint, I am able to create a new data source, test the connection successfully without any errors but when it gets to the part of saving what has been created it continues to prompt that it either can't find the data source or I don't have permissions. What is even more annoying is the fact that when I go back to the data connection page I actually see a created data source.  It's almost as if it initially has has access and then losses access.

    Could you or someone that has actually configured SharePoint Performance services help?

    Thanks,

    Dominic

    Tuesday, April 7, 2015 4:51 PM