locked
Failed to find a suitable device driver - Win7 x86/x64 Deployment RRS feed

  • Question

  • Hello Everyone,

    I'm new to SCCM and I'm having a lot of issues with deploying Windows 7.  Right now I'm just trying to do a Build & Capture of Windows 7 Professional with SP1, both x86 and x64.  I keep getting errors in the logs regarding drivers.  Oddly enough, this is on a machine manufactured in 2006 so all the drivers are within the OS.  I know this because if I do a hand install of Windows 7, it installs everything in the device manager.  

    Oddly enough, it seems like it is trying to download Synaptics drivers and then marks them as being boot critical.  This is a desktop.  What is going on!?

    Here are some of the errors from the logs:

    2012-06-25 16:20:27, Info                         PnPIBS: The class GUID for INF C:\_SMSTaskSequence\drivers\2\synpd.inf is 4d36e96f-e325-11ce-bfc1-08002be10318
    2012-06-25 16:20:27, Info                         PnPIBS: The class GUID 4d36e96f-e325-11ce-bfc1-08002be10318 is boot-critical.
    2012-06-25 16:20:27, Info                         PnPIBS: The driver C:\_SMSTaskSequence\drivers\2\synpd.inf is boot-critical.
    2012-06-25 16:20:27, Info                         PnPIBS: Importing driver C:\_SMSTaskSequence\drivers\2\synpd.inf ...
    2012-06-25 16:20:30, Info       [0x0640ae] IBSLIB PublishMessage: Publishing message [Windows Setup could not install one or more boot-critical drivers. To install Windows, make sure that the drivers are valid, and restart the installation.]
    2012-06-25 16:20:30, Info                         [SETUP.EXE] Called script [X:\windows\Setup\Scripts\ErrorHandler.cmd] to handle fatal error
    2012-06-25 16:20:30, Info       [0x070042] DIAG   CallBack_DiagnosticDataSend: Called with notification for Error published by ErrorHandler

    Failed to find a suitable device driver for device 'ACPI\PNP0501\1'. OSDDriverClient 6/25/2012 4:19:24 PM 1744 (0x06D0)
    Failed to find a suitable device driver for device 'Universal Serial Bus (USB) Controller'. OSDDriverClient 6/25/2012 4:19:24 PM 1744 (0x06D0)
    Failed to find a suitable device driver for device 'USB Input Device'. OSDDriverClient 6/25/2012 4:19:24 PM 1744 (0x06D0)
    Failed to find a suitable device driver for device 'ACPI\PNP0700\4&27EB6C7D&0'. OSDDriverClient 6/25/2012 4:19:24 PM 1744 (0x06D0)
    Failed to find a suitable device driver for device 'ATA Channel 1'. OSDDriverClient 6/25/2012 4:19:24 PM 1744 (0x06D0)
    Failed to find a suitable device driver for device 'ACPI\PNP0800\4&27EB6C7D&0'. OSDDriverClient 6/25/2012 4:19:24 PM 1744 (0x06D0)
    Failed to find a suitable device driver for device 'Video Controller (VGA Compatible)'. OSDDriverClient 6/25/2012 4:19:24 PM 1744 (0x06D0)
    Failed to find a suitable device driver for device 'ATA Channel 0'. OSDDriverClient 6/25/2012 4:19:24 PM 1744 (0x06D0)
    Failed to find a suitable device driver for device 'ST3808110AS ATA Device'. OSDDriverClient 6/25/2012 4:19:24 PM 1744 (0x06D0)
    Failed to find a suitable device driver for device 'Universal Serial Bus (USB) Controller'. OSDDriverClient 6/25/2012 4:19:24 PM 1744 (0x06D0)

    Copying "C:\_SMSTaskSequence\ContentCache\E91CFEC5-7AB5-496E-9FB8-047FD3C260AE" to "C:\_SMSTaskSequence\drivers\1". OSDDriverClient 6/25/2012 4:19:45 PM 1744 (0x06D0)
    Successfully installed driver "AMD PCI Express (3GIO) Filter Driver". OSDDriverClient 6/25/2012 4:19:45 PM 1744 (0x06D0)
    Entering ReleaseSource() for C:\_SMSTaskSequence\ContentCache\E91CFEC5-7AB5-496E-9FB8-047FD3C260AE OSDDriverClient 6/25/2012 4:19:45 PM 1744 (0x06D0)
    reference count 1 for the source C:\_SMSTaskSequence\ContentCache\E91CFEC5-7AB5-496E-9FB8-047FD3C260AE before releasing OSDDriverClient 6/25/2012 4:19:45 PM 1744 (0x06D0)
    Delete source directory C:\_SMSTaskSequence\ContentCache\E91CFEC5-7AB5-496E-9FB8-047FD3C260AE OSDDriverClient 6/25/2012 4:19:45 PM 1744 (0x06D0)
    Released the resolved source C:\_SMSTaskSequence\ContentCache\E91CFEC5-7AB5-496E-9FB8-047FD3C260AE OSDDriverClient 6/25/2012 4:19:45 PM 1744 (0x06D0)
    Failed to find a suitable device driver for device 'ATA Channel 1'. OSDDriverClient 6/25/2012 4:19:45 PM 1744 (0x06D0)
    Failed to find a suitable device driver for device 'ACPI\PNP0B00\4&27EB6C7D&0'. OSDDriverClient 6/25/2012 4:19:45 PM 1744 (0x06D0)
    Failed to find a suitable device driver for device 'Video Controller'. OSDDriverClient 6/25/2012 4:19:45 PM 1744 (0x06D0)
    Failed to find a suitable device driver for device 'ACPI\AUTHENTICAMD_-_AMD64_FAMILY_15_MODEL_75_-_AMD_ATHLON(TM)_64_X2_DUAL_CORE_PROCESSOR_3800+\_1'. OSDDriverClient 6/25/2012 4:19:45 PM 1744 (0x06D0)
    Failed to find a suitable device driver for device 'RamDisk'. OSDDriverClient 6/25/2012 4:19:45 PM 1744 (0x06D0)
    Failed to find a suitable device driver for device 'Universal Serial Bus (USB) Controller'. OSDDriverClient 6/25/2012 4:19:45 PM 1744 (0x06D0)
    Failed to find a suitable device driver for device 'ACPI\PNP0C01\2&DABA3FF&0'. OSDDriverClient 6/25/2012 4:19:45 PM 1744 (0x06D0)
    Failed to find a suitable device driver for device 'IDE Controller'. OSDDriverClient 6/25/2012 4:19:45 PM 1744 (0x06D0)
    Failed to find a suitable device driver for device 'ROOT\MSSMBIOS\0000'. OSDDriverClient 6/25/2012 4:19:45 PM 1744 (0x06D0)
    Failed to find a suitable device driver for device 'ACPI\PNP0C02\1'. OSDDriverClient 6/25/2012 4:19:45 PM 1744 (0x06D0)
    Failed to find a suitable device driver for device 'ACPI\PNP0C02\2'. OSDDriverClient 6/25/2012 4:19:45 PM 1744 (0x06D0)
    Failed to find a suitable device driver for device 'ROOT\ACPI_HAL\0000'. OSDDriverClient 6/25/2012 4:19:45 PM 1744 (0x06D0)
    Failed to find a suitable device driver for device 'PCI HOST Bridge'. OSDDriverClient 6/25/2012 4:19:45 PM 1744 (0x06D0)
    Failed to find a suitable device driver for device 'Universal Serial Bus (USB) Controller'. OSDDriverClient 6/25/2012 4:19:45 PM 1744 (0x06D0)
    Failed to find a suitable device driver for device 'ROOT\VDRVROOT\0000'. OSDDriverClient 6/25/2012 4:19:45 PM 1744 (0x06D0)
    Failed to find a suitable device driver for device 'ACPI\PNP0C04\4&27EB6C7D&0'. OSDDriverClient 6/25/2012 4:19:45 PM 1744 (0x06D0)
    Failed to find a suitable device driver for device 'PCI Device'. OSDDriverClient 6/25/2012 4:19:45 PM 1744 (0x06D0)
    Failed to find a suitable device driver for device 'ROOT\BLBDRIVE\0000'. OSDDriverClient 6/25/2012 4:19:45 PM 1744 (0x06D0)
    Failed to find a suitable device driver for device 'ROOT\VOLMGR\0000'. OSDDriverClient 6/25/2012 4:19:45 PM 1744 (0x06D0)
    Failed to find a suitable device driver for device 'ACPI\AUTHENTICAMD_-_AMD64_FAMILY_15_MODEL_75_-_AMD_ATHLON(TM)_64_X2_DUAL_CORE_PROCESSOR_3800+\_2'. OSDDriverClient 6/25/2012 4:19:45 PM 1744 (0x06D0)
    Failed to find a suitable device driver for device 'ACPI\PNP0C0C\2&DABA3FF&0'. OSDDriverClient 6/25/2012 4:19:45 PM 1744 (0x06D0)
    Failed to find a suitable device driver for device 'Generic volume'. OSDDriverClient 6/25/2012 4:19:45 PM 1744 (0x06D0)
    Failed to find a suitable device driver for device 'PCI HOST Bridge'. OSDDriverClient 6/25/2012 4:19:45 PM 1744 (0x06D0)
    Failed to find a suitable device driver for device 'ACPI\PNP0C14\0'. OSDDriverClient 6/25/2012 4:19:45 PM 1744 (0x06D0)
    Failed to find a suitable device driver for device 'IDE Controller'. OSDDriverClient 6/25/2012 4:19:45 PM 1744 (0x06D0)
    Failed to find a suitable device driver for device 'PCI to PCI Bridge'. OSDDriverClient 6/25/2012 4:19:45 PM 1744 (0x06D0)

    Monday, June 25, 2012 9:40 PM

All replies

  • Nobody?

    I went through my drivers and disabled the 'unsigned' ones which were just a few.  I then eliminated the 'add drivers' part in the task sequence and tried re-deploying it.  I get less errors now but now it is complaining about the product key which I know is good....

    setupact.log:

    2012-06-26 09:45:45, Error      [0x060551] IBS    Callback_Productkey_Validate: EditionID for product key was NULL.
    2012-06-26 09:45:45, Info                  IBS    Callback_Productkey_Validate: EulaType (a.k.a. ChannelType) for product key is [Volume].
    2012-06-26 09:45:45, Error      [0x060554] IBS    Callback_Productkey_Validate: An error occurred writing the product key data to the blackboard.
    2012-06-26 09:45:45, Info       [0x06012e] IBS    Callback_Productkey_Validate: ProductKey Value=NULLSTR Error=ERROR_INVALID_DATA Show=1
    2012-06-26 09:45:45, Info                  IBS    Callback_Productkey_Validate: Storing return code 0x80004005 on the blackboard.
    2012-06-26 09:45:45, Info       [0x060130] IBS    Callback_Productkey_Validate: Exit
    2012-06-26 09:45:45, Error      [0x06011a] IBS    Callback_Productkey_Validate_Unattend:Product key did not successfully validate.[gle=0x00000490]
    2012-06-26 09:45:45, Error      [0x0603c7] IBS    Callback_Productkey_Validate_Unattend:Did not pass validation; halting Setup.[gle=0x00000490]
    2012-06-26 09:45:45, Error      [0x060120] IBS    Callback_Productkey_Validate_Unattend: An error occurred preventing setup from being able to validate the product key; hr = 0x80300006[gle=0x00000490]
    2012-06-26 09:45:45, Info       [0x0640ae] IBSLIB PublishMessage: Publishing message [The unattend answer file contains an invalid product key. Either remove the invalid key or provide a valid product key in the unattend answer file to proceed with Windows installation.]
    2012-06-26 09:45:45, Info                         This installation is blocked from completing due to compliance failures or invalid input; this is not an internal error.
    2012-06-26 09:45:45, Info                         [SETUP.EXE] Called script [X:\windows\Setup\Scripts\ErrorHandler.cmd] to handle fatal error
    2012-06-26 09:45:45, Info       [0x070042] DIAG   CallBack_DiagnosticDataSend: Called with notification for Error published by ErrorHandler
    2012-06-26 09:45:45, Warning    [0x070041] DIAG   DiagnosticDataSendWorker: invalid arguments
    2012-06-26 09:45:45, Warning               DIAG   CallBack_DiagnosticDataSend: DiagnosticDataSendWorker failed, hresult=0x80070057

    Tuesday, June 26, 2012 3:09 PM
  • Is it Windows 7 Enterprise you are trying to deploy? Just a recommendation, If you are buildning an image you should build this on a virtual machine!
    Tuesday, June 26, 2012 8:36 PM
  • Windows 7 Professional w/ SP1.

    It shouldn't matter what I'm building an image on, as long as I Sysprep.  That'll eliminate anything tied to an actual machine, drivers, etc.

    I got it working by eliminating the 'drivers' and 'cd-key' in the Build phase.  Weird and not ideal.

    At this point I'm just trying to deploy Vanilla Windows 7 to all my models to make sure drivers are taken care of.

    Tuesday, June 26, 2012 8:43 PM