none
DC with 4 NICS - all 4 are showing up in DNS RRS feed

  • Question

  • Hi all,

    Quick question to people. I have a DC with 1 NIC for LAN and 3 NICS for iSCSI traffic. Clients cannot see the iSCSI network.

    When i run 'nslookup serverdc' I get all 4 addresses. My assumption is this is not desired because if a client try to get to the DC using one of the iSCSI IPs it will not work.

    So on the 3 iSCSI NICS i have removed the tick in the "Register this connection's addresses in DNS" I assume i need to delete something out of DNS too?

    Monday, December 9, 2019 10:25 AM

Answers

  • If you have multiple IP's on the same NIC, you have to change the SkipAsSource flag

    https://blogs.technet.microsoft.com/rmilne/2012/02/08/fine-grained-control-when-registering-multiple-ip-addresses-on-a-network-card/

    But if you have multiple NIC, you have to uncheck the box "Register this connnection's addresses in DNS" on the NIC that you don't want to be registered in the DNS

    Because it's a DC, you may have different records in DNS you may have to delete manually like the A record.

    hth


    This posting is provided AS IS without warranty of any kind

    Monday, December 9, 2019 4:53 PM
  • Hi ,

    If the DC is running DNS server service, we also need to check name server tab and interfaces tab. Then manually delete the existing unwanted Host A record.

    Select the Only the following IP addresses check box. Type the IP addresses that you want the server to listen on. Include only the IP addresses of the interfaces for which you want a host A record registered in DNS.

    Remove unwanted IP address in the name server tab.

    Best Regards,

    Candy


    Please remember to mark the replies as an answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com   

    Tuesday, December 10, 2019 3:05 AM
    Moderator

All replies