locked
Explorer crashing when generating thumbnails view for large (4GB) video (.TS) files RRS feed

  • Question

  • I am suffering consistent application crashes in Windows Explorer when it tries to generate thumbnails. 

    The error is reported as COM Surrogate has stopped working with an APPCRASH of dllhost.exe in module msvcrt.dll.

    This only but always happens in the following circumstances.  A folder set to view tiles or icons (with thumbnail view option NOT disabled).  This folder contains several sub-folders, each of which contain video files.  As explorer scans the folder and its sub-folders, generating thumbnails for each, whenever it encounters a video file (.TS) that is 3.99GB or larger. COM surrogate crashes again.  Closing COM Surrogate will then allow explorer to continue to scan the remaining sub-folders until it encounters the next large file. 

    If I subsequently open one of the sub-folders where it crashed trying to generate a thumbnail, and refresh the folder, it will successfully generate a thumbnail for the video file. If I then return to the main folder and change the customization of the sub-folder from video to document and back to video, explorer then successfully generates the folder icon with the inset video thumbnail.

    I have tried this in safe mode and the problem persists.

    Can anybody please help as I am pulling my hair out.


    • Edited by cbh-forum Tuesday, June 10, 2014 12:36 PM
    Tuesday, June 10, 2014 12:33 PM

All replies

  • Hi,

    This problem probably caused by third party application or service, first of all, you can try to make a clean boot for your computer if the problem still occures.

    If so, which APP do you use to open .TS file? please try to uninstall or reinstall this APP for test.

    Thirdly, try to update your Graphic card driver for test to fix this problem.

    If problem persists, please feel free let us know.


    Roger Lu
    TechNet Community Support

    Wednesday, June 11, 2014 2:24 AM
  • Hi Roger. Thanks for your reply.  

    For info, I am running Windows 8.1 (basically Windows 7 + annoyances) 64-bit. 

    I have already tried everything you have suggested, including Safe Boot, removing all media players/codes etc.  Windows updates and drivers are all up-to-date. No reason to suspect virus or application conflicts.

    Wednesday, June 11, 2014 8:24 AM
  • Hi,

    How about other media type files? Is them also have same problem? You can try to use ShellExView to check if there is any 3rd extension cause this problem.

    ShellExView: http://www.nirsoft.net/utils/shexview.html

    If there is any updates, please feel free let us know.


    Roger Lu
    TechNet Community Support

    Thursday, June 12, 2014 12:42 AM
  • What is your default application to open video?

    Please try to restore the defaults program association.

    Click on "Set Program Access and computer defaults"

    Hope it helps.

    Check below:


    Every second counts..make use of it. Disclaimer: This posting is provided AS IS with no warranties or guarantees and confers no rights.
    IT Stuff Quick Bytes

    Thursday, June 12, 2014 6:24 AM
  • Hi Roger.

    Almost all of my media files are TS, and all of my large (4GB) files are TS files, so I cannot tell if other file types have the same problem.  I did try renaming the TS files to be .mpg (they still play as mpg) but this did not help.

    However, I have downloaded and used ShelleExView and this has proved very useful.  For the benefit of anyone else with a similar problem and using this very useful tool, I will detail the technique I used. 

    First, using ShellExView, I disabled various groups of extensions to identify which, if any, were relevant.  After disabling/enabling each set I performed a system restart to ensure the changes took effect.  This was not actually necessary as restarting Windows Explorer (via Task Manager) works equally well (but this loses my customm Taskbar toolbar). 

    Also, before re-opening the folders containing the problem files, I deleted the icon cache (I could have done this manually but chose to use CCleaner's delete Thumbnail Cache option as this was quick and easy).  I then viewed the folders containing the problem files, watching to see what effect the changes in ShellExView had made.

    Using ShellExView, I progfessively disabled by Type (e.g. Thumbnail, Icon Handler), then by Company (e.g. non-Microsoft), then by Product (e.g. MS Office, Windows Search).  The result was that I identified the extension that was creating the thumbnails: Icaros Thumbnail Provider (installed as part of the K-Lite codec pack).

    Hoping I had found the cause, I removed K-Lite from my system and checked again.  No thumbnails (as expected), but COM Surrogate continued to crash (I have subsequently reinstalled K-Lite as I need this to play my media files).  Further analysys with ShellExView then identified a further problem extension: Microsoft's MF MPEG Property Handler. 

    With both extensions (Icaros Thumbnail Provider & MF MPEG Property Handler) disabled, COM Surrogate does not crash.  With either one enabled, but not the other, COM Surrogate crashes.  These two extensions are therefore both individually causing the crashes.  This leads me to wonder if they perhaps have something in common (e.g. a dll).

    Although disabling these extensions stops the crashes, I of course alos lose what they provide: file details (e.g. media length etc.) and thumbnails.  So simply disabling them is not a solution.  

    Is it possible to idenitfy what, if anything, they have in common (which may be the true culprit)? 

    Alternatively, are there other ways I can continue to obtain file property information and thumnails without using these extensions?

    • Edited by cbh-forum Tuesday, June 17, 2014 5:02 AM
    Tuesday, June 17, 2014 4:35 AM
  • Hi ItStuff,

    Thanks for your reply, but I had already previosuly tried various default applications. Please, though, see my post following investigations using ShellExView as this seems to have resulted in significant progress towards identifying the cause, if not a cure.

    Tuesday, June 17, 2014 5:05 AM
  • try opening an elevated command prompt.

    then do an sfc check, type: sfc /scannow

    check if it helps.


    Every second counts..make use of it. Disclaimer: This posting is provided AS IS with no warranties or guarantees and confers no rights.
    IT Stuff Quick Bytes

    Tuesday, June 17, 2014 9:48 AM
  • Hi IT Stuff,

    I already ran the System File Checker and parsed the results.  The only issues were start menu items (Windows 8 new style problems). 

    Wednesday, June 18, 2014 8:15 AM
  • Hi,

    I doubt if this problem caused by K-lite, as I had also encounter some problem using this app, it you do need decoder, please try other app's decoder for test.

    In addition, for your Start Menu items problem, would you please provide more details about this?


    Roger Lu
    TechNet Community Support

    Thursday, June 19, 2014 2:06 AM
  • Hi Roger,

    I'm not suggestring the problem is caused by K-Lite, but one of it's components (Icaros Thumbnail Provider), which does cause crashes.  The other issue is that Microsoft's MF MPEG Property Handler is also causing crashes. 

    That is why I am suggesting the true culprit may be something these two shell extensions have in common (e.g. a dll). What this does confirm though, is that a stripped-down or virgin installation of Windows 8.1 also crashes and I think this should be an issue for Microsoft to investigate. 

    If I disable Icaros, I would need to find a replacement so I can view the thumbnails.  Also, if I disable the Media Foundation MPEG property handler, I would need something else to view properties. 

    The ideal solution would be to identify and fix the common element (if any).  Alternatively I would need to identify, install and test both an alternative thumbnail provider(s) and a property handler(s).

    Any suggestions?

    Thursday, June 19, 2014 6:29 AM
  • hi cbh, have you came across this link below:

    http://superuser.com/questions/274753/how-can-i-make-windows-7-show-thumbnails-for-mkv-files


    Every second counts..make use of it. Disclaimer: This posting is provided AS IS with no warranties or guarantees and confers no rights.
    IT Stuff Quick Bytes

    Thursday, June 19, 2014 7:46 AM
  • Hi IT.  Thanks, but if you read the thread (which refers to MKV files, not TS), it says to use the Icaros thumbnail provider (which is what I am using and which is failing). The solution to problems with Windows 64-bit (which I have)  is to use K-Lite (which I am using).  Also, the latest version of K-Lite is for both 32 and 64 but systems.

    I have previously had problems with the Haali media splitter and am not keen to complicate matters by installing it.  Also, even if I resolve the thumbnail problem, I still have the issue with the property handler extension.

    Thursday, June 19, 2014 8:31 AM
  • i just search the web but i'm not really sure whether this would help you but check out this link:

    http://forum.team-mediaportal.com/threads/ts-files-sometimes-crash-explorer.78821/page-2

    and the last reply from that link was to install radlight software.

     

    if you have a virtual machine that you can play and I think it's better to have one.

    So you don't have to worry crashing it or messing it up; you just wipe out the virtual machine and install another one until you finally resolve or find a solution to your issue.

    you can download an evaluation same with your OS version, just search the web.



    Every second counts..make use of it. Disclaimer: This posting is provided AS IS with no warranties or guarantees and confers no rights.
    IT Stuff Quick Bytes

    Thursday, June 19, 2014 9:35 AM
  • Hi IT Stuff. 

    The Radlight software is not an option; it also appears not to have been updated for several years.

    As to VMs, I really don't want to mess around with this that I don't need and which would just introduce further complications without solving the problem.

    Saturday, June 21, 2014 10:13 AM
  • Thank you!!! This solved my problems immediately and I didn't have to do all the research!!!
    Wednesday, January 7, 2015 10:45 PM