locked
Exchange 2010 - SMTP Issues RRS feed

  • Question

  • So here is the issue.

    I have a server running Windows Small Business Server 2011 with Exchange 2010.

    Up to this point everyone has been using activesync protocol with no problem. Today they decided to bring in a Ricoh multifunction printer to setup for scan-to-email. I, for some reason, cannot get this thing to work with SMTP. I set up a unique user account on exchange for the printer, but it just doesn't work. Here's what I've tried:

    I've tried port 25 and 587. SLL, TLS and No encryption.

    I've tried setting up Receive and Send connectors with thee most broad wildcards I could conceive.

    I can configure an Outlook 2010 client in the local network with the ricoh's account information and it works fine, however, when i tried configuring an external computer the POP worked but the SMTP keeps timing out.

    POP and SMTP work on my iPad via 3G or an external Wifi but I cannot use authentication, it has to be blank user and password and have to use SSL on port 25. Tried doing that with outlook and it would not work, still said it could not find the SMTP server. check Windows Firewall, the ports are open, i even enable traversal.

    What am I doing wrong here?

    Monday, March 19, 2012 11:14 PM

Answers

  • Okay, with the exception of the printer, how do i get external network devices to work? I dont understand how my iPad can use POP/SMTP but my laptop cannot when they're on the same network and have the same settings. I set the receive connect to accept connections from 0.0.0.0 to 255.255.255.255 shouldn't that cover all bases?

    SBS sets the connectors in a different way, which allows an external host to connect, but not an internal.
    If you have changed the connectors though, the change doesn't take effect until the transport service has been restarted.

    I wouldn't recommend changing the connectors though, not on an SBS system. Create a new one.

    Simon.


    Simon Butler, Exchange MVP
    Blog | Exchange Resources | In the UK? Hire Me.

    • Proposed as answer by Mike Crowley Tuesday, March 20, 2012 5:12 AM
    • Marked as answer by Evan Liu Sunday, April 1, 2012 4:10 AM
    Monday, March 19, 2012 11:41 PM
  • For Outlook you should be using Outlook Anywhere.
    For tablets and phones you should be using ActiveSync.

    Your issues are that you have modified away from the way that SBS has configured them. You need to get it back to the way that SBS has it setup. The Fix My Network wizard should do that for you.

    Then create an additional receive connector with the "Receive mail from remote servers that have these IP addresses" specifically lists the IP address of anything internal that you want to send email to internal recipients. As it will be a closer match the traffic should be allowed to be sent.

    Simon.


    Simon Butler, Exchange MVP
    Blog | Exchange Resources | In the UK? Hire Me.

    • Marked as answer by Evan Liu Sunday, April 1, 2012 4:11 AM
    Wednesday, March 21, 2012 9:58 AM

All replies

  • The only thing you would need to change is the subnet setting on the Receive Connector that SBS creates.

    Therefore I would start by running the Fix My Network wizard in SBS management console, so that it puts everything back to how it should be.

    Then you have two choices.

    1. Modify the existing Receive Connector to allow that printer to connect.

    2. Create a new Receive Connector to accept email from that printer. That is a matter of running the new Connector wizard. Once complete, change the network settings in the second box and list only the IP address of the printer. Then enable anonymous. That will allow the printer to send to internal recipients.

    Simon.


    Simon Butler, Exchange MVP
    Blog | Exchange Resources | In the UK? Hire Me.

    Monday, March 19, 2012 11:19 PM
  • Okay, with the exception of the printer, how do i get external network devices to work? I dont understand how my iPad can use POP/SMTP but my laptop cannot when they're on the same network and have the same settings. I set the receive connect to accept connections from 0.0.0.0 to 255.255.255.255 shouldn't that cover all bases?

    Monday, March 19, 2012 11:23 PM
  • Some more details would be great - but from the jist of things you may need to allow anonymous internal relay - you can specifiy the receive connector to only listen to one particular ip address for this - but here's the technet on how to do it:

    http://technet.microsoft.com/en-us/library/bb232021.aspx

    Monday, March 19, 2012 11:26 PM
  • Okay, with the exception of the printer, how do i get external network devices to work? I dont understand how my iPad can use POP/SMTP but my laptop cannot when they're on the same network and have the same settings. I set the receive connect to accept connections from 0.0.0.0 to 255.255.255.255 shouldn't that cover all bases?

    SBS sets the connectors in a different way, which allows an external host to connect, but not an internal.
    If you have changed the connectors though, the change doesn't take effect until the transport service has been restarted.

    I wouldn't recommend changing the connectors though, not on an SBS system. Create a new one.

    Simon.


    Simon Butler, Exchange MVP
    Blog | Exchange Resources | In the UK? Hire Me.

    • Proposed as answer by Mike Crowley Tuesday, March 20, 2012 5:12 AM
    • Marked as answer by Evan Liu Sunday, April 1, 2012 4:10 AM
    Monday, March 19, 2012 11:41 PM
  • tell me what you need to know. I tried the anonymous internal relay but to no avail. I just want to be able to setup an outlook client that's outside the network to use POP/SMTP. so far, the POP works fine, SMTP keeps saying no connection, but will work with my iPad. I tried doing a network fix but it didn't find anything (because i already removed all my changes) and reconfigured the recieve connect to accept all ip address and every permision group, but still no luck.
    Monday, March 19, 2012 11:43 PM
  • My problem is currently the other way around. I managed to get all the internal clients to connect. the ricoh printer did not support TLS/SSL on port 25 which seemed to be the problem, so I did create a receive connector specifically for it's IP address and gave it the ability to send emails with authentication.

    The problem now is that I can configure my iPad to work with SMTP but I cannot configure Outlook 2010 or even Windows Mail or Mozilla Thunderbird. Just keeps saying time-out. The iPad works so long as I don't use authentication and I use SSL on port 25. All these clients are outside the network, including the iPad which i'm using the 3G on.

    There is a receive connector already defined in SBS for all IP addresses (excluding the internal subnet) to all connections from anonymous users so long as they use TLS.

    Tuesday, March 20, 2012 4:06 PM
  • For Outlook you should be using Outlook Anywhere.
    For tablets and phones you should be using ActiveSync.

    Your issues are that you have modified away from the way that SBS has configured them. You need to get it back to the way that SBS has it setup. The Fix My Network wizard should do that for you.

    Then create an additional receive connector with the "Receive mail from remote servers that have these IP addresses" specifically lists the IP address of anything internal that you want to send email to internal recipients. As it will be a closer match the traffic should be allowed to be sent.

    Simon.


    Simon Butler, Exchange MVP
    Blog | Exchange Resources | In the UK? Hire Me.

    • Marked as answer by Evan Liu Sunday, April 1, 2012 4:11 AM
    Wednesday, March 21, 2012 9:58 AM