locked
Windows Photo Viewer And ICC Profiles RRS feed

  • Question

  • Hi,

    on my Windows 7 Ultimate x64 machine, I just calibrated my Dell SP2309W monitor using an i1DisplayPro and basICColor 5, creating a ICC v2 profile (I am aware of the problems under Windows with ICC v4 profiles).

    It created the ICC profile and applied it to be used by Windows. I double checked under COLOR MANAGEMENT that the new ICC profile is being used as the default profile. Although I can see that the new ICC is being used (desktop appearance changes), there are is an issue I am experiencing:

    Windows Photo Viewer

    The thumbnails in Windows Explorer look fine (they DO use the new ICC profile), when I double click a jpeg and open the image in Windows Photo Viewer it DOES NOT use the new ICC profile. When I click the PLAY SLIDESHOW button (starting the slideshow) in the opened image in Windows Photo Viewer, the images DO use the new ICC profile.

    Why does the single image display in Windows Photo Viewer not use the currently used ICC profile ?

    FYI, All current internet browser (Firefox, IE, Safari and Chrome) DO use the new ICC profile and display the image correctly.

    Thank you for your help !

    - M
    Friday, June 15, 2012 12:16 AM

Answers

  • Vincent, they are all installed correctly...

    Here's what I assume after running multiple tests:

    (1.) Windows Photo Viewer by default honors embedded profiles in images and displays them accordingly to that profile

    > if an image is untagged (no profile embedded) it will default to sRGB IEC 61966-2.1 - always ignoring the specified system default profile (my custom profile)

    (2.) Windows Photo Viewer in Slideshow Mode does the exact opposite. It ignores embedded profiles and displays all images via the specified system default profile (my custom profile)

    --> internet browser do the same thing

    Can you confirm this ?

    - M

    • Marked as answer by michanagel Tuesday, June 26, 2012 10:42 PM
    Thursday, June 21, 2012 9:01 AM
  • after more research:

    it is exactly as I stated in my second post. On wide gamut monitors the saturation shift between your monitor's profile and sRGB is much more noticeable...

    • Marked as answer by michanagel Tuesday, June 26, 2012 10:42 PM
    Tuesday, June 26, 2012 10:42 PM

All replies

  • Hi,


    Please go to control panel---Color Management---All Profiles to make sure the ICC profiles are configured and installed on your PC, more detail you can refer:


    Change color management settings

    http://windows.microsoft.com/en-US/windows7/Change-color-management-settings?SignedIn=1


    Hope this helps


    Vincent Wang

    TechNet Community Support

    Tuesday, June 19, 2012 6:03 AM
  • Vincent, they are all installed correctly...

    Here's what I assume after running multiple tests:

    (1.) Windows Photo Viewer by default honors embedded profiles in images and displays them accordingly to that profile

    > if an image is untagged (no profile embedded) it will default to sRGB IEC 61966-2.1 - always ignoring the specified system default profile (my custom profile)

    (2.) Windows Photo Viewer in Slideshow Mode does the exact opposite. It ignores embedded profiles and displays all images via the specified system default profile (my custom profile)

    --> internet browser do the same thing

    Can you confirm this ?

    - M

    • Marked as answer by michanagel Tuesday, June 26, 2012 10:42 PM
    Thursday, June 21, 2012 9:01 AM
  • I am also having the exact same issue as you Michanagel, and I also used the i1DisplayPro. This is very frustrating and albeit all my searching, I have yet to get a proper solution.

    Vincent where is the specific color profile that Windows Photo Viewer uses?

    Saturday, June 23, 2012 1:40 PM
  • Hi,

    I suggest you backup the color profile and then try removing the profile, and going back to the default.  Next try creating a new one with quick adjustments for testing purposes and check if the profile is active or not in the photo viewer.

    1: Navigate to the location 

    C:\Windows\system 32\Spool\drivers\color

    2: Then Right click on the ICC(International Color Consortium) profiles and then copy it and save it. 
    3: Then type Color Management in the start search box and hit enter.
    4: Now click All Profiles tab. 
    5: Now click the ICC profiles and then click Remove. 
    6: Now Go ahead and right click on the profile which you had copied and then click Install Profile. 

    Hope this helps. 


    Vincent Wang

    TechNet Community Support

    Tuesday, June 26, 2012 1:59 AM
  • after more research:

    it is exactly as I stated in my second post. On wide gamut monitors the saturation shift between your monitor's profile and sRGB is much more noticeable...

    • Marked as answer by michanagel Tuesday, June 26, 2012 10:42 PM
    Tuesday, June 26, 2012 10:42 PM
  • Part of the problem is that some programs generate an ICC version 4 profile, while Windows Photo Viewer will only recognize an ICC v2 profile. Setting your calibration program to generate a v2 profile (most programs have this as an option) will also fix this issue.

    See also:

    http://www.thephotoforum.com/forum/digital-discussion-q/273062-windows-photo-viewer-problem.html

    • Proposed as answer by Dan Parratt Friday, August 11, 2017 11:01 PM
    Friday, August 24, 2012 6:59 PM
  • Hi there

    The i1Display Pro Messed up my Windows Photo Viewer ICC profiles.  See photo,  I do portrait photography and  this device kept my IE and Photoshop icc profiles intact but the Windows Viewer profile is a mess.  The photo does have an sRGB profile.  How do I fix this?

    i1Display Pro Messed upmy Windows Photo Viewer ICC profiles


    • Edited by JulesOille Thursday, December 1, 2016 5:56 PM
    Thursday, December 1, 2016 5:55 PM
  • I'm having exactly the same problem, have you found a solution?
    Wednesday, February 22, 2017 4:59 PM
  • Did you get an answer to this?
    Thursday, March 9, 2017 4:51 PM
  • Part of the problem is that some programs generate an ICC version 4 profile, while Windows Photo Viewer will only recognize an ICC v2 profile. Setting your calibration program to generate a v2 profile (most programs have this as an option) will also fix this issue.

    Just so everyone still reading this in 2017 and beyond knows; THIS is the answer!

    I profiled my display with v4 thinking a newer ICC profile version would be better but v2 is equally as diverse & yields the same results as v4, though with the added benefit of displaying your images correctly in Windows Photo Viewer.

    Friday, August 11, 2017 11:07 PM
  • Thanks! This fixed the problem for me.

    I use an xRite ColorMunki Photo and had the same problem. I went into Preferences and changed it from v4 to v2. All is well with the universe...

    Wednesday, August 23, 2017 2:34 AM
  • I'm not seeing how to change the version in x-rite i1 Display Pro.  Can anyone advise?
    Saturday, March 3, 2018 9:53 AM
  • I checked my Spyder 5 Elite and it's set to ICC version 2 and I still have this problem. It's a total pain. 
    Sunday, March 11, 2018 8:56 AM
  • It's under Profile Settings, the second drop-down on the second screen when you use Advanced Mode in i1Profiler. Changing to version 2 solved this issue for me.
    Tuesday, March 20, 2018 10:16 PM