none
Not able to connect to Remote Distributor from Publisher using Administrative Link Password

Answers

  • Right click on the replication option in your database instance where you have configured your distributor, and go to distributor properties. Go to(click) the publisher option on the left side panel. You will see the place where you need to specify a password for your publisher. Change the password and try once more. I think ur problem will be solved.

    Tuesday, January 29, 2008 6:37 AM

All replies

  • Right click on the replication option in your database instance where you have configured your distributor, and go to distributor properties. Go to(click) the publisher option on the left side panel. You will see the place where you need to specify a password for your publisher. Change the password and try once more. I think ur problem will be solved.

    Tuesday, January 29, 2008 6:37 AM
  • Thanks. It worked.

    Friday, October 17, 2008 12:39 PM
  • Hi

    Have done the same but does'nt work me still getting the same error. Pls help. 
    Apps Dev
    Friday, January 16, 2009 3:53 PM
  • I'm getting the same problem as the poster.  Unfortunately, nothing has worked to resolve the issue.

    - Changing the administrative link password (Various strong type passwords tried, nothing worked)
    - Dropping/recreating the distributor
    - Changing the 'Agent Connection to the Publisher' from Impersonation to SQL Server Auth (neither work)

    Anyone else have ideas?  It used to work but the User Account that was setup to start the SQL Server Service expired.  Problems started after that.

    Thursday, February 19, 2009 1:46 PM
  • i have the same thing

    distributor is build 4262 and the publisher is 3161. trying to set up a server as a publisher and it's not working
    Friday, November 06, 2009 1:43 PM
  • Hi, I recently encountered this problem as well. Though it is an old post, no doubt others will encounter it in the future!

    I found a link where the steps taken resolved the issue.

    http://www.eggheadcafe.com/software/aspnet/32070626/error-21670-sql-server-c.aspx

    Steps referenced:

    "Error: 21670 SQL Server could not connect to the Distributor using the specified password. (Configure Distribution Wizard)
    Jim posted on Thursday, June 12, 2008 11:05 PM

    I had the same problem and here's how I resolved it.

    1- Connect to the server where your distribution db resides
    2- Right click on the replication folder and select distributor
    properties.
    3- Select publishers. If you have already entered your publisher
    uncheck and select OK
    4- Add a new publisher
    5- Enter a password for the administrative link
    6- Connect to your publishing server and and create a new publication
    using the remote distributor.
    7- Enter the password you used earlier when assigning the publisher in
    the distrubution properties

    If you don't put in the password when you first add the publisher it
    won't accept this password later so removing and readding with the new
    password seems to work.

    good luck,
    Jim
    "


    NCi DBA
    Tuesday, December 08, 2009 6:10 PM
  • i think we ended up changing the password and it took 15 minutes to change it for all the publishers
    Monday, January 11, 2010 5:55 PM
  • I tried this method and am still getting the same issue.
    • Proposed as answer by Deepak_manohar Thursday, August 05, 2010 11:54 AM
    Thursday, June 24, 2010 8:04 PM
  • Check if the remote access parameter in sp_configure is enabled on the Publisher. If its not enabled, enable it and restart the SQL Server service for the change to take effect.
    Thursday, August 05, 2010 11:57 AM
  • Check if the remote access parameter in sp_configure is enabled on the Publisher. If its not enabled, enable it and restart the SQL Server service for the change to take effect.

    http://msdn.microsoft.com/en-us/library/ms187660.aspx indicates that the Remote Access Enable feature will be removed in a future realease and not to use it for production systems. Is there a work-around?
    Friday, December 10, 2010 9:00 PM
  • Verify your linked servers is_remote_login_enabled = 1 in master.sys.servers for the server you are connecting from on the server you are connecting to. I ran into this as well in setting up a remote distributor. I also saw the error: could not connect to server because is not defined as a remote server in my error log at the distributor that I was connecting to.

    I hope this helps!

    Derek Stanley

    • Proposed as answer by Derek Stanley Thursday, January 30, 2014 4:30 PM
    Thursday, January 30, 2014 4:30 PM
  • Thank you, this worked for me!!!

    Mulu M

    Tuesday, October 13, 2015 1:01 PM
  • Thanks a lot, I tried so many ways but at last this worked for me.
    Tuesday, September 27, 2016 6:13 AM
  • The password for which account is referenced here?
    Tuesday, May 01, 2018 11:18 PM
  • Hello Derek,

    During configuration of Distribution (dedicated server) named A

    I was asked to specify the password required for "B" (publisher) to establish an administrative link with the Distributor (server A)

    What's password they are talking about it here?

    Tuesday, May 01, 2018 11:22 PM