locked
Availability of UCWA 2.0 API REST resources in Skype for Business Online and how to get conversationLogTranscript for SFB Online Meetings RRS feed

  • Question

  • Hi,

    We are trying to use UCWA 2.0 API for integrating Skype for Business Online. Using MS developer account(Azure AD tenant) with free trial.

    After home pool server discovery when we create the application resource we get limited resources links in the response of POST https://webpoolmaain102.infra.lync.com/ucwa/oauth/v1/applications

    UCWA 2.0 API documentation (https://msdn.microsoft.com/en-us/skype/ucwa/ucwaresources) mentions many resources and links for all of them are not provided in the response of above POST.

    Quesiton -1 : Are all UCWA 2.0 REST resources available for use with Skype for Busines Online? If not then which are not exposed and when they will be available?

    Question 2:

    We are struggling specially with conversationlogtranscript. Objective is to get the chat transcript of chat conversation in a meeting .

    What we have tried is here:

    Hit to POST https://webpoolmaain102.infra.lync.com/ucwa/oauth/v1/applications/10241512914/communication/makeMeAvailable ( to add modalities like messaging)

    with body

    {
      "audioPreference" : "PhoneAudio",
      "phoneNumber" : "4255552222",
      "signInAs" : "BeRightBack",
      "supportedMessageFormats" : [
        "Plain",
        "Html"
      ],
      "supportedModalities" : [
        "PhoneAudio",
        "Messaging"
      ]
    }

    returns 204 No Content

    Hit to PUT https://webpoolmaain102.infra.lync.com/ucwa/oauth/v1/applications/10241512914/communication,  (where we are trying to enable a specific parameter "conversationHistory")

    returns :

    428 Precondition Required with If-Match header as 3fc81bb8-98f5-48b3-8981-d2fbd05305f. or 1529525322 (communications etag value)

    Response body in both base : {
      "code": "PreconditionRequired",
      "message": "Your request couldn't be completed."
    }

    here body of this PUT as below:

    {
      "simultaneousRingNumberMatch" : "Disabled",
      "videoBasedScreenSharing" : "Disabled",
      "rel" : "communication",
      "audioPreference" : "PhoneAudio",
      "conversationHistory" : "Enabled",
      "lisLocation" : "samplevalue",
      "lisQueryResult" : "Succeeded",
      "phoneNumber" : "tel : +14255524222",
      "publishEndpointLocation" : true,
      "supportedMessageFormats" : [
        "Plain",
        "Html"
      ],
      "supportedModalities" : [
        "PhoneAudio",
        "Messaging"
      ]
    }

    Header of this PUT is as below:


    If-Match:3fc81bb8-98f5-48b3-8981-d2fbd05305f
    Authorization:Bearer<token>

    Accept:application/json
    Content-Type:application/json
    Host:webpoolmaain102.infra.lync.com


    Here we have tried "If-Match" header with both : (1) "3fc81bb8-98f5-48b3-8981-d2fbd05305fc": (this value comes with text "please pass this in a PUT request") and (2)   "etag": "1529525322" . Both from "communication" section inside embedded of the application resources.

    So both ways to enable conversationHistory settings through communication resources is giving 428 issue which shoudl not come as we are passing "If-Match" header already.


    Can you pls suggest if we are doing something wrong here and how can we get "conversationLogTranscript" of a user's meetings.

    Thanks and Regards,

    Amit












    Saturday, May 13, 2017 7:26 PM

All replies

  • Hi Amit__Verma,

    Welcome to post in our forum.

    Regarding this issue, we suggest you post in Lync SDK forum, there are more experts will help you resolve this issue, thanks for your understanding and support.
    https://social.msdn.microsoft.com/Forums/en-US/home?category=SfB


    Regards,

    Alice Wang


    Please remember to mark the replies as an answers if they help and unmark them if they provide no help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    • Proposed as answer by Alice-Wang Monday, May 22, 2017 8:36 AM
    Monday, May 15, 2017 2:10 AM