none
Set Assigned Access for MS Edge on Windows 10 not possible. MS Edges AUMID problem. RRS feed

  • Question

  • Hello.

    My aim is to set up MS Edge with desired web app (machine HMI visualisation) with Assigned Acces. I am successful on my PC, but not on the other machine with different OS version.

    Here is successful procedure on PC machine with Windows 10 Pro, Version 1913, OS Biuld 18362.1016 and here is working all fine:

    1.  Create non-admin Local user  "Operator"for the kiosk.
    2. Log On as the new user and check if MS Edge Installed, find its AUMID (on successfull machine AUMID is  "Microsoft.MicrosoftEdge_8wekyb3d8bbwe!MicrosoftEdge")
    3. Log on as "Admin" and configure Assigned Access in PowerShell by means of: Set-AssignedAccess -UserName "Operator" -AppUserModelId "Microsoft.MicrosoftEdge_8wekyb3d8bbwe!MicrosoftEdge
    4. Restart
    5. Log On as "Admin"
    6. In Local Group Policy Editor set up Edge parameters for starting page and full screen mode.
    7. Log On As "Operator". MS Edge has been launched in Kiosk mode.

    My problem comes when I want to set up Assigned Access on HMI machine with Windows 10 Enterprise LTSC , Version 1809, OS Build 17763.1075. I fail in step 3. with Set-AssignedAcces from procedure above, since MS Edge AUMID I find in step 2. is different and thus not valid parameter for cmdlet. 

    My question is, why AUMID of MS Edge is different on the machine with different OS version, even it was installed successfully with MicrosoftEdgeSetup.exe?

    Many Thanks

    VVT




    Tuesday, September 22, 2020 11:42 AM