locked
Autopilot White Glove: "Registering your device for mobile management failed" RRS feed

  • Question

  • Hi,

    I am setting up a Pilot for Autopilot White Glove. The test machine is Panasonic Toughbook and regular Autopilot successfully provisions the device with following Intune management (Bitlocker, Windows Hello etc...). I created a new enrollment profile with the only one change - White Glove is on for OOBE. I can initiate the White Glove successfully (five times Windows key + select white Glove) but it sits in MDM enrollment state forever before timing out. At that point I do have either option to Reset the machine or try again (that fails the same way).

    If I switch it back to a regular Autopilot profile (without White Glove) it works again.

    OS is Windows 10 1903.

    I am wondering if anybody has a similar experience or have any suggestion how to overcome the issue?

    Regards,

    Alex


    Alex Ignatenko | MCSE | MCITP | MCTS:SCCM, Lync, Virtualization

    Friday, June 21, 2019 1:32 PM

Answers

  • it turned out that the registration failed due to:

    Autopilot discovery failed to find a valid MDM.  Confirm that the AAD tenant is properly provisioned and licensed for exactly one MDM.  HRESULT = 0x81036501

    Autopilot team advised me to remove "Microsoft Intune Enrollment" under MDM node in AAD, so only one entry - "Microsoft Intune" left there. I did and now the device enrolled successfully.

    I guess White Glove considered two entries as different MDMs.

    Thank you, Michael!

    Regards,

    Alex



    Alex Ignatenko | MCSE | MCITP | MCTS:SCCM, Lync, Virtualization

    • Marked as answer by Alenat Friday, June 21, 2019 6:07 PM
    Friday, June 21, 2019 6:07 PM

All replies

  • it turned out that the registration failed due to:

    Autopilot discovery failed to find a valid MDM.  Confirm that the AAD tenant is properly provisioned and licensed for exactly one MDM.  HRESULT = 0x81036501

    Autopilot team advised me to remove "Microsoft Intune Enrollment" under MDM node in AAD, so only one entry - "Microsoft Intune" left there. I did and now the device enrolled successfully.

    I guess White Glove considered two entries as different MDMs.

    Thank you, Michael!

    Regards,

    Alex



    Alex Ignatenko | MCSE | MCITP | MCTS:SCCM, Lync, Virtualization

    • Marked as answer by Alenat Friday, June 21, 2019 6:07 PM
    Friday, June 21, 2019 6:07 PM
  • Thanks a lot! It works!!!
    Monday, July 1, 2019 3:43 PM
  • Might be a little bit late but as a reference for others facing the same issue I've covered this within a blog post: https://tech.nicolonsky.ch/windows-autopilot-white-glove-error-0x81036501/
    Monday, August 19, 2019 11:35 AM
  • Interesting findings. I am also facing this exact issue with the same errors in event viewer. I do not however have this second MDM entry in AAD, so I am not sure what is the issue for me. If anyone has ideas I am all ears. Else I will have to open a ticket to Microsoft.
    Tuesday, September 3, 2019 12:30 PM
  • I'm also getting the same thing, seems to happen after it reboots during provisioning. It passes on the first attempt and gets stuck when it goes through the steps to carry on what it was doing before.

    <p>MCP, MCDST, MCTS x 6, MCITP x 3</p> <p>Please don't forget to mark this post as an answer if it is the solution to your problem!</p> <p>If you like trance music, please subscribe to my podcast <a href="http://feeds.feedburner.com/trancendanceuk"> Trancendance Podcast</a></p> <p><a href="https://www.mcpvirtualbusinesscard.com/VBCServer/trancendance/profile">View my MCP Certifications</a></p> <p><a href="http://www.twitter.com/brianjonesdj">Follow me on Twitter</p> </a>

    Tuesday, November 5, 2019 12:05 PM
  • has a solution been found? suffering this issue as well, however, we also have just one MDM entry in AAD (intune).

    otherwise same symptoms :/

    Tuesday, December 3, 2019 5:56 PM
  • For me, it was a time zone issue. I pressed shift f10 and used control /name Microsoft.windowsupdate to bring up the settings window, then checked the time and it was on the wrong time zone, so I corrected it and rebooted and it went straight through

    <p>MCP, MCDST, MCTS x 6, MCITP x 3</p> <p>Please don't forget to mark this post as an answer if it is the solution to your problem!</p> <p>If you like trance music, please subscribe to my podcast <a href="http://feeds.feedburner.com/trancendanceuk"> Trancendance Podcast</a></p> <p><a href="https://www.mcpvirtualbusinesscard.com/VBCServer/trancendance/profile">View my MCP Certifications</a></p> <p><a href="http://www.twitter.com/brianjonesdj">Follow me on Twitter</p> </a>

    Tuesday, December 3, 2019 6:32 PM