Hyper-V Restore Failure RRS feed

  • Question

  • Hi,

    I accidentally messed up a Hyper-V client so ended up restoring it via my DPM 2019. The restore seemed to go ok except it wont start.

    When it boots I get an error SCSI Disk 0,0.. The boot loader did not load an operating system.

    Its set to secure boot, not TPM.

    I've restored loads of these before without an issue.. not sure why this one won't start.

    I've tried, disabling secure boot, restoring to a dffierent Host, restoring an older backup and even wanted to try and repair using a DVD but even that wont start.

    Thursday, October 31, 2019 11:12 PM

All replies

  • Hi,

    I noticed you also posted the similar question over at Spiceworks:

    You mention you run "DPM 1809", but there exists no version of DPM like that, unless you mean something else that I don't understand, could you tell me the build version of your DPM?

    What generation is the Hyper-V virtual machine in question running?

    Best regards,

    Blog: LinkedIn:

    Thursday, October 31, 2019 11:25 PM
  • It's DPM 2019 and gen 2. I've tried creating a new host on gen 1 and attaching the vhdx but that fails too. 
    Thursday, October 31, 2019 11:45 PM
  • Does this happen to all Hyper-V virtual machines?

    Could you show the virtual machine settings?

    Blog: LinkedIn:

    Thursday, October 31, 2019 11:47 PM
  • Hi, I haven't tried restoring any others just yet as I am worried they all might be corrupt.

    The settings are pretty standard,  secure boot ticked and Tpm unticked. 

    Friday, November 1, 2019 6:49 AM
  • Does the virtual machine have any snapshots or mounted ISOs?

    How does it look like under the Firmware tab of the virtual machine?

    If there's a bootmgfw.efi, make sure it's on the top of the boot order list, if there isn't one then make sure the VHDX which contains the C-drive is on the top.

    Blog: LinkedIn:

    Friday, November 1, 2019 8:21 AM
  • No snapshots or mounted ISOs. I've tried changing the HD to top also.

    Friday, November 1, 2019 9:19 AM
  • And you also tried with both Generation 1 and Generation 2 VMs by creating a new manually and attaching the VHDX files to them?

    If that also didn't work, it sounds like corrupted backups..

    You could also use the Test-VHD PowerShell cmdlet to test the virtual hard disk for any problems that would make it unusable.

    Blog: LinkedIn:

    Friday, November 1, 2019 9:22 AM
  • The test-vhd just comes back as true.

    I've tried 2 backups.. I'll try to go back another week and see how I go.

    I'm slightly worried DPM is corrupting my backups.

    Friday, November 1, 2019 9:34 AM
  • Let us know how it goes, you do have two possibilities here, either use host-level backup or guest-level backups.

    It's really important to test the backups, this should preferably be a procedure done each month to make sure the backups are valid, of course you cannot test all backups because that would be time consuming, but let's say one host-level and one guest-level backup at least.

    Blog: LinkedIn:

    Friday, November 1, 2019 9:39 AM
  • I've tried an even older recovery which also failed. I'll try a different VM and see what happens to that.

    Friday, November 1, 2019 3:47 PM
  • I experienced this a few weeks ago with DPM version 1807 running on a physical server. We had restored the VHXD files for our domain controllers to another server and the VMs would not start up afterwards. The VHXD files were probably a few weeks old but when I restored from the most recent backup that we had, those worked without any rhyme or reason. 
    Tuesday, November 5, 2019 5:08 PM
  • Hi,

    Just checking to see if you have any update on your issue?

    If your issue was resolved, may I ask you to mark all the answers that helped you? This way it will also help others in the future who face the same challenge. Many thanks in advance!

    Best regards,

    Blog: LinkedIn:

    Wednesday, December 11, 2019 9:38 PM