locked
Exchange 2010 SP2 U2 Event ID 4999 error RRS feed

  • Question

  • I'm seeing this error and I'm having a hard time trying to figure out how to fix.  Can anyone assist?

    Log Name:      Application
    Source:        MSExchange Common
    Date:          6/2/2012 3:36:00 PM
    Event ID:      4999
    Task Category: General
    Level:         Error
    Keywords:      Classic
    User:          N/A
    Computer:      mail01.domain.com
    Description:
    Watson report about to be sent for process id: 5824, with parameters: E12, c-RTL-AMD64, 14.02.0297.000, WS, M.Exchange.StoreProvider, M.M.MapiMessage.CreateAttach, M.E.D.Storage.AccessDeniedException-27121, ffcb-5111, 14.02.0298.002.
    ErrorReportingEnabled: True
    Event Xml:
    <Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
      <System>
        <Provider Name="MSExchange Common" />
        <EventID Qualifiers="16388">4999</EventID>
        <Level>2</Level>
        <Task>1</Task>
        <Keywords>0x80000000000000</Keywords>
        <TimeCreated SystemTime="2012-06-02T22:36:00.000000000Z" />
        <EventRecordID>521183</EventRecordID>
        <Channel>Application</Channel>
        <Computer>mail01.domain.com</Computer>
        <Security />
      </System>
      <EventData>
        <Data>5824</Data>
        <Data>E12</Data>
        <Data>c-RTL-AMD64</Data>
        <Data>14.02.0297.000</Data>
        <Data>WS</Data>
        <Data>M.Exchange.StoreProvider</Data>
        <Data>M.M.MapiMessage.CreateAttach</Data>
        <Data>M.E.D.Storage.AccessDeniedException-27121</Data>
        <Data>ffcb-5111</Data>
        <Data>14.02.0298.002</Data>
        <Data>True</Data>
        <Data>
        </Data>
      </EventData>
    </Event>

    Saturday, June 2, 2012 11:45 PM

Answers

All replies

  • Hi Kanien,

    When did the error event appear first time? After you installed SP2 RU2?

    Is there any other error event in the Event Viewer?

    Since the RU3 have been released, it is a best practice to install it on all Exchange server roles first.

    Description of Update Rollup 3 for Exchange Server 2010 Service Pack 2

    http://support.microsoft.com/kb/2685289

    Please remember to mark the replies as answers if they help and unmark them if they provide no help. If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.


    Frank Wang

    TechNet Community Support

    Monday, June 4, 2012 9:01 AM
  • Frank,

    Thank you for responding.  I installed RU2 last week and I am uncertain if the event was before the RU.  Using Windows Update I was unable to get RU3 as it was not an option for install.  I went and manually downloaded RU3 and the install failed, but I could not figure out why.  This is why I'm on Exchange 2010 SP2 RU2.

    I do not see any other relevant error in the logs, but I will continue looking.  How can I tell why RU3 failed installation?  It visibly said, "rolling back changes, failed to install" or something similar, but nothing was in the Application Logs.

    Thanks!

    Monday, June 4, 2012 6:45 PM
  • Hi Kanien,

    Please install RU3 via Command-Line Options with Verbose MSI Logging enabled, e.g.

    Exchange2010-KB2685289-x64-en.msp /lxv* c:\SP2RU3.log

    For more information, please see:

    Troubleshooting Update Rollup Installations

    http://technet.microsoft.com/en-us/library/ff772434(v=exchg.80).aspx

    By the way, please install SP and Rollup for Exchange Server manually rather than by Microsoft update.


    Frank Wang

    TechNet Community Support

    Tuesday, June 5, 2012 3:18 AM
  • We have a client that is experiencing a similar issue. Our client has been having trouble with the  hub-transport crashing due to TLS errors, this is the error in the application log.

    Event ID: 4999, MSExchange Common
    Watson report about to be sent for process id: 9264, with parameters: E12, c-buddy-RTL-AMD64, 14.02.0297.000, AutoDisc, M.Exchange.Autodiscover, M.E.A.W.LegacyErrorHandler.HandleError, S.S.Diagnostics.CallbackException, 7eb3, 14.02.0298.004.
    ErrorReportingEnabled: False


    Wednesday, June 6, 2012 9:09 PM
  • Hi IPP-JB,

    The Watson error is different with OP's, "AutoDisc, M.Exchange.Autodiscover".

    I would suggest you open a new case about your question.

    Kanien, any updates?


    Frank Wang

    TechNet Community Support

    Thursday, June 7, 2012 6:46 AM
  • Hey Frank,

    I updated both exchange servers to RU3.  I still see this event in the logs:Log Name:      Application
    Source:        MSExchange Common
    Date:          6/7/2012 12:03:35 AM
    Event ID:      4999
    Task Category: General
    Level:         Error
    Keywords:      Classic
    User:          N/A
    Computer:      mail01.domain.com
    Description:
    Watson report about to be sent for process id: 4284, with parameters: E12, c-RTL-AMD64, 14.02.0297.000, WS, M.Exchange.StoreProvider, M.M.MapiMessage.CreateAttach, M.E.D.Storage.AccessDeniedException-27121, ffcb-5111, 14.02.0309.000.
    ErrorReportingEnabled: True
    Event Xml:
    <Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
      <System>
        <Provider Name="MSExchange Common" />
        <EventID Qualifiers="16388">4999</EventID>
        <Level>2</Level>
        <Task>1</Task>
        <Keywords>0x80000000000000</Keywords>
        <TimeCreated SystemTime="2012-06-07T07:03:35.000000000Z" />
        <EventRecordID>527665</EventRecordID>
        <Channel>Application</Channel>
        <Computer>mail01.domain.com</Computer>
        <Security />
      </System>
      <EventData>
        <Data>4284</Data>
        <Data>E12</Data>
        <Data>c-RTL-AMD64</Data>
        <Data>14.02.0297.000</Data>
        <Data>WS</Data>
        <Data>M.Exchange.StoreProvider</Data>
        <Data>M.M.MapiMessage.CreateAttach</Data>
        <Data>M.E.D.Storage.AccessDeniedException-27121</Data>
        <Data>ffcb-5111</Data>
        <Data>14.02.0309.000</Data>
        <Data>True</Data>
        <Data>
        </Data>
      </EventData>
    </Event>

    Thursday, June 7, 2012 7:29 AM
  • Hey Frank,

    After installing RU3 I saw that error upon reboot.  I don't know the cause or how to resolve it.

    Thursday, June 7, 2012 7:40 PM
  • HI Kanien,

    One partner found the issue was related the bad Outlook cached connection.

    2010SP2 RU1 : CAS Server 4999. MSExchange Common: M.M.MapiMessage.CreateAttach, M.E.D.Storage.AccessDeniedException

    http://social.technet.microsoft.com/Forums/sr/exchange2010/thread/de4c9eb2-bd59-4d9a-8606-840de754f550

    You can try to install NetMon to monitor the connection.


    Frank Wang

    TechNet Community Support

    • Marked as answer by Kanien Friday, June 8, 2012 2:55 AM
    Friday, June 8, 2012 2:01 AM